[PATCH] Fixed missing files in org-roam 2.1.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Adolfo De Unánue
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
Adolfo De Unánue
Severity
normal
A
A
Adolfo De Unánue wrote on 2 Sep 2021 08:28
(address . guix-patches@gnu.org)
877dfzebfd.fsf@unanue.mx
From d601aa318aa03255d23b82cd94a5080889636a47 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?= <adolfo+git@unanue.mx>
Date: Thu, 2 Sep 2021 00:53:32 -0500
Subject: [PATCH] fixed missing files in org-roam

---
gnu/packages/emacs-xyz.scm | 36 +++++++++++++++++++++++-------------
1 file changed, 23 insertions(+), 13 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c106e81fa5..e712892e34 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -102,6 +102,7 @@
;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28239,6 +28240,15 @@ snippets for Emacs.")
(let ((out (assoc-ref outputs "out")))
(install-file "doc/images/org-ref-citelink.png"
(string-append out "/share/info/images")))))
+ (add-after 'install 'install-extensions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "extensions"
+ (string-append (assoc-ref outputs "out")
+ (string-append
+ "/share/emacs/site-lisp/org-roam-"
+ ,version)))
+ #t))
(add-after 'install-image 'make-info
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -28246,23 +28256,23 @@ snippets for Emacs.")
(invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
(install-file "org-roam.info"
(string-append out "/share/info")))))))))
- (native-inputs
- `(("texinfo" ,texinfo)))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
- ("emacs-f" ,emacs-f)
- ("emacs-magit" ,emacs-magit)
- ("emacs-org" ,emacs-org)
- ("emacs-s" ,emacs-s)))
- (home-page "https://github.com/org-roam/org-roam/")
- (synopsis "Non-hierarchical note-taking with Org mode")
- (description "Emacs Org Roam is a solution for taking non-hierarchical
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
+ ("emacs-f" ,emacs-f)
+ ("emacs-magit" ,emacs-magit)
+ ("emacs-org" ,emacs-org)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/org-roam/org-roam/")
+ (synopsis "Non-hierarchical note-taking with Org mode")
+ (description "Emacs Org Roam is a solution for taking non-hierarchical
notes with Org mode. Notes are captured without hierarchy and are connected
by tags. Notes can be found and created quickly. Org Roam should also work
as a plug-and-play solution for anyone already using Org mode for their
personal wiki.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public emacs-org-roam-bibtex
(package
--
2.33.0
--
- A
A
A
Z
Z
zimoun wrote on 14 Sep 2021 14:26
(name . Adolfo De Unánue)(address . adolfo@unanue.mx)(address . 50333@debbugs.gnu.org)
86ilz3tkai.fsf@gmail.com
Hi,

You are asking in http://issues.guix.gnu.org/issue/50374 about this
one. Well, I am not an expert and I am not an Emacs Roam user.

On Thu, 02 Sep 2021 at 22:57, Adolfo De Unánue <adolfo@unanue.mx> wrote:

Toggle quote (5 lines)
>>From a99fa75c0f5d3025827d99c3ef6a2c71c85e0be5 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?= <adolfo+git@unanue.mx>
> Date: Thu, 2 Sep 2021 22:23:58 -0500
> Subject: [PATCH] Fixed missing files in org-roam v2.1.0

The commit message should be:

Toggle snippet (6 lines)
gnu: emacs-org-roam: Adding extensions.

* guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to install
extensions.

Or something along these lines.

Toggle quote (14 lines)
> ---
> gnu/packages/emacs-xyz.scm | 94 +++++++++++++++++++++-----------------
> 1 file changed, 53 insertions(+), 41 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 030809f5ac..431444c255 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -103,6 +103,7 @@
> ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
> ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
> ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
> +;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>

Since you submit with this name “Adolfo De Unánue“, the Copyright should
be the same instead of a nick name. From my point of view, nickname as
copyright holder should be avoided; if possible, obviously. :-)

Toggle quote (2 lines)
> + (let ((commit "f819720c510185af713522c592833ec9f2934251")

Usually, the package uses tagged version instead of random commit. When
it is not possible because upstream do not tag, it seems good to provide
an explanation why the lasted tagged version cannot be used;
explanations as a comment or in the cover letter.

Another reason is because for instance it changes all the indentation
and makes ‘git log/blame’ harder to investigate.

Toggle quote (10 lines)
> + (add-after 'install 'install-extensions
> + (lambda* (#:key outputs #:allow-other-keys)
> + (copy-recursively
> + "extensions"
> + (string-append (assoc-ref outputs "out")
> + (string-append
> + "/share/emacs/site-lisp/org-roam-"
> + ,version)))
> + #t))

Patch#50333 will install the extensions with “guix install
emacs-org-roam”. Instead the attempt of patch#50374 is to install with
“guix install emacs-org-roam-extensions”. Well, I do not know if
patch#50374 is correct, though.

Because I am not an Org-Roam user, I do not have an opinion about this
extensions. Maybe it is better to distribute them along the package
emacs-org-roam or in a separate package, I do not know. WDYT?

All the best,
simon
A
A
Adolfo De Unánue wrote on 15 Sep 2021 00:10
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 50333@debbugs.gnu.org)
87o88ureh9.fsf@unanue.mx
Thank you for your comments and advices.



zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (31 lines)
> Hi,
>
> You are asking in <http://issues.guix.gnu.org/issue/50374> about
> this
> one. Well, I am not an expert and I am not an Emacs Roam user.
>
> On Thu, 02 Sep 2021 at 22:57, Adolfo De Unánue
> <adolfo@unanue.mx> wrote:
>
>>>From a99fa75c0f5d3025827d99c3ef6a2c71c85e0be5 Mon Sep 17
>>>00:00:00 2001
>> From: =?UTF-8?q?Adolfo=20De=20Un=C3=A1nue?=
>> <adolfo+git@unanue.mx>
>> Date: Thu, 2 Sep 2021 22:23:58 -0500
>> Subject: [PATCH] Fixed missing files in org-roam v2.1.0
>
> The commit message should be:
>
> --8<---------------cut
> here---------------start------------->8---
> gnu: emacs-org-roam: Adding extensions.
>
> * guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to
> install
> extensions.
> --8<---------------cut
> here---------------end--------------->8---
>
> Or something along these lines.
>

Should I apply your suggested changes, commit them, use this
commit
message, create the patch and send them again?

Toggle quote (22 lines)
>> ---
>> gnu/packages/emacs-xyz.scm | 94
>> +++++++++++++++++++++-----------------
>> 1 file changed, 53 insertions(+), 41 deletions(-)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm
>> b/gnu/packages/emacs-xyz.scm
>> index 030809f5ac..431444c255 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -103,6 +103,7 @@
>> ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
>> ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
>> ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
>> +;;; Copyright © 2021 Nanounanue <adolfo@unanue.mx>
>
> Since you submit with this name “Adolfo De Unánue“, the
> Copyright should
> be the same instead of a nick name. From my point of view,
> nickname as
> copyright holder should be avoided; if possible, obviously. :-)

I will do, makes complete sense


Toggle quote (11 lines)
>
>> + (let ((commit "f819720c510185af713522c592833ec9f2934251")
>
> Usually, the package uses tagged version instead of random
> commit. When
> it is not possible because upstream do not tag, it seems good to
> provide
> an explanation why the lasted tagged version cannot be used;
> explanations as a comment or in the cover letter.
>

As you guessed, org-roam has not tagged this new (breaking)
change,
that's why I am using the commit



Toggle quote (28 lines)
> Another reason is because for instance it changes all the
> indentation
> and makes ‘git log/blame’ harder to investigate.
>
>> + (add-after 'install 'install-extensions
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (copy-recursively
>> + "extensions"
>> + (string-append (assoc-ref outputs "out")
>> + (string-append
>> + "/share/emacs/site-lisp/org-roam-"
>> + ,version)))
>> + #t))
>
> Patch#50333 will install the extensions with “guix install
> emacs-org-roam”. Instead the attempt of patch#50374 is to
> install with
> “guix install emacs-org-roam-extensions”. Well, I do not know
> if
> patch#50374 is correct, though.
>
> Because I am not an Org-Roam user, I do not have an opinion
> about this
> extensions. Maybe it is better to distribute them along the
> package
> emacs-org-roam or in a separate package, I do not know. WDYT?
>

I mean, structurally the upstream owner just moved some files to a
new
folder, my guess is that it shouldn't be a different packages
since it
is still part of org-roam.


Toggle quote (4 lines)
> All the best,
> simon


Again thank you, it was super helpful!

--
- A
Z
Z
zimoun wrote on 15 Sep 2021 07:03
(name . Adolfo De Unánue)(address . adolfo@unanue.mx)(address . 50333@debbugs.gnu.org)
8635q6e8gg.fsf@gmail.com
Hi,

On Tue, 14 Sep 2021 at 17:10, Adolfo De Unánue <adolfo@unanue.mx> wrote:
Toggle quote (20 lines)
> zimoun <zimon.toutoune@gmail.com> writes:

>>> Subject: [PATCH] Fixed missing files in org-roam v2.1.0
>>
>> The commit message should be:
>>
>> --8<---------------cut here---------------start------------->8---
>> gnu: emacs-org-roam: Adding extensions.
>>
>> * guix/emacs-xyz.scm (emacs-org-roam)[arguments]: Add phases to
>> install
>> extensions.
>> --8<---------------cut here---------------end--------------->8---
>>
>> Or something along these lines.
>
> Should I apply your suggested changes, commit them, use this
> commit
> message, create the patch and send them again?

Yeah, you can address and send then an updated patch. Doing so, please
increment the re-roll count which eases to know that patch is the last.

For instance, the ones you sent looks like:

Toggle snippet (5 lines)
[ Adolfo De Unánue ] [bug#50333] [PATCH] Fixed missing files in org-roam 2.1.0
[ Adolfo De Unánue ]
[ Adolfo De Unánue ]

and the reviewer has to open all 3 to know what happens. Compare with
for instance:

Toggle snippet (12 lines)
[ Marius Bakke ] [bug#50377] [PATCH 0/2] Support 'git describe' …
[ Marius Bakke ] [bug#50377] [PATCH 1/2] git: 'resolve-refer …
[ Marius Bakke ] [bug#50377] [PATCH 2/2] transformations …
[ Marius Bakke ] [bug#50377] [PATCH v2 1/2] git: 'resolv …
[ Marius Bakke ] [bug#50377] [PATCH v3 0/2] Support 'git des …
[ Marius Bakke ] [bug#50377] [PATCH v3 1/2] git: 'resolv …
[ Ludovic Courtès ] [bug#50377] [PATCH 0/2] Support …
[ Marius Bakke ] [bug#50377] [PATCH v3 2/2] transformati …
[ Ludovic Courtès ] [bug#50377] [PATCH 0/2] Support …
[ Xinglu Chen ] [bug#50377] [PATCH v3 0/2] Support 'git …

Well, I suggest you to use “git format-patch -v4”. :-)


Toggle quote (14 lines)
>>> + (let ((commit "f819720c510185af713522c592833ec9f2934251")
>>
>> Usually, the package uses tagged version instead of random
>> commit. When
>> it is not possible because upstream do not tag, it seems good to
>> provide
>> an explanation why the lasted tagged version cannot be used;
>> explanations as a comment or in the cover letter.
>>
>
> As you guessed, org-roam has not tagged this new (breaking)
> change,
> that's why I am using the commit

Yeah, but is it released? Or simply the development version? If it is
the development version, usually it is on per user basis, i.e., you can
use a package transformation. Inclusion of releases is preferred.

Toggle quote (29 lines)
>>> + (add-after 'install 'install-extensions
>>> + (lambda* (#:key outputs #:allow-other-keys)
>>> + (copy-recursively
>>> + "extensions"
>>> + (string-append (assoc-ref outputs "out")
>>> + (string-append
>>> + "/share/emacs/site-lisp/org-roam-"
>>> + ,version)))
>>> + #t))
>>
>> Patch#50333 will install the extensions with “guix install
>> emacs-org-roam”. Instead the attempt of patch#50374 is to
>> install with
>> “guix install emacs-org-roam-extensions”. Well, I do not know
>> if
>> patch#50374 is correct, though.
>>
>> Because I am not an Org-Roam user, I do not have an opinion
>> about this
>> extensions. Maybe it is better to distribute them along the
>> package
>> emacs-org-roam or in a separate package, I do not know. WDYT?
>
> I mean, structurally the upstream owner just moved some files to a
> new
> folder, my guess is that it shouldn't be a different packages
> since it
> is still part of org-roam.

Note that some packages are only one upstream source but indeed
different packages. For instance, notmuch and emacs-notmuch (for the
most recent :-)). Another example, IIRC, some time ago, Org-contrib was
a folder under Org but distributed by 2 packages. Well, it is sometime
the same package and simply that upstream reorganize stuff. :-)

BTW, why is it needed to explicitly copy the “extensions” files?
Without this added phase, does it not work?

All the best,
simon
A
A
Adolfo De Unánue wrote on 25 Sep 2021 08:16
[PATCH v4] gnu: emacs-org-roam: Adding extensions.
(address . 50333@debbugs.gnu.org)
87lf3l9nul.fsf@unanue.mx
Following suggestions from zimoun <zimon.toutoune@gmail.com>, I
cleaned
my git commit history, use my name instead of my nickname in the
copyright and fixed the subject so is easier to follow.
--
- A
N
N
Nicolas Goaziou wrote on 17 Jan 2022 00:30
(name . Adolfo De Unánue)(address . adolfo@unanue.mx)(address . 50333-done@debbugs.gnu.org)
874k63i7h4.fsf@nicolasgoaziou.fr
Hello,

Adolfo De Unánue <adolfo@unanue.mx> writes:

Toggle quote (2 lines)
> Subject: [PATCH v4] gnu: emacs-org-roam: Adding extensions.

Thank you for the patch.

However, extensions for Org Roam are installed since bug#50287.

Therefore, I'm closing this bug report. Feel free to re-open it if you
think something is missing.

Regards,
--
Nicolas Goaziou
Closed
?