[PATCH 0/1] Add org-roam-extensions package

  • Done
  • quality assurance status badge
Details
4 participants
  • Adolfo De Unánue
  • Collin J. Doering
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
Collin J. Doering
Severity
normal
C
C
C
Collin J. Doering wrote on 4 Sep 2021 18:19
[PATCH 1/1] gnu: Add emacs-org-roam-extensions
(address . 50374@debbugs.gnu.org)
87y28c8g8o.fsf@rekahsoft.ca
---
gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f04a0225b3..830c642492 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28264,6 +28264,25 @@ as a plug-and-play solution for anyone already using Org mode for their
personal wiki.")
(license license:gpl3+)))
+(define-public emacs-org-roam-extensions
+ (package
+ (inherit emacs-org-roam)
+ (name "emacs-org-roam-extensions")
+ (propagated-inputs
+ `(,@(package-propagated-inputs emacs-org-roam)
+ ("emacs-org-roam" ,emacs-org-roam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-subdirectory
+ (lambda _ (chdir "extensions") #t))
+ (add-before 'install-license-files 'leave-subdirectory
+ (lambda _ (chdir "..") #t)))))
+ (synopsis "Extensions for Org-Roam")
+ (description "Emacs Org Roam Extensions include utilities for daily note
+taking, the org-roam protocol, graphing note relationships and providing id link
+overlays.")))
+
(define-public emacs-org-roam-bibtex
(package
(name "emacs-org-roam-bibtex")
--
2.33.0


--
Collin J. Doering

http://rekahsoft.ca
http://blog.rekahsoft.ca
http://git.rekahsoft.ca
A
A
Adolfo De Unánue wrote on 12 Sep 2021 18:19
(no subject)
(address . 50374@debbugs.gnu.org)
875yv5sr0z.fsf@unanue.mx
Hi

I am the author of the patch https://issues.guix.gnu.org/50333(my
first
patch, so I am a newbie on this).

Could you help me to understand why your proposal is a better
solution?
I want to learn how to approach to this matters in the future.

My rationale is that the extensions folder *is* part of org-roam,
that's
why I *added* them to the original package.

Also, Do we need to do something in order to get this patch (or
mine)
approved?
(again, just asking because this workflow is new for me)

Thanks in advance for your time

--
- A
Z
Z
zimoun wrote on 14 Sep 2021 14:30
Re: [bug#50374] [PATCH 0/1] Add org-roam-extensions package
(name . Collin J. Doering)(address . collin@rekahsoft.ca)(address . 50374@debbugs.gnu.org)
86fsu7tk4v.fsf@gmail.com
Hi,

On Sat, 04 Sep 2021 at 12:12, "Collin J. Doering" <collin@rekahsoft.ca> wrote:
Toggle quote (4 lines)
> Instead of the implementation put forth in
> https://issues.guix.gnu.org/50333 this change includes org-roam
> extensions as a separate package.

Naive question, why should the extensions be distributed as a separate
package? Well, I am not an Org-Roam user… having the extensions along
with the package emacs-org-roam seem the best; other said, why an
Org-Roam user would be annoyed to have these extensions and not use
them?

All the best,
simon
C
C
Collin J. Doering wrote on 16 Sep 2021 15:38
Re: [bug#50374] (no subject)
(name . Adolfo De Unánue)(address . adolfo@unanue.mx)
871r5ohbxj.fsf@rekahsoft.ca
Hi Adolfo,

I am not a guix expert either and am relatively new to the project. I
actually asked about this topic on guix IRC, where folks there suggested
splitting it into another package. I see very little difference between
including the org-roam-extensions as a separate package output, or as a
standalone package. I feel that having it as an additional output is
more "pure", but found that many packages already use a standalone
package for extensions, and I found that doing it in this way made both
packages themselves easier to define. You can see this for yourself with
a query like this `guix package -s '.*-extensions$' | recsel -CP name`.

Hope this helps, and kind regards!

On 12 Sep 2021 at 11:19, Adolfo De Unánue <adolfo@unanue.mx> wrote:

Toggle quote (18 lines)
> Hi
>
> I am the author of the patch https://issues.guix.gnu.org/50333 (my first
> patch, so I am a newbie on this).
>
> Could you help me to understand why your proposal is a better solution?
> I want to learn how to approach to this matters in the future.
>
> My rationale is that the extensions folder *is* part of org-roam, that's
> why I *added* them to the original package.
>
> Also, Do we need to do something in order to get this patch (or mine)
> approved?
> (again, just asking because this workflow is new for me)
>
> Thanks in advance for your time


C
C
Collin J. Doering wrote on 16 Sep 2021 15:48
Re: [bug#50374] [PATCH 0/1] Add org-roam-extensions package
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 50374@debbugs.gnu.org)
87wnngfwv9.fsf@rekahsoft.ca
Hi Zimoun,

Thanks for taking the time to look at this patch.

On 14 Sep 2021 at 14:30, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (10 lines)
> Hi,
>
> On Sat, 04 Sep 2021 at 12:12, "Collin J. Doering" <collin@rekahsoft.ca> wrote:
>> Instead of the implementation put forth in
>> https://issues.guix.gnu.org/50333 this change includes org-roam
>> extensions as a separate package.
>
> Naive question, why should the extensions be distributed as a separate
> package?

They are not required for the use of org-roam. They could also be
distributed as an additional output on the org-roam package itself.
Happy to re-adjust if that's preferred.

Toggle quote (4 lines)
> Well, I am not an Org-Roam user… having the extensions along with the
> package emacs-org-roam seem the best; other said, why an Org-Roam user
> would be annoyed to have these extensions and not use them?

I don't think they need to be included directly in the main output of
the emacs-org-roam package as not all org-roam users will leverage them.
However I can't think of any reasons why a org-roam user would be
annoyed that they are included (other then including software that is
not used, which is not necessarily favorable).

Please let me know your preference between the following:

1. org-roam extensions as part of a separate package (this is what is
already presented in this patch set).
2. Extensions as a separate `extensions` output on the emacs-org-roam package
3. Build the extensions directly into the primary output of the
emacs-org-roam package (this is already done in https://issues.guix.gnu.org/50333)

Toggle quote (2 lines)
> All the best,

N
N
Nicolas Goaziou wrote on 17 Jan 2022 00:31
(name . Collin J. Doering)(address . collin@rekahsoft.ca)(address . 50374-done@debbugs.gnu.org)
87zgnvgsvn.fsf@nicolasgoaziou.fr
Hello,

"Collin J. Doering" <collin@rekahsoft.ca> writes:

Toggle quote (4 lines)
> Instead of the implementation put forth in
> https://issues.guix.gnu.org/50333 this change includes org-roam
> extensions as a separate package.

Thank you for the patch.

However, extensions for Org Roam are installed since bug#50287.

Therefore, I'm closing this bug report. Feel free to re-open it if you
think something is missing.

Regards,
--
Nicolas Goaziou
Closed
?