[PATCH 1/5] gnu: go-github-com-muesli-reflow-wordwrap: Update to 0.2.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
Merged with
S
S
Stefan Reichör wrote on 11 May 2021 20:55
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210511185554.67355-1-stefan@xsteve.at
* gnu/packages/golang.scm (go-github-com-muesli-reflow-wordwrap): Update to 0.2.0.
---
gnu/packages/golang.scm | 47 ++++++++++++++++++++++-------------------
1 file changed, 25 insertions(+), 22 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8c3c81ceda..718794934e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5621,29 +5622,31 @@ transforms one JSON document into another through a JMESPath expression.")
(license license:bsd-3)))
(define-public go-github-com-muesli-reflow-wordwrap
- (package
- (name "go-github-com-muesli-reflow-wordwrap")
- (version "0.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/muesli/reflow")
- (commit (string-append "v" version))))
- (file-name (git-file-name "go-github-com-muesli-reflow" version))
- (sha256
- (base32
- "1vhynm2n1az13fn03lp0gi28p9mznq1mblglh8f2rb9y1vkd2dqr"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/muesli/reflow/wordwrap"
- #:unpack-path "github.com/muesli/reflow"))
- (native-inputs
- `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)))
- (home-page "https://github.com/muesli/reflow/")
- (synopsis "Collection of methods helping to transform blocks of text")
- (description "This package provides a collection of ANSI-aware methods and
+ (let ((commit "c80126ec2ad5d2c5210b2eefe1b33aaaca2fdeb8")
+ (revision "1"))
+ (package
+ (name "go-github-com-muesli-reflow-wordwrap")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/reflow")
+ (commit commit)))
+ (file-name (git-file-name "go-github-com-muesli-reflow" version))
+ (sha256
+ (base32
+ "049yzl3k4s0hn6ywh57qqivx8aqz3cfqpv8z9gk9jvf9kvwaa3zf"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/muesli/reflow/wordwrap"
+ #:unpack-path "github.com/muesli/reflow"))
+ (native-inputs
+ `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)))
+ (home-page "https://github.com/muesli/reflow/")
+ (synopsis "Collection of methods helping to transform blocks of text")
+ (description "This package provides a collection of ANSI-aware methods and
io.Writers helping you to transform blocks of text.")
- (license license:expat)))
+ (license license:expat))))
(define-public go-github-com-muesli-reflow-ansi
(package
--
2.25.1
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:08
control message for bug #48369
(address . control@debbugs.gnu.org)
86tuk1g528.fsf@mgsn.dev
merge 48369 48364 48363 48362 48361 48360
quit
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:44
(address . control@debbugs.gnu.org)
86sfzlg3ee.fsf@mgsn.dev
unmerge 48369
quit
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:54
control message for bug #48364
(address . control@debbugs.gnu.org)
E1mCGDc-0000p4-4T@debbugs.gnu.org
merge 48364 48362 48360 48361 48363
quit
?