[PATCH 4/5] gnu: Add go-github-com-charmbracelet-bubbletea.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
Merged with
S
S
Stefan Reichör wrote on 11 May 2021 20:55
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210511185554.67355-4-stefan@xsteve.at
* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): New variable.
---
gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 77abde2575..a9f299be98 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5865,6 +5865,40 @@ use one of our glamorous default themes.")
dependencies and a simple API.")
(license license:asl2.0)))
+(define-public go-github-com-charmbracelet-bubbletea
+ (package
+ (name "go-github-com-charmbracelet-bubbletea")
+ (version "0.13.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charmbracelet/bubbletea")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github-com-containerd-console" ,go-github-com-containerd-console)
+ ("go-github-com-google-goterm" ,go-github-com-google-goterm)
+ ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
+ ("go-github-com-muesli-reflow-truncate" ,go-github-com-muesli-reflow-truncate)
+ ("go-github-com-muesli-termenv" ,go-github-com-muesli-termenv)
+ ("go-golang-org-colorful" ,go-golang-org-colorful)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+ (arguments
+ `(#:import-path "github.com/charmbracelet/bubbletea"))
+ (home-page "https://github.com/charmbracelet/bubbletea")
+ (synopsis "A powerful Go TUI framework")
+ (description "A Go framework to build terminal apps. Bubble Tea is
+well-suited for simple and complex terminal applications, either inline,
+full-window, or a mix of both.")
+ (license license:expat)))
+
(define-public go-github-com-coreos-go-semver
(package
(name "go-github-com-coreos-go-semver")
--
2.25.1
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:08
control message for bug #48369
(address . control@debbugs.gnu.org)
86tuk1g528.fsf@mgsn.dev
merge 48369 48364 48363 48362 48361 48360
quit
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:44
(address . control@debbugs.gnu.org)
86sfzlg3ee.fsf@mgsn.dev
unmerge 48369
quit
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:54
control message for bug #48364
(address . control@debbugs.gnu.org)
E1mCGDc-0000p4-4T@debbugs.gnu.org
merge 48364 48362 48360 48361 48363
quit
?