Toggle diff (455 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index a5820b5827..c5fdb8fc16 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -42,6 +42,7 @@
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
# Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
# Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2021 André Batista <nandre@riseup.net>
#
# This file is part of GNU Guix.
#
@@ -1739,6 +1740,8 @@ dist_patch_DATA = \
%D%/packages/patches/tipp10-qt5.patch \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/tla2tools-build-xml.patch \
+ %D%/packages/patches/torbrowser-start-desktop.patch \
+ %D%/packages/patches/torbrowser-start-script.patch \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
diff --git a/gnu/packages/patches/torbrowser-start-desktop.patch b/gnu/packages/patches/torbrowser-start-desktop.patch
new file mode 100644
index 0000000000..6832ed363b
--- /dev/null
+++ b/gnu/packages/patches/torbrowser-start-desktop.patch
@@ -0,0 +1,22 @@
+Change TorBrowser desktop file in order for it to be agnostic to the
+path when invoked.
+
+--- torbrowser-68.10.0esr-9.5-1/tbb-scripts/RelativeLink/start-tor-browser.desktop.orig 2020-07-05 18:47:40.689484877 -0300
++++ torbrowser-68.10.0esr-9.5-1/tbb-scripts/RelativeLink/start-tor-browser.desktop 2020-07-24 14:36:37.720579884 -0300
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env ./Browser/execdesktop
++#!/usr/bin/env bash
+ #
+ # This file is a self-modifying .desktop file that can be run from the shell.
+ # It preserves arguments and environment for the start-tor-browser script.
+@@ -28,7 +28,7 @@
+ GenericName=Web Browser
+ Comment=Tor Browser is +1 for privacy and −1 for mass surveillance
+ Categories=Network;WebBrowser;Security;
+-Exec=sh -c '"$(dirname "$*")"/Browser/start-tor-browser --detach || ([ ! -x "$(dirname "$*")"/Browser/start-tor-browser ] && "$(dirname "$*")"/start-tor-browser --detach)' dummy %k
+-X-TorBrowser-ExecShell=./Browser/start-tor-browser --detach
+-Icon=web-browser
++Exec=sh -c start-tor-browser
++X-TorBrowser-ExecShell=start-tor-browser --detach
++Icon=torbrowser
+ StartupWMClass=Tor Browser
diff --git a/gnu/packages/patches/torbrowser-start-script.patch b/gnu/packages/patches/torbrowser-start-script.patch
new file mode 100644
index 0000000000..b8c8d9a26a
--- /dev/null
+++ b/gnu/packages/patches/torbrowser-start-script.patch
@@ -0,0 +1,181 @@
+Change TorBrowser startup script in order for it to setup needed files
+outside guix store. Remove tests which are not needed on guix system.
+
+--- torbrowser-68.10.0esr-9.5-1/tbb-scripts/RelativeLink/start-tor-browser.orig 2020-07-05 18:47:40.685485004 -0300
++++ torbrowser-68.10.0esr-9.5-1/tbb-scripts/RelativeLink/start-tor-browser 2020-07-23 18:13:32.426282743 -0300
+@@ -5,6 +5,14 @@
+ #
+ # Copyright 2017 The Tor Project. See LICENSE for licensing information.
+
++TBB_HOME="${HOME}/.local/share/torbrowser"
++TBB_LOGFILE="${TBB_HOME}/torbrowser.log"
++TBB_DATA="${TBB_HOME}/Data"
++TBB_PROFILE="${TBB_DATA}/Browser/profile.default"
++TBB_STORE_PATH=$(dirname $(realpath "$0"))
++TBB_STORE_DATA="${TBB_STORE_PATH}/TorBrowser/Data"
++TORRC="${TBB_DATA}/Tor/torrc-defaults"
++
+ complain_dialog_title="Tor Browser"
+
+ # First, make sure DISPLAY is set. If it isn't, we're hosed; scream
+@@ -134,8 +142,8 @@
+ ;;
+ -l | --log)
+ if [ -z "$2" -o "${2:0:1}" == "-" ]; then
+- printf "Logging Tor Browser debug information to tor-browser.log\n"
+- logfile="../tor-browser.log"
++ printf "Logging Tor Browser debug information to torbrowser.log\n"
++ logfile="${TBB_LOGFILE}"
+ elif [ "${2:0:1}" == "/" -o "${2:0:1}" == "~" ]; then
+ printf "Logging Tor Browser debug information to %s\n" "$2"
+ logfile="$2"
+@@ -187,41 +195,22 @@
+ export XAUTHORITY
+ fi
+
+-# If this script is being run through a symlink, we need to know where
+-# in the filesystem the script itself is, not where the symlink is.
+-myname="$0"
+-if [ -L "$myname" ]; then
+- # XXX readlink is not POSIX, but is present in GNU coreutils
+- # and on FreeBSD. Unfortunately, the -f option (which follows
+- # a whole chain of symlinks until it reaches a non-symlink
+- # path name) is a GNUism, so we have to have a fallback for
+- # FreeBSD. Fortunately, FreeBSD has realpath instead;
+- # unfortunately, that's also non-POSIX and is not present in
+- # GNU coreutils.
+- #
+- # If this launcher were a C program, we could just use the
+- # realpath function, which *is* POSIX. Too bad POSIX didn't
+- # make that function accessible to shell scripts.
+-
+- # If realpath is available, use it; it Does The Right Thing.
+- possibly_my_real_name="`realpath "$myname" 2>/dev/null`"
+- if [ "$?" -eq 0 ]; then
+- myname="$possibly_my_real_name"
+- else
+- # realpath is not available; hopefully readlink -f works.
+- myname="`readlink -f "$myname" 2>/dev/null`"
+- if [ "$?" -ne 0 ]; then
+- # Ugh.
+- complain "start-tor-browser cannot be run using a symlink on this operating system."
+- fi
+- fi
++# Try to be agnostic to where we're being started from, check if files are on its
++# default paths and chdir to TBB_HOME
++if [ -e "${TORRC}" ]; then
++ cd "${TBB_HOME}"
++else
++ mkdir -p "${TBB_HOME}"
++ cp -R "${TBB_STORE_DATA}" "${TBB_HOME}"
++ chmod -R 700 "${TBB_HOME}"
++ mkdir -p "${TBB_PROFILE}"
++ echo "user_pref(\"extensions.torlauncher.torrc-defaults_path\", \"${TORRC}\");"\
++ > "${TBB_PROFILE}/user.js"
++ echo "ClientTransportPlugin meek_lite,obfs2,obfs3,obfs4,scramblesuit exec ${TBB_STORE_PATH}/TorBrowser/Tor/PluggableTransports/obfs4proxy"\
++ >> "${TORRC}"
++ cd "${TBB_HOME}"
+ fi
+
+-# Try to be agnostic to where we're being started from, chdir to where
+-# the script is.
+-mydir="`dirname "$myname"`"
+-test -d "$mydir" && cd "$mydir"
+-
+ # If ${PWD} results in a zero length string, we can try something else...
+ if [ ! "${PWD}" ]; then
+ # "hacking around some braindamage"
+@@ -236,16 +225,9 @@
+ ln -nsf ~/.config/ibus/bus .config/ibus
+ fi
+
+-# Fix up .desktop Icon and Exec Paths, and update the .desktop file from the
+-# canonical version if it was changed by the updater.
+-cp start-tor-browser.desktop ../
+-sed -i -e "s,^Name=.*,Name=Tor Browser,g" ../start-tor-browser.desktop
+-sed -i -e "s,^Icon=.*,Icon=$PWD/browser/chrome/icons/default/default128.png,g" ../start-tor-browser.desktop
+-sed -i -e "s,^Exec=.*,Exec=sh -c '\"$PWD/start-tor-browser\" --detach || ([ ! -x \"$PWD/start-tor-browser\" ] \&\& \"\$(dirname \"\$*\")\"/Browser/start-tor-browser --detach)' dummy %k,g" ../start-tor-browser.desktop
+-
+ if [ "$register_desktop_app" -eq 1 ]; then
+ mkdir -p "$HOME/.local/share/applications/"
+- cp ../start-tor-browser.desktop "$HOME/.local/share/applications/"
++ cp "${TBB_STORE_PATH}/start-tor-browser.desktop" "$HOME/.local/share/applications/"
+ update-desktop-database "$HOME/.local/share/applications/"
+ printf "Tor Browser has been registered as a desktop app for this user in ~/.local/share/applications/\n"
+ exit 0
+@@ -265,21 +247,6 @@
+ HOME="${PWD}"
+ export HOME
+
+-SYSARCHITECTURE=$(getconf LONG_BIT)
+-TORARCHITECTURE=$(expr "$(file TorBrowser/Tor/tor)" : '.*ELF \([[:digit:]]*\)')
+-
+-if [ $SYSARCHITECTURE -ne $TORARCHITECTURE ]; then
+- complain "Wrong architecture? 32-bit vs. 64-bit."
+- exit 1
+-fi
+-
+-[% IF c("var/asan") -%]
+-# We need to disable LSan which is enabled by default now. Otherwise we'll get
+-# a crash during shutdown: https://bugs.torproject.org/10599#comment:59
+-ASAN_OPTIONS="detect_leaks=0"
+-export ASAN_OPTIONS
+-[% END -%]
+-
+ function setControlPortPasswd() {
+ local ctrlPasswd=$1
+
+@@ -342,13 +309,15 @@
+ # your password in the following line where the word “secret” is:
+ setControlPortPasswd ${TOR_CONTROL_PASSWD:='"secret"'}
+
+-# Set up custom bundled fonts. See fonts-conf(5).
+-export FONTCONFIG_PATH="${HOME}/TorBrowser/Data/fontconfig"
+-export FONTCONFIG_FILE="fonts.conf"
+-
+ # Avoid overwriting user's dconf values. Fixes #27903.
+ export GSETTINGS_BACKEND=memory
+
++# Set up custom bundled fonts. See fonts-conf(5).
++export FONTCONFIG_FILE="${HOME}/Data/fontconfig/fonts.conf"
++
++sed -i "${FONTCONFIG_FILE}"\
++ -e "s,<dir>fonts</dir>,<dir>${TBB_STORE_PATH}/fonts</dir>,"
++
+ cd "${HOME}"
+
+ # We pass all additional command-line arguments we get to Firefox.
+@@ -357,23 +326,23 @@
+
+ if [ "$show_usage" -eq 1 ]; then
+ # Display Firefox help, then our help
+- TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" \
+- -profile TorBrowser/Data/Browser/profile.default --help 2>/dev/null
++ TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ${TBB_STORE_PATH}/firefox --class "Tor Browser" \
++ -profile Data/Browser/profile.default --help 2>/dev/null
+ tbb_usage
+ elif [ "$detach" -eq 1 ] ; then
+- TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" \
+- -profile TorBrowser/Data/Browser/profile.default "${@}" > "$logfile" 2>&1 </dev/null &
++ TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ${TBB_STORE_PATH}/firefox --class "Tor Browser" \
++ -profile Data/Browser/profile.default "${@}" > "$logfile" 2>&1 </dev/null &
+ disown "$!"
+ elif [ "$log_output" -eq 1 -a "$show_output" -eq 1 ]; then
+- TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" \
+- -profile TorBrowser/Data/Browser/profile.default "${@}" 2>&1 </dev/null | \
++ TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ${TBB_STORE_PATH}/firefox --class "Tor Browser" \
++ -profile Data/Browser/profile.default "${@}" 2>&1 </dev/null | \
+ tee "$logfile"
+ elif [ "$show_output" -eq 1 ]; then
+- TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" \
+- -profile TorBrowser/Data/Browser/profile.default "${@}" < /dev/null
++ TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ${TBB_STORE_PATH}/firefox --class "Tor Browser" \
++ -profile Data/Browser/profile.default "${@}" < /dev/null
+ else
+- TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" \
+- -profile TorBrowser/Data/Browser/profile.default "${@}" > "$logfile" 2>&1 </dev/null
++ TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ${TBB_STORE_PATH}/firefox --class "Tor Browser" \
++ -profile Data/Browser/profile.default "${@}" > "$logfile" 2>&1 </dev/null
+ fi
+
+ exit $?
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 52d78cba79..d5832b19df 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -28,31 +28,71 @@
(define-module (gnu packages tor)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
+ #:use-module (guix monads)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (guix store)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cargo)
#:use-module (guix build-system go)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages assembly)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cups)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnuzilla)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages kerberos)
+ #:use-module (gnu packages libcanberra)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages node)
+ #:use-module (gnu packages nss)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages autotools)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages rsync) ; for httpse
+ #:use-module (gnu packages rust)
+ #:use-module (gnu packages rust-apps)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
- #:use-module (gnu packages w3m))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages vim) ; for xxd
+ #:use-module (gnu packages w3m)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages xml) ; for httpse
+ #:use-module (ice-9 match)
+ #:use-module ((srfi srfi-1) #:hide (zip)))
(define-public tor
(package
@@ -498,3 +538,677 @@ incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.
The obfs naming was chosen primarily because it was shorter, in terms of
protocol ancestery obfs4 is much closer to ScrambleSuit than obfs2/obfs3.")
(license license:gpl3+)))
+
+;; torbrowser and tor-browser-builder build versions are not always in sync
+(define %torbrowser-version "78.11.0esr-10.0-1")
+(define %tbb-build-version "10.0.17")
+(define %torbrowser-build "build1")
+(define %tbb-build "build1")
+(define %torbrowser-build-id "20210602000000");must be of the form YYYYMMDDhhmmss
+
+;; Fonts for Tor Browser. Avoid downloading 4Gb+ git repo on
+;; https://github.com/googlei18n/noto-fonts.git to use just a handful.
+;; Use the fonts on Tor Browser release tarball.
+(define torbrowser-fonts
+ (package
+ (name "torbrowser-fonts")
+ (version %tbb-build-version)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.torproject.org/tor-package-archive/torbrowser/"
+ version "/tor-browser-linux64-"
+ version "_en-US.tar.xz"))
+ (sha256
+ (base32
+ "13x38n1cvqmxjz0jf2fda8lx2k25szzmg7gvv08z3q5na7109m2m"))))
+ (build-system trivial-build-system)
+ (native-inputs
+ `(("tar" ,tar)
+ ("xz" ,xz)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((src (assoc-ref %build-inputs "source"))
+ (src-dir "tor-browser_en-US/Browser/fonts")
+ (fonts (string-append %output "/share/fonts"))
+ (tar (assoc-ref %build-inputs "tar"))
+ (xz (assoc-ref %build-inputs "xz")))
+ (mkdir-p fonts)
+ (format #t "Untaring torbrowser ball ...~%")
+ (invoke (string-append tar "/bin/tar") "-xf" src
+ "-C" fonts "--strip-components=3"
+ (string-append "--use-compress-program=" xz "/bin/xz")
+ src-dir)
+ #t))))
+ (home-page "https://github.com/googlei18n/noto-fonts")
+ (synopsis "Tor Browser bundled fonts")
+ (description "Free fonts bundled with Tor Browser. Includes a subset of Noto,
+Arimo, Cousine, Tinos and STIX fonts.")
+ (license license:silofl1.1)))
+
+(define tor-browser-build
+ (let ((commit (string-append "tbb-desktop-" %tbb-build-version
+ "-" %tbb-build)))
+ (package
+ (name "tor-browser-build")
+ (version %tbb-build-version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.torproject.org/builders/tor-browser-build.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qwgghy79wx0w1yz132yyaln4g42s72133n6gbdf07rkf5n44izc"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (format #t "Copying build scripts ...~%")
+ (copy-recursively (string-append
+ (assoc-ref %build-inputs "source")
+ "/projects/tor-browser")
+ %output
+ #:log (%make-void-port "w")))))
+ (home-page "https://www.torproject.org")
+ (synopsis "Tor Browser build scripts")
+ (description "Tor Browser runtime scripts.")
+ (license (license:non-copyleft "file://LICENSE")))))
+
+(define tor-launcher
+ (package
+ (name "tor-launcher")
+ (version "0.2.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.torproject.org/tor-package-archive/torbrowser/"
+ %tbb-build-version "/src-" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0mbd1q46d8nqisn6n79sp6m29332ymb2pf13xzgq1ml7rfcy6jjy"))))
+ (build-system trivial-build-system)
+ (native-inputs
+ `(("tar" ,tar)
+ ("xz" ,xz)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (format #t "Extracting source ...~%")
+ (let ((src (assoc-ref %build-inputs "source"))
+ (tar (assoc-ref %build-inputs "tar"))
+ (xz (assoc-ref %build-inputs "xz")))
+ (mkdir-p %output)
+ (format #t "Extracting source ...~%")
+ (invoke (string-append tar "/bin/tar") "-xf" src
+ "-C" %output "--strip-components=1"
+ (string-append "--use-compress-program=" xz "/bin/xz"))))))
+ (home-page "https://www.torproject.org")
+ (synopsis "Tor Browser built-in controler extension")
+ (description "Browser extension that starts the tor process (which
+connects the browser and other applications to the Tor Network), and
+which helps people configure and use @code{tor}. The first window that
+you see when you start Tor Browser is displayed by this extension.")
+ (license (license:non-copyleft "file://src/LICENSE"))))
+
+(define https-everywhere-lib-wasm
+ (let ((commit "45b1622f1240659aca4762fa336aad1322d6d50f"))
+ (package
+ (name "https-everywhere-lib-wasm")
+ (version "2021.4.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EFForg/https-everywhere-lib-wasm")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lq62rzypdzmnnzvfns3ccvv1g7p7g9s8jx788zzigr3gnmkpffx"))))
+ (build-system trivial