[PATCH 5/6] gnu: Add python-pytest-env.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 17:46
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200627154645.64264-5-monego@posteo.net
* gnu/packages/check.scm (python-pytest-env): New variable.
---
gnu/packages/check.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c2435a78af..f03d1f42fe 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -933,6 +933,26 @@ and many external plugins.")
("python-py" ,python2-py)
("python-wcwidth" ,python2-wcwidth))))))
+(define-public python-pytest-env
+ (package
+ (name "python-pytest-env")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-env" version))
+ (sha256
+ (base32 "1hl0ln0cicdid4qjk7mv90lw9xkb0v71dlj7q7rn89vzxxm9b53y"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/MobileDynasty/pytest-env")
+ (synopsis "Pytest plugin that allows you to add environment variables")
+ (description
+ "This is a py.test plugin that enables you to set environment variables
+in the pytest.ini file.")
+ (license license:expat)))
+
(define-public python-pytest-cov
(package
(name "python-pytest-cov")
--
2.20.1
M
M
Marius Bakke wrote on 20 Jul 2020 23:27
(name . Vinicius Monego)(address . monego@posteo.net)
87r1t5ho6o.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/check.scm (python-pytest-env): New variable.

python-check.scm is better here too, even though pytest lives
elsewhere.

[...]

Toggle quote (14 lines)
> +(define-public python-pytest-env
> + (package
> + (name "python-pytest-env")
> + (version "0.6.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pytest-env" version))
> + (sha256
> + (base32 "1hl0ln0cicdid4qjk7mv90lw9xkb0v71dlj7q7rn89vzxxm9b53y"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-pytest" ,python-pytest)))

As mentioned in another patch, it's good not to propagate the package
that this one "plugs in to", in order to allow using it with other
versions.

Toggle quote (6 lines)
> + (synopsis "Pytest plugin that allows you to add environment variables")
> + (description
> + "This is a py.test plugin that enables you to set environment variables
> +in the pytest.ini file.")

@command{py.test} and @file{pytest.ini}.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WDE8ACgkQoqBt8qM6
VPpg4AgAvPYLo833gbsLFa7ruwXXlsoU3JJzggDeABGeIAscuojycAWbbUmvbDEn
JKtUhofaRMqcowwVapRmtXaiNRoRtjd+dMr2++97RwLXVVKqvEhvgBnK4ov/DQPV
bCf3fdTuiWo1Cb0a+gXvQyyuE7XV2FnmaX5aS+0YBiNXBtWhf5p0FffRzj6nRGZM
CPUE7c5zffKIYU1uIHBRP9JsfJAm+1eNdMcIVq+rmH/PSRfI6b2ClPoZKtpRjTQR
GN1BJmdzO+pQmLvW60hNvT+lQNGcj31SwYAu/oQ6HaUnerN6FP9XxdJMiWKZwc9f
NLrEZCpoNoEUFcG04qiF9Jh1RsppEA==
=uxCa
-----END PGP SIGNATURE-----

B
B
Brett Gilio wrote on 25 Jul 2020 04:21
Re: [bug#42082] [PATCH 1/6] gnu: Add python-covdefaults.
(name . Vinicius Monego)(address . monego@posteo.net)
87r1t02v2m.fsf@gnu.org
merge 42082 42083 42084 42085 42086 42087
?