[PATCH 4/6] gnu: Add python-nodeenv.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 17:46
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200627154645.64264-4-monego@posteo.net
* gnu/packages/python-xyz.scm (python-nodeenv): New variable.
---
gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 045ee833ff..9eac0ff74f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17187,6 +17187,44 @@ Public Suffix List's private domains as well.")
(define-public python2-tldextract
(package-with-python2 python-tldextract))
+(define-public python-nodeenv
+ (package
+ (name "python-nodeenv")
+ (version "1.4.0")
+ (source
+ (origin
+ ;; There's no tarball in PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekalinin/nodeenv")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y443icx0w7jlzmxmmcm4q8dqfiwgafbb9cp8jpm68mbqxbz40a7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; This test fails. It tries to open a network socket.
+ (invoke "pytest" "-vv" "-k" "not test_smoke")
+ #t)))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-tox" ,python-tox)))
+ (home-page "https://ekalinin.github.io/nodeenv/")
+ (synopsis "Tool to create isolated node.js environments")
+ (description
+ "Nodeenv (node.js virtual environment) is a tool to create isolated
+node.js environments. It creates an environment that has its own installation
+directories, that doesn't share libraries with other node.js virtual
+environments.")
+ (license license:bsd-3)))
+
(define-public python-pynamecheap
(package
(name "python-pynamecheap")
--
2.20.1
M
M
Marius Bakke wrote on 20 Jul 2020 23:25
(name . Vinicius Monego)(address . monego@posteo.net)
87tuy1hob5.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-nodeenv): New variable.

We often omit the python- prefix for packages that are not used as a
library, i.e. Python packages that produce a "normal program". Is that
the case here?

Perhaps it would make sense to place this in (gnu packages node) as
simply "nodeenv"?

[...]

Toggle quote (7 lines)
> + (native-inputs
> + `(("python-coverage" ,python-coverage)
> + ("python-flake8" ,python-flake8)
> + ("python-mock" ,python-mock)
> + ("python-pytest" ,python-pytest)
> + ("python-tox" ,python-tox)))

'python-tox' can probably be removed since we call out to pytest
directly. Some packages needlessly test for it though, in that case you
can remove it from requirements-dev.txt with substitute*.

Toggle quote (3 lines)
> + (synopsis "Tool to create isolated node.js environments")

s/Tool to c/C/
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WC68ACgkQoqBt8qM6
VPpKlQf+MxCjBnZDJ7dHpVnlfCRwMPbkO+wuMY75GdJXkrIA5ILE9B1WULyAduJz
KmGXf5EG62B7SoVfPvCxWzOEfoM+7Iw0qQJNgpzxCKcnsvj4/KCK7v2/4tCmv8vo
Jrc75ecbyNrhEz4biVoW5LtdSEjoFEdsOIOmYgSzHCYOdRYxfPd/qAU58Hu5X0hJ
B9bE8fM1w6/H1DU8mI2yWBvZD7MkICyXGM+s+51HKGK1dchP60m1JlEDdx+ABH6c
qVKu5dryvCJRjdFml/MSRhw5R9to98kZckKFIu5DBtOwxwe4rcay2HPxbKJgjwTP
4J/FVH/yj6SGHLzFmzHJg4Wc+/FgKw==
=btxk
-----END PGP SIGNATURE-----

V
V
Vinicius Monego wrote on 21 Jul 2020 20:42
5c8aad09797a818d525c121a24601020b271b514.camel@posteo.net
Em seg, 2020-07-20 às 23:25 +0200, Marius Bakke escreveu:

Toggle quote (5 lines)
> We often omit the python- prefix for packages that are not used as a
> library, i.e. Python packages that produce a "normal program". Is
> that
> the case here?

It does provide an executable. It's a tool like virtualenv, but for
Node packages instead of Python.

Toggle quote (3 lines)
> Perhaps it would make sense to place this in (gnu packages node) as
> simply "nodeenv"?

IIUC the {language} modules are for packages affiliated with the
foundation behind the language, or other compiler or interpreter
implementations. That's not the case here.

Toggle quote (12 lines)
> > + (native-inputs
> > + `(("python-coverage" ,python-coverage)
> > + ("python-flake8" ,python-flake8)
> > + ("python-mock" ,python-mock)
> > + ("python-pytest" ,python-pytest)
> > + ("python-tox" ,python-tox)))
>
> 'python-tox' can probably be removed since we call out to pytest
> directly. Some packages needlessly test for it though, in that case
> you
> can remove it from requirements-dev.txt with substitute*.

Removed. I also removed flake8, since it's only used in the tox.ini
file.
B
B
Brett Gilio wrote on 25 Jul 2020 04:21
Re: [bug#42082] [PATCH 1/6] gnu: Add python-covdefaults.
(name . Vinicius Monego)(address . monego@posteo.net)
87r1t02v2m.fsf@gnu.org
merge 42082 42083 42084 42085 42086 42087
?