[PATCH 3/6] gnu: Add python-identify.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 17:46
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200627154645.64264-3-monego@posteo.net
* gnu/packages/python-xyz.scm (python-identify): New variable.
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac839a4e16..045ee833ff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -161,6 +161,7 @@
#:use-module (gnu packages terminals)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
@@ -17119,6 +17120,40 @@ library to allow local file system access via @code{file://} URLs.")
(define-public python2-requests-file
(package-with-python2 python-requests-file))
+(define-public python-identify
+ (package
+ (name "python-identify")
+ (version "1.4.20")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chriskuehl/identify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ivafv83ivjgyan10yf0calbzraknps60n2v841n7jfazracr8v2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv")
+ #t)))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-editdistance" ,python-editdistance)))
+ (home-page "https://github.com/chriskuehl/identify")
+ (synopsis "File identification library for Python")
+ (description
+ "File identification library for Python. Given a file (or some information
+about a file), return a set of standardized tags identifying what the file is.")
+ (license license:expat)))
+
(define-public python-tldextract
(package
(name "python-tldextract")
--
2.20.1
M
M
Marius Bakke wrote on 20 Jul 2020 23:17
(name . Vinicius Monego)(address . monego@posteo.net)
87wo2xhona.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-identify): New variable.

LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WCfkACgkQoqBt8qM6
VPoXhggAipjeGJVevrmfgnkbASRLEIT6axblJ4g4GvSyleR8q1pMCYJVB7ML1AnG
IgAsot5srAcdb5+dYc5yG3dNGzXKBk05YQ8Fxc8rBghiBXJKeeiC4AwvQ9EHs/u7
InKkIOBfyFWfTjT03dPczv4HnjRBHXrbI6uShaTvNgzusI6j8uWhZR5Xuinp+wZQ
KivFQUh4uLGhWDvZq+56jedrf6+Sqx0jn0lcpveN/NEFLl5o1cYZCgYfDqUQGpNs
N55xBSjYTbH3MS8pOB1akDcFhFf5jfh7Xy6WHI1qTI4KMskYeYoCbH73HkE7p43S
yDuOZz21C1GtAv12vXGnfImqargWNg==
=R3bk
-----END PGP SIGNATURE-----

B
B
Brett Gilio wrote on 25 Jul 2020 04:21
Re: [bug#42082] [PATCH 1/6] gnu: Add python-covdefaults.
(name . Vinicius Monego)(address . monego@posteo.net)
87r1t02v2m.fsf@gnu.org
merge 42082 42083 42084 42085 42086 42087
?