[PATCH 4/6] gnu: Add python-pytest-openfiles.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 00:15
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200626221542.22604-4-monego@posteo.net
* gnu/packages/check.scm (python-pytest-openfiles): New variable.
---
gnu/packages/check.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d3ea6e31d6..136bdcc6d2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -730,6 +730,38 @@ interfaces and processes.")
(define-public python2-nose2
(package-with-python2 python-nose2))
+(define-public python-pytest-openfiles
+ (package
+ (name "python-pytest-openfiles")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-openfiles" version))
+ (sha256
+ (base32 "0n0a7fdc9m86360y96l23fvdmd6rw04bl6h5xqgl9qxfv08jk70p"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/astropy/pytest-openfiles")
+ (synopsis "Pytest plugin for detecting inadvertent open file handles")
+ (description
+ "This package provides a plugin for the pytest framework that allows
+developers to detect whether any file handles or other file-like objects
+were inadvertently left open at the end of a unit test.")
+ (license license:bsd-3)))
+
(define-public python-unittest2
(package
(name "python-unittest2")
--
2.20.1
B
B
Brett Gilio wrote on 25 Jul 2020 04:20
Re: [bug#42069] [PATCH 1/6] gnu: Add python-pytest-arraydiff.
(name . Vinicius Monego)(address . monego@posteo.net)
87tuxw2v3x.fsf@gnu.org
merge 42069 42070 42071 42072 42073 42074
?