[PATCH 6/6] gnu: Add python-pytest-mpl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 00:15
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200626221542.22604-6-monego@posteo.net
* gnu/packages/check.scm (python-pytest-mpl): New variable.
---
gnu/packages/check.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5ed5675998..b49fd9e162 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2776,6 +2776,35 @@ loaded.")
grew out of the @dfn{Vc} project.")
(license license:bsd-3))))
+(define-public python-pytest-mpl
+ (package
+ (name "python-pytest-mpl")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mpl" version))
+ (sha256
+ (base32 "1km202c1s5kcn52fx0266p06qb34va3warcby594dh6vixxa9i96"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-nose" ,python-nose)
+ ("python-pillow" ,python-pillow)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/matplotlib/pytest-mpl")
+ (synopsis "Pytest plugin to help with testing figures output from Matplotlib")
+ (description
+ "This is a plugin to facilitate image comparison for Matplotlib figures
+in Pytest.")
+ (license license:bsd-3)))
+
(define-public python-pyfakefs
(package
(name "python-pyfakefs")
--
2.20.1
B
B
Brett Gilio wrote on 25 Jul 2020 04:20
Re: [bug#42069] [PATCH 1/6] gnu: Add python-pytest-arraydiff.
(name . Vinicius Monego)(address . monego@posteo.net)
87tuxw2v3x.fsf@gnu.org
merge 42069 42070 42071 42072 42073 42074
?