[PATCH 3/6] gnu: Add python-pytest-filter-subpackage.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
Merged with
V
V
Vinicius Monego wrote on 27 Jun 2020 00:15
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200626221542.22604-3-monego@posteo.net
* gnu/packages/check.scm (python-pytest-filter-subpackage): New variable.
---
gnu/packages/check.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6b682d18a2..d3ea6e31d6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1538,6 +1538,43 @@ testing tools. @code{pytest-asyncio} provides useful fixtures and markers
to make testing async code easier.")
(license license:asl2.0)))
+(define-public python-pytest-filter-subpackage
+ (package
+ (name "python-pytest-filter-subpackage")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-filter-subpackage" version))
+ (sha256
+ (base32 "1s4s2kd31yc65rfvl4xhy8xx806xhy59kc7668h6b6wq88xgrn5p"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; One test is failing. There's an issue reported upstream. See
+ ;; https://github.com/astropy/pytest-filter-subpackage/issues/3.
+ ;; Disable it for now.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k" "not test_with_rst"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-doctestplus"
+ ,python-pytest-doctestplus)))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/astropy/pytest-filter-subpackage")
+ (synopsis "Pytest plugin for filtering based on sub-packages")
+ (description
+ "This package contains a simple plugin for the pytest framework that
+provides a shortcut to testing all code and documentation for a given
+sub-package.")
+ (license license:bsd-3)))
+
(define-public python-cov-core
(package
(name "python-cov-core")
--
2.20.1
B
B
Brett Gilio wrote on 25 Jul 2020 04:20
Re: [bug#42069] [PATCH 1/6] gnu: Add python-pytest-arraydiff.
(name . Vinicius Monego)(address . monego@posteo.net)
87tuxw2v3x.fsf@gnu.org
merge 42069 42070 42071 42072 42073 42074
?