[PATCH] gnu: Add python-flask-cors.

  • Done
  • quality assurance status badge
Details
3 participants
  • Hamzeh Nasajpour
  • Jelle Licht
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hamzeh Nasajpour
Severity
normal

Debbugs page

Hamzeh Nasajpour wrote 5 years ago
(address . guix-patches@gnu.org)
3f1fdf71-c664-4fb1-8ba1-f82e2d5f39b7@www.fastmail.com
* gnu/packages/python-web.scm (python-flask-cors): New variable.
---
gnu/packages/python-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e37ae94e18..276ed0f01f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2146,6 +2146,27 @@ SlimIt also provides a library that includes a JavaScript parser, lexer,
pretty printer and a tree visitor.")
(license license:expat)))
+(define-public python-flask-cors
+ (package
+ (name "python-flask-cors")
+ (version "3.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Cors" version))
+ (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-flask" ,python-flask)))
+ (home-page "https://github.com/corydolphin/flask-cors")
+ (synopsis "A Flask extension adding a decorator for CORS support")
+ (description
+ "A Flask extension for handling Cross Origin Resource Sharing (CORS),
+making cross-origin AJAX possible.")
+ (license license:expat)))
+
(define-public python-flask-restful
(package
(name "python-flask-restful")
--
2.23.0
Ludovic Courtès wrote 5 years ago
(name . Hamzeh Nasajpour)(address . h.nasajpour@pantherx.org)(address . 37535@debbugs.gnu.org)
87h84wnoh9.fsf@gnu.org
Hi Hamzeh,

"Hamzeh Nasajpour" <h.nasajpour@pantherx.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-flask-cors): New variable.

[...]

Toggle quote (5 lines)
> +(define-public python-flask-cors
> + (package
> + (name "python-flask-cors")
> + (version "3.0.7")

The indentation is different from what we usually do. Could you run
./etc/indent-code.el as noted at

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

Could you try to run the test suite or, as a last resort, add a comment
explaining why it is disabled?

Toggle quote (6 lines)
> + (synopsis "A Flask extension adding a decorator for CORS support")
> + (description
> + "A Flask extension for handling Cross Origin Resource Sharing (CORS),
> +making cross-origin AJAX possible.")

Please fix the issue reported by ‘guix lint’ for the synopsis and make a
full sentence for the description. See

Could you send an updated patch?

Thanks,
Ludo’.
Ludovic Courtès wrote 5 years ago
(name . Hamzeh Nasajpour)(address . h.nasajpour@pantherx.org)(address . 37535@debbugs.gnu.org)
87k19idp96.fsf@gnu.org
Ping! :-)

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (37 lines)
> Hi Hamzeh,
>
> "Hamzeh Nasajpour" <h.nasajpour@pantherx.org> skribis:
>
>> * gnu/packages/python-web.scm (python-flask-cors): New variable.
>
> [...]
>
>> +(define-public python-flask-cors
>> + (package
>> + (name "python-flask-cors")
>> + (version "3.0.7")
>
> The indentation is different from what we usually do. Could you run
> ./etc/indent-code.el as noted at
> <https://guix.gnu.org/manual/en/html_node/Formatting-Code.html>?
>
>> + (arguments
>> + `(#:tests? #f))
>
> Could you try to run the test suite or, as a last resort, add a comment
> explaining why it is disabled?
>
>> + (home-page "https://github.com/corydolphin/flask-cors")
>> + (synopsis "A Flask extension adding a decorator for CORS support")
>> + (description
>> + "A Flask extension for handling Cross Origin Resource Sharing (CORS),
>> +making cross-origin AJAX possible.")
>
> Please fix the issue reported by ‘guix lint’ for the synopsis and make a
> full sentence for the description. See
> <https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
Jelle Licht wrote 2 years ago
Re: bug#37535: [PATCH] gnu: Add python-flask-cors.
(address . 37535-done@debbugs.gnu.org)
87leh8p2c3.fsf@fsfe.org
python-flask-cors is available on current guix master, so closing this.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37535@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37535
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help