Hamzeh Nasajpour wrote 5 years ago
(address . guix-patches@gnu.org)
* gnu/packages/python-web.scm (python-flask-cors): New variable.
---
gnu/packages/python-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e37ae94e18..276ed0f01f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2146,6 +2146,27 @@ SlimIt also provides a library that includes a JavaScript parser, lexer,
pretty printer and a tree visitor.")
(license license:expat)))
+(define-public python-flask-cors
+ (package
+ (name "python-flask-cors")
+ (version "3.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Cors" version))
+ (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-flask" ,python-flask)))
+ (home-page "https://github.com/corydolphin/flask-cors")
+ (synopsis "A Flask extension adding a decorator for CORS support")
+ (description
+ "A Flask extension for handling Cross Origin Resource Sharing (CORS),
+making cross-origin AJAX possible.")
+ (license license:expat)))
+
(define-public python-flask-restful
(package
(name "python-flask-restful")
--
2.23.0