[PATCH 4/4] gnu: Add r-bslib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Todor Kondi?
  • zimoun
Owner
unassigned
Submitted by
Todor Kondi?
Severity
normal
Merged with
T
T
Todor Kondi? wrote on 4 Feb 2021 02:13
(address . guix-patches@gnu.org)(name . Todor Kondi?)(address . kondor@librem.one)
20210204011301.50868-4-kondor@librem.one
* gnu/packages/cran.scm(r-bslib): New variable.
---
gnu/packages/cran.scm | 34 +++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e52963d789..0fce49f45e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2019, 2020 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2020 Todor Kondi? <tk.code@protonmail.com>
+;;; Copyright © 2020, 2021 Todor Kondi? <kondor@librem.one>
;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
@@ -25863,3 +25863,35 @@ With this, R developers can use variables, inheritance, and functions
to generate dynamic style sheets. The package uses the @code{Sass
CSS} extension language, which is stable and CSS compatible.")
(license license:expat)))
+
+(define-public r-bslib
+ (package
+ (name "r-bslib")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bslib" version))
+ (sha256
+ (base32
+ "0qlpv2lqr3hjykszmnll7vi4zhmrz4rgcfl0sifxc6cha6jy2nac"))))
+ (properties `((upstream-name . "bslib")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jquerylib" ,r-jquerylib)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rlang" ,r-rlang)
+ ("r-sass" ,r-sass)))
+ (home-page "https://rstudio.github.io/bslib/")
+ (synopsis
+ "Custom @code{Bootstrap Sass} Themes for @code{shiny} and @code{rmarkdown}")
+ (description
+ "Simplifies custom @code{CSS} styling of both @code{shiny} and
+@code{rmarkdown} via @code{Bootstrap Sass}. Supports both
+@code{Bootstrap} 3 and 4 as well as their various @code{Bootswatch}
+themes. An interactive widget is also provided for previewing themes
+in real time.")
+ (license license:expat)))
--
2.30.0
Z
Z
zimoun wrote on 11 Mar 2021 00:12
merge 46285 46286 46287 46288
(address . control@debbugs.gnu.org)
86h7libo2a.fsf@gmail.com
merge 46285 46286 46287 46288
thanks
?