[PATCH 1/4] gnu: Add r-jquerylib.

  • Done
  • quality assurance status badge
Details
3 participants
  • Todor Kondi?
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Todor Kondi?
Severity
normal
Merged with
T
T
Todor Kondi? wrote on 4 Feb 2021 02:12
(address . guix-patches@gnu.org)(name . Todor Kondi?)(address . kondor@librem.one)
20210204011301.50868-1-kondor@librem.one
* gnu/packages/cran.scm(r-jquerylib): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 874a77c552..6f7d07140d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25782,3 +25782,29 @@ tuning, e.g. Grid Search, Random Search, or Simulated Annealing. Various
termination criteria can be set and combined. The class @code{AutoTuner} provides a
convenient way to perform nested resampling in combination with @code{mlr3}.")
(license license:lgpl3)))
+
+(define-public r-jquerylib
+ (package
+ (name "r-jquerylib")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "jquerylib" version))
+ (sha256
+ (base32
+ "1s0d6mws13hwkx07jqmry7vp30a05b2p9w7ir68bmkhasidwkzdq"))))
+ (properties `((upstream-name . "jquerylib")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)))
+ (home-page
+ "https://cran.r-project.org/package=jquerylib")
+ (synopsis
+ "Obtain @code{jQuery} as an HTML Dependency Object")
+ (description
+ "Obtain any major version of @code{jQuery}
+@url{https://code.jquery.com,jQuery} and use it in any webpage
+generated by @code{htmltools}. Most R users do not need to use this
+package directly.")
+ (license license:expat)))
--
2.30.0
Z
Z
zimoun wrote on 11 Mar 2021 00:12
merge 46285 46286 46287 46288
(address . control@debbugs.gnu.org)
86h7libo2a.fsf@gmail.com
merge 46285 46286 46287 46288
thanks
R
R
Ricardo Wurmus wrote on 23 Nov 2021 00:03
[PATCH 1/4] gnu: Add r-jquerylib.
(address . 46285-done@debbugs.gnu.org)
87czmrvlju.fsf@elephly.net
I’m closing this. We have r-jquerylib 0.1.4 in Guix. It is
unfortunately a bit more complicated because we build the minified
JavaScript files from source.

--
Ricardo
Closed
?