[PATCH 2/4] gnu: Add r-cachem.

  • Done
  • quality assurance status badge
Details
2 participants
  • Todor Kondi?
  • zimoun
Owner
unassigned
Submitted by
Todor Kondi?
Severity
normal
Merged with
T
T
Todor Kondi? wrote on 4 Feb 2021 02:12
(address . guix-patches@gnu.org)(name . Todor Kondi?)(address . kondor@librem.one)
20210204011301.50868-2-kondor@librem.one
* gnu/packages/cran.scm(r-cachem): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6f7d07140d..89474a491d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25808,3 +25808,27 @@ convenient way to perform nested resampling in combination with @code{mlr3}.")
generated by @code{htmltools}. Most R users do not need to use this
package directly.")
(license license:expat)))
+
+(define-public r-cachem
+ (package
+ (name "r-cachem")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cachem" version))
+ (sha256
+ (base32
+ "0hann47kpalhi0wp86xkd3j6zbl6x785ciggl86z53znyk1ywx44"))))
+ (properties `((upstream-name . "cachem")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fastmap" ,r-fastmap) ("r-rlang" ,r-rlang)))
+ (home-page "https://cachem.r-lib.org/")
+ (synopsis
+ "Cache R Objects with Automatic Pruning")
+ (description
+ "Key-value stores with automatic pruning. Caches can limit
+either their total size or the age of the oldest object (or both),
+automatically pruning objects to maintain the constraints.")
+ (license license:expat)))
--
2.30.0
Z
Z
zimoun wrote on 11 Mar 2021 00:12
merge 46285 46286 46287 46288
(address . control@debbugs.gnu.org)
86h7libo2a.fsf@gmail.com
merge 46285 46286 46287 46288
thanks
?