[PATCH 3/4] gnu: Add r-sass.

  • Done
  • quality assurance status badge
Details
3 participants
  • Todor Kondi?
  • phodina
  • zimoun
Owner
unassigned
Submitted by
Todor Kondi?
Severity
normal
Merged with
T
T
Todor Kondi? wrote on 4 Feb 2021 02:13
(address . guix-patches@gnu.org)(name . Todor Kondi?)(address . kondor@librem.one)
20210204011301.50868-3-kondor@librem.one
* gnu/packages/cran.scm(r-sass): Add variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 89474a491d..e52963d789 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25832,3 +25832,34 @@ package directly.")
either their total size or the age of the oldest object (or both),
automatically pruning objects to maintain the constraints.")
(license license:expat)))
+
+(define-public r-sass
+ (package
+ (name "r-sass")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sass" version))
+ (sha256
+ (base32
+ "1cxqwsdyz71mgflqqa65mfr161jlv8q9mshs1y19pxp6pz5wnv0s"))))
+ (properties `((upstream-name . "sass")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-fs" ,r-fs)
+ ("r-htmltools" ,r-htmltools)
+ ("r-r6" ,r-r6)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-rlang" ,r-rlang)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/rstudio/sass")
+ (synopsis
+ "Syntactically Awesome Style Sheets")
+ (description
+ "An @code{SCSS} compiler, powered by the @code{LibSass} library.
+With this, R developers can use variables, inheritance, and functions
+to generate dynamic style sheets. The package uses the @code{Sass
+CSS} extension language, which is stable and CSS compatible.")
+ (license license:expat)))
--
2.30.0
Z
Z
zimoun wrote on 11 Mar 2021 00:12
merge 46285 46286 46287 46288
(address . control@debbugs.gnu.org)
86h7libo2a.fsf@gmail.com
merge 46285 46286 46287 46288
thanks
P
P
phodina wrote on 5 Nov 2021 09:24
RE: [PATCH 3/4] gnu: Add r-sass.
(name . 46288@debbugs.gnu.org)(address . 46288@debbugs.gnu.org)
UIRXnyjEQ5JsaaiNrIZ3bpnoR2OF0KhSablyYiTJdhcWhAVq3YNCZgAhNR7RzJE3VvoYwdi7vTj1gg12ksPph86SPmqI68QXGbzRfZ--WBY=@protonmail.com
Hi,

this package has already been added in 281df0d225877bf784c562cbdec0400f7f4c4513 by Ricardo Wurmus.

Petr
?