(address . bug-guix@gnu.org)
When I run `guix challenge` it shows that there are many versions of
Guile that are not reproducible.
`guix describe` outputs:
```
Generation 24 May 12 2021 18:06:24 (current)
guix d6aeebb
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: d6aeebb23639258311fdfb9dbf5f903079fde51a
```
The versions of Guile that are not reproducible are:
```
/gnu/store/2wrp7x9aclqsapm58dz5i654qds8nbb8-guile-2.0.14
/gnu/store/l6id6m9fjx5bphgyf1kp6srbmdwspqkn-guile-2.2.7
/gnu/store/k5d9vx4jp8z199c6diampwh6dd7bdjbi-guile-3.0.2
/gnu/store/zslki807w05y73wbpnszxpz44fl2yn8b-guile-3.0.2
/gnu/store/ai5w29qdymayb61xq6qadlqgbl6g5qli-guile-3.0.5
/gnu/store/m5iprcg6pb5ch86r9agmqwd8v6kp7999-guile-3.0.5
```
Attached for each of these Guile versions are the output of files that
are not reproducible and the diffoscope output.
/gnu/store/2wrp7x9aclqsapm58dz5i654qds8nbb8-guile-2.0.14 contents differ:
local hash: 0p3lnx0dc0j3brsrfb2dlfi7pn57saadgp292qmhw7i0ihsdb4sn
https://ci.guix.gnu.org/nar/lzip/2wrp7x9aclqsapm58dz5i654qds8nbb8-guile-2.0.14:09zilm6fp8v6m7nn11r26gvsmjwa05m33ip5rbn9v0zf25p02b83
differing files:
/lib/guile/2.0/ccache/ice-9/deprecated.go
/lib/guile/2.0/ccache/rnrs/arithmetic/fixnums.go
/lib/guile/2.0/ccache/srfi/srfi-27.go
/lib/guile/2.0/ccache/srfi/srfi-41.go
/lib/guile/2.0/ccache/srfi/srfi-45.go
/lib/guile/2.0/ccache/srfi/srfi-64.go
/lib/guile/2.0/ccache/srfi/srfi-69.go
/lib/guile/2.0/ccache/srfi/srfi-111.go
/lib/guile/2.0/ccache/srfi/srfi-37.go
/lib/guile/2.0/ccache/system/repl/coop-server.go
/lib/guile/2.0/ccache/system/vm/coverage.go
/lib/guile/2.0/ccache/system/base/types.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive
/gnu/store/l6id6m9fjx5bphgyf1kp6srbmdwspqkn-guile-2.2.7 contents differ:
local hash: 048cgks5w4yxnskgl8y4c2hqw0dsx2zzw9rjdnxrhn1bxpy043hv
https://ci.guix.gnu.org/nar/lzip/l6id6m9fjx5bphgyf1kp6srbmdwspqkn-guile-2.2.7:1jkjld1q4nrgpsqy5888198fzzb5lw862lsjsabnplqzrizqnnym
differing files:
/lib/guile/2.2/ccache/language/tree-il/effects.go
/lib/guile/2.2/ccache/language/cps/utils.go
/lib/guile/2.2/ccache/language/cps/slot-allocation.go
/lib/guile/2.2/ccache/language/cps/intset.go
/lib/guile/2.2/ccache/language/cps/types.go
/lib/guile/2.2/ccache/language/cps/effects-analysis.go
/lib/guile/2.2/ccache/language/cps/intmap.go
/lib/guile/2.2/ccache/rnrs/io/ports.go
/lib/guile/2.2/ccache/rnrs/arithmetic/fixnums.go
/lib/guile/2.2/ccache/srfi/srfi-27.go
/lib/guile/2.2/ccache/srfi/srfi-41.go
/lib/guile/2.2/ccache/srfi/srfi-45.go
/lib/guile/2.2/ccache/srfi/srfi-64.go
/lib/guile/2.2/ccache/srfi/srfi-69.go
/lib/guile/2.2/ccache/srfi/srfi-111.go
/lib/guile/2.2/ccache/srfi/srfi-37.go
/lib/guile/2.2/ccache/system/repl/coop-server.go
/lib/guile/2.2/ccache/system/vm/coverage.go
/lib/guile/2.2/ccache/system/vm/elf.go
/lib/guile/2.2/ccache/system/vm/dwarf.go
/lib/guile/2.2/ccache/system/vm/debug.go
/lib/guile/2.2/ccache/system/vm/assembler.go
/lib/guile/2.2/ccache/system/vm/linker.go
/lib/guile/2.2/ccache/system/vm/frame.go
/lib/guile/2.2/ccache/system/base/message.go
/lib/guile/2.2/ccache/system/base/types.go
/lib/guile/2.2/ccache/system/base/lalr.go
/lib/guile/2.2/ccache/oop/goops.go
/lib/guile/2.2/ccache/statprof.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive
/gnu/store/k5d9vx4jp8z199c6diampwh6dd7bdjbi-guile-3.0.2 contents differ:
local hash: 0mc6gg6dybg422w3m5i210p0c1gkl2q61m0cxjcbb59zi9ipdf0p
https://ci.guix.gnu.org/nar/lzip/k5d9vx4jp8z199c6diampwh6dd7bdjbi-guile-3.0.2:0pmydfbmvcqkz8il9m6zwmsn7agnag3sgs2a2wivlbdn4bzv3n3h
differing files:
/lib/guile/3.0/ccache/language/tree-il/effects.go
/lib/guile/3.0/ccache/language/cps/slot-allocation.go
/lib/guile/3.0/ccache/language/cps/intset.go
/lib/guile/3.0/ccache/language/cps/types.go
/lib/guile/3.0/ccache/language/cps/effects-analysis.go
/lib/guile/3.0/ccache/language/cps/graphs.go
/lib/guile/3.0/ccache/language/cps/intmap.go
/lib/guile/3.0/ccache/rnrs/io/ports.go
/lib/guile/3.0/ccache/rnrs/arithmetic/fixnums.go
/lib/guile/3.0/ccache/srfi/srfi-171/meta.go
/lib/guile/3.0/ccache/srfi/srfi-27.go
/lib/guile/3.0/ccache/srfi/srfi-41.go
/lib/guile/3.0/ccache/srfi/srfi-45.go
/lib/guile/3.0/ccache/srfi/srfi-64.go
/lib/guile/3.0/ccache/srfi/srfi-69.go
/lib/guile/3.0/ccache/srfi/srfi-111.go
/lib/guile/3.0/ccache/srfi/srfi-37.go
/lib/guile/3.0/ccache/system/repl/coop-server.go
/lib/guile/3.0/ccache/system/vm/coverage.go
/lib/guile/3.0/ccache/system/vm/dwarf.go
/lib/guile/3.0/ccache/system/vm/debug.go
/lib/guile/3.0/ccache/system/vm/assembler.go
/lib/guile/3.0/ccache/system/base/message.go
/lib/guile/3.0/ccache/system/base/types.go
/lib/guile/3.0/ccache/system/base/lalr.go
/lib/guile/3.0/ccache/oop/goops.go
/lib/guile/3.0/ccache/statprof.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive
/gnu/store/zslki807w05y73wbpnszxpz44fl2yn8b-guile-3.0.2 contents differ:
local hash: 1mgb672br2jdp2rchc28cnhi6xaacarlg95fhw5r7ljxn9df4g19
https://ci.guix.gnu.org/nar/lzip/zslki807w05y73wbpnszxpz44fl2yn8b-guile-3.0.2:0bfa48m7zif03drzh6rbz8qi8bc5r9bg34z39vbs97vhx4lisvlf
differing files:
/lib/guile/3.0/ccache/language/tree-il/effects.go
/lib/guile/3.0/ccache/language/cps/slot-allocation.go
/lib/guile/3.0/ccache/language/cps/intset.go
/lib/guile/3.0/ccache/language/cps/types.go
/lib/guile/3.0/ccache/language/cps/effects-analysis.go
/lib/guile/3.0/ccache/language/cps/graphs.go
/lib/guile/3.0/ccache/language/cps/intmap.go
/lib/guile/3.0/ccache/rnrs/io/ports.go
/lib/guile/3.0/ccache/rnrs/arithmetic/fixnums.go
/lib/guile/3.0/ccache/srfi/srfi-171/meta.go
/lib/guile/3.0/ccache/srfi/srfi-27.go
/lib/guile/3.0/ccache/srfi/srfi-41.go
/lib/guile/3.0/ccache/srfi/srfi-45.go
/lib/guile/3.0/ccache/srfi/srfi-64.go
/lib/guile/3.0/ccache/srfi/srfi-69.go
/lib/guile/3.0/ccache/srfi/srfi-111.go
/lib/guile/3.0/ccache/srfi/srfi-37.go
/lib/guile/3.0/ccache/system/repl/coop-server.go
/lib/guile/3.0/ccache/system/vm/dwarf.go
/lib/guile/3.0/ccache/system/vm/debug.go
/lib/guile/3.0/ccache/system/vm/assembler.go
/lib/guile/3.0/ccache/system/base/message.go
/lib/guile/3.0/ccache/system/base/types.go
/lib/guile/3.0/ccache/system/base/lalr.go
/lib/guile/3.0/ccache/oop/goops.go
/lib/guile/3.0/ccache/statprof.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive
/gnu/store/ai5w29qdymayb61xq6qadlqgbl6g5qli-guile-3.0.5 contents differ:
local hash: 07yr8xz1gj8iv2md2lb7bgmsbb0yr8z40hrw4mdvcrnfqdlid1gf
https://ci.guix.gnu.org/nar/lzip/ai5w29qdymayb61xq6qadlqgbl6g5qli-guile-3.0.5:1v05fy63s9pak2xlwag9v86vb696393lh7j2nz27jqgfh68s1kcb
differing files:
/lib/guile/3.0/ccache/ice-9/vlist.go
/lib/guile/3.0/ccache/ice-9/suspendable-ports.go
/lib/guile/3.0/ccache/srfi/srfi-27.go
/lib/guile/3.0/ccache/srfi/srfi-19.go
/lib/guile/3.0/ccache/srfi/srfi-18.go
/lib/guile/3.0/ccache/srfi/srfi-37.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive
/gnu/store/m5iprcg6pb5ch86r9agmqwd8v6kp7999-guile-3.0.5 contents differ:
local hash: 0c0klgg4asf11zkp93nd1pccbfalyfxifjdzw0dmhk6g0zkkkjwf
https://ci.guix.gnu.org/nar/lzip/m5iprcg6pb5ch86r9agmqwd8v6kp7999-guile-3.0.5:0d0a51gk2jv09dy9q06hqv03kvch940b7jkaljll2i11kr0wp1vj
differing files:
/lib/guile/3.0/ccache/ice-9/vlist.go
/lib/guile/3.0/ccache/ice-9/suspendable-ports.go
/lib/guile/3.0/ccache/rnrs/arithmetic/fixnums.go
/lib/guile/3.0/ccache/srfi/srfi-27.go
/lib/guile/3.0/ccache/srfi/srfi-41.go
/lib/guile/3.0/ccache/srfi/srfi-19.go
/lib/guile/3.0/ccache/srfi/srfi-45.go
/lib/guile/3.0/ccache/srfi/srfi-64.go
/lib/guile/3.0/ccache/srfi/srfi-37.go
/lib/guile/3.0/ccache/system/vm/dwarf.go
/lib/guile/3.0/ccache/system/vm/debug.go
/lib/guile/3.0/ccache/system/base/types.go
/lib/guile/3.0/ccache/oop/goops.go
1 store items were analyzed:
- 0 (0.0%) were identical
- 1 (100.0%) differed
- 0 (0.0%) were inconclusive