mikadoZero <mikadozero@yandex.com> writes:
Toggle quote (3 lines)
> Attached are diffs for three of the packages listed in the `guix
> challenge` output that were listed as differing.
Thank you, this is very helpful!
Toggle quote (11 lines)
> diff -ru --no-dereference /gnu/store/9z98cvjm7p7z21xdid1ryydxy5vyz6wr-python-3.7.0/lib/python3.7/site-packages/pip-10.0.1.dist-info/RECORD /tmp/python/lib/python3.7/site-packages/pip-10.0.1.dist-info/RECORD
> --- /gnu/store/9z98cvjm7p7z21xdid1ryydxy5vyz6wr-python-3.7.0/lib/python3.7/site-packages/pip-10.0.1.dist-info/RECORD 1969-12-31 19:00:01.000000000 -0500
> +++ /tmp/python/lib/python3.7/site-packages/pip-10.0.1.dist-info/RECORD 1970-01-01 00:00:01.000000000 -0500
> @@ -295,285 +295,285 @@
> ../../../bin/pip3,sha256=78NRTi33kWTTiOubADOTlPa85pTXmVhJrO-OdccUy3Q,270
> ../../../bin/pip3.7,sha256=78NRTi33kWTTiOubADOTlPa85pTXmVhJrO-OdccUy3Q,270
> pip-10.0.1.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
> -pip/_vendor/html5lib/treebuilders/__pycache__/__init__.cpython-37.pyc,,
> -pip/_vendor/html5lib/treebuilders/__pycache__/etree.cpython-37.pyc,,
> -pip/_vendor/html5lib/treebuilders/__pycache__/dom.cpython-37.pyc,,
> -pip/_vendor/html5lib/treebuilders/__pycache__/etree_lxml.cpython-37.pyc,,
[…]
This looks like the output is not ordered; maybe it’s the result of
readdir, which can return files in arbitrary order. We’ll need to find
the code responsible for generating these RECORD files and patch it to
sort the result of readdir.
On to Guile:
Toggle quote (4 lines)
> Binary files /gnu/store/9alic3caqhay3h8mx4iihpmyj6ymqpcx-guile-2.2.4/lib/guile/2.2/ccache/ice-9/suspendable-ports.go and /tmp/guile/lib/guile/2.2/ccache/ice-9/suspendable-ports.go differ
> Binary files /gnu/store/9alic3caqhay3h8mx4iihpmyj6ymqpcx-guile-2.2.4/lib/guile/2.2/ccache/ice-9/vlist.go and /tmp/guile/lib/guile/2.2/ccache/ice-9/vlist.go differ
> Binary files /gnu/store/9alic3caqhay3h8mx4iihpmyj6ymqpcx-guile-2.2.4/lib/guile/2.2/ccache/srfi/srfi-19.go and /tmp/guile/lib/guile/2.2/ccache/srfi/srfi-19.go differ
I wonder if this is related to non-deterministic behaviour of macro expansion…?
Toggle quote (13 lines)
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/gnu/ci.go and /tmp/guix-cli/gnu/ci.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/build.go and /tmp/guix-cli/guix/scripts/build.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/challenge.go and /tmp/guix-cli/guix/scripts/challenge.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/describe.go and /tmp/guix-cli/guix/scripts/describe.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/import/pypi.go and /tmp/guix-cli/guix/scripts/import/pypi.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/lint.go and /tmp/guix-cli/guix/scripts/lint.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/offload.go and /tmp/guix-cli/guix/scripts/offload.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/pack.go and /tmp/guix-cli/guix/scripts/pack.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/processes.go and /tmp/guix-cli/guix/scripts/processes.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/publish.go and /tmp/guix-cli/guix/scripts/publish.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/substitute.go and /tmp/guix-cli/guix/scripts/substitute.go differ
> Binary files /gnu/store/cz9pln04cax43rdd9x7k9l7wlldzm7k3-guix-cli/guix/scripts/weather.go and /tmp/guix-cli/guix/scripts/weather.go differ
These are all files relating to “guix pull”. You listed other outputs
that are the result of work performed by “guix pull”. I suspect that
there’s something wrong about the environment in which “guix pull”
operates.
--
Ricardo