[PATCH] - updated lisp library unix-opts.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Maxime Devos
Owner
unassigned
Submitted by
cage
Severity
normal
Merged with
C
(address . guix-patches@gnu.org)
YJbKbNQN7XVHlXeM@kurosawa.casa.net
Hi!

I found this library outdated, this patch makes guix uses a commit with
new features added.

Bye!
C.

---
gnu/packages/lisp-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0824fa1d82..275517654f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3276,19 +3276,21 @@ settings ensure a very simple mode of operation, similar to that provided by
(sbcl-package->ecl-package sbcl-cl-json))
(define-public sbcl-unix-opts
+ (let ((commit "0e61f34b2ecf62288437810d4abb31e572048b04")
+ (revision "1"))
(package
(name "sbcl-unix-opts")
- (version "0.1.7")
+ (version (git-version "0.1.7" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/libre-man/unix-opts")
- (commit version)))
+ (commit commit)))
(file-name (git-file-name "unix-opts" version))
(sha256
(base32
- "08djdi1ard09fijb7w9bdmhmwd98b1hzmcnjw9fqjiqa0g3b44rr"))))
+ "16mcqpzwrz808p9n3wwl99ckg3hg7yihw08y1i4l7c92aldbkasq"))))
(build-system asdf-build-system/sbcl)
(home-page "https://github.com/hankhero/cl-json")
(synopsis "Unix-style command line options parser")
--
2.31.1
M
M
Maxime Devos wrote on 8 May 2021 23:28
2f8fc5428e3d4069e8822dc8cb3f5d1fac16a719.camel@telenet.be
cage schreef op za 08-05-2021 om 19:29 [+0200]:
Toggle quote (5 lines)
> Hi!
>
> I found this library outdated, this patch makes guix uses a commit with
> new features added.

There is a strong preference for only using versions that are ‘official releases’
‘blessed’ by upstream, and not some random commit, unless there are compelling
reasons to do otherwise.

I see the 0.1.7 commit dates from 2017. If there are new features and/or bug fixes,
maybe ask upstream to make a new release? If there are important bug fixes and
upstream doesn't feel ready for a new release, we can cherry-pick the bug fixes
via the 'patches' mechanism.

Or maybe we could just use the commit, I dunno. But then a comment should be added
explaining why a particular commit is used instead of an official release.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYJcCbBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tsjAQDoCxzWozMAQJUY7yAPeyroZpMH
VRUgrZ6ZXV9QANReBwD6AkUJd+gGo3lDS9i/GCda3LfiAX3tMOYJCvPawpF5zQY=
=S1LN
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 8 May 2021 23:29
Re: [bug#48292] [PATCH] - updated lisp library unix-opts.
(address . control@debbugs.gnu.org)
b5e07d00af986e01d1785cff22d7621422f69fd7.camel@telenet.be
merge 48291 48292
thanks
C
Re: [bug#48291] [PATCH] - updated lisp library unix-opts.
(name . Maxime Devos)(address . maximedevos@telenet.be)
YJe1GIclCkuUN6ug@kurosawa.casa.net
Hi!

[...]

Toggle quote (5 lines)
>
> There is a strong preference for only using versions that are ‘official releases’
> ‘blessed’ by upstream, and not some random commit, unless there are compelling
> reasons to do otherwise.

I can totally see the point here, i have sent this patch because
another program i have packaged (tinmop) uses a new version of this
library and simply crash if called with any command line switch. :(

So i have asked upstream to tag the current commit (or any commit they
choose, of course) as new release,


so i suppose we just have to wait. :)

Thanks for your reply!
C.
?