[PATCH] - updated lisp library unix-opts.

  • Done
  • quality assurance status badge
Details
3 participants
  • cage
  • Guillaume Le Vaillant
  • Maxime Devos
Owner
unassigned
Submitted by
cage
Severity
normal
Merged with

Debbugs page

cage wrote 4 years ago
(address . guix-patches@gnu.org)
YJbM/5D9H/Uwj+w2@kurosawa.casa.net
Hi!

I found this library outdated, this patch makes guix uses a commit with
new features added.

Bye!
C.

PS: please ignore my previous patch (#48291) for this library as there is a syntax
error :(


---
gnu/packages/lisp-xyz.scm | 40 ++++++++++++++++++++-------------------
1 file changed, 21 insertions(+), 19 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0824fa1d82..e267840ffe 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3276,31 +3276,33 @@ settings ensure a very simple mode of operation, similar to that provided by
(sbcl-package->ecl-package sbcl-cl-json))
(define-public sbcl-unix-opts
- (package
- (name "sbcl-unix-opts")
- (version "0.1.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libre-man/unix-opts")
- (commit version)))
- (file-name (git-file-name "unix-opts" version))
- (sha256
- (base32
- "08djdi1ard09fijb7w9bdmhmwd98b1hzmcnjw9fqjiqa0g3b44rr"))))
- (build-system asdf-build-system/sbcl)
- (home-page "https://github.com/hankhero/cl-json")
- (synopsis "Unix-style command line options parser")
- (description
- "This is a minimalistic parser of command line options. The main
+ (let ((commit "0e61f34b2ecf62288437810d4abb31e572048b04")
+ (revision "1"))
+ (package
+ (name "sbcl-unix-opts")
+ (version (git-version "0.1.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libre-man/unix-opts")
+ (commit commit)))
+ (file-name (git-file-name "unix-opts" version))
+ (sha256
+ (base32
+ "16mcqpzwrz808p9n3wwl99ckg3hg7yihw08y1i4l7c92aldbkasq"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/hankhero/cl-json")
+ (synopsis "Unix-style command line options parser")
+ (description
+ "This is a minimalistic parser of command line options. The main
advantage of the library is the ability to concisely define command line
options once and then use this definition for parsing and extraction of
command line arguments, as well as printing description of command line
options (you get --help for free). This way you don't need to repeat
yourself. Also, @command{unix-opts} doesn't depend on anything and
precisely controls the behavior of the parser via Common Lisp restarts.")
- (license license:expat)))
+ (license license:expat))))
(define-public cl-unix-opts
(sbcl-package->cl-source-package sbcl-unix-opts))
--
2.31.1
Maxime Devos wrote 4 years ago
(address . control@debbugs.gnu.org)
b5e07d00af986e01d1785cff22d7621422f69fd7.camel@telenet.be
merge 48291 48292
thanks
cage wrote 3 years ago
updating code
(address . 48292@debbugs.gnu.org)
YadSgR+CNbiwESO3@kurosawa.casa.net
Hi!

As there has not been any response from upstream, i wonder if this decision can be reconsidered and the git version of 'unix-opts' packaged.

The reason for this request is because the gemini browser tinmop (packaged in guix) does not works with such older version of 'unix-opts'.

Thanks in advance!
C.
Guillaume Le Vaillant wrote 3 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 48292-done@debbugs.gnu.org)
87o8608q1o.fsf@kitej
Patch pushed as 8e7e839c98102a79b5804b39e3cfb58e94687d97 with a modified
commit message.
Thanks.

We'll switch back to using a tag if upstream decides to make one some
day.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYadrIw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/GPQD9EuUukuRbrVoAXRmKkocg+c40oQ3Piyi+iJeH
YK3H++YA/34DywY3cxPR6I0GOhRrBzZNvQnC43Ih6/iLZ3UmLeMb
=wzdu
-----END PGP SIGNATURE-----

Closed
cage wrote 3 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 48292-done@debbugs.gnu.org)(name . cage)(address . cage-dev@twistfold.it)
YaeeAVAhItTScy7Q@kurosawa.casa.net
On Wed, Dec 01, 2021 at 12:29:50PM +0000, Guillaume Le Vaillant wrote:
Toggle quote (7 lines)
> Patch pushed as 8e7e839c98102a79b5804b39e3cfb58e94687d97 with a modified
> commit message.
> Thanks.
>
> We'll switch back to using a tag if upstream decides to make one some
> day.

That's a great news for me, thanks!

I am preparing a few patches for other library the new version of tinmop needs, i believe updating these libraries could be useful for other people too! :)
Bye!
C.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48292@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48292
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help