cabal-install/GHC fails to find libraries

  • Done
  • quality assurance status badge
Details
3 participants
  • John Soo
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 22 Jul 2020 20:45
(address . bug-guix@gnu.org)
875zafcrt9.fsf@asu.edu
Hi Guix,

I have a haskell project until recently compiled with the following:

env -u GHC_PACKAGE_PATH cabal new-build

Now it fails with the following:

ld: cannot find -lm
ld: cannot find -lpthread
ld: cannot find -lz
ld: cannot find -lrt
ld: cannot find -lutil
ld: cannot find -ldl
ld: cannot find -lpthread
ld: cannot find -lm
ld: cannot find -lrt
ld: cannot find -ldl
ld: cannot find -lpthread
ld: cannot find -lpthread
ld: cannot find -lpthread
ld: cannot find -lc

Could a graft be failing to update references to various libraries?

I really don't know what could be going on.

Thanks!

John
R
R
Ricardo Wurmus wrote on 22 Jul 2020 23:51
(name . John Soo)(address . jsoo1@asu.edu)(address . 42480@debbugs.gnu.org)
87zh7rz09q.fsf@elephly.net
John Soo <jsoo1@asu.edu> writes:

Toggle quote (6 lines)
> I have a haskell project until recently compiled with the following:
>
> env -u GHC_PACKAGE_PATH cabal new-build
>
> Now it fails with the following: [ld errors]

Do you have “gcc-toolchain” installed?

--
Ricardo
J
J
John Soo wrote on 23 Jul 2020 01:43
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 42480@debbugs.gnu.org)
87zh7rt8sz.fsf@asu.edu
Hi Ricardo,

I do have gcc-toolchain installed and I just realized that my project
compiles fine if I do not try to statically link. I believe this can be
closed as dynamic linking works fine. My mistake. I did see the issue
regarding captured inputs to ghc. I am in favor of removing them. I
always must have gcc-toolchain installed when using ghc anyways.

Thanks again,

John
S
S
Simon Tournier wrote on 22 Sep 2023 18:16
(name . John Soo)(address . jsoo1@asu.edu)
875y4289p0.fsf@gmail.com
Hi

I think this old bug#42480,


can be closed.

On Wed, 22 Jul 2020 at 16:43, John Soo <jsoo1@asu.edu> wrote:

Toggle quote (6 lines)
> I do have gcc-toolchain installed and I just realized that my project
> compiles fine if I do not try to statically link. I believe this can be
> closed as dynamic linking works fine. My mistake. I did see the issue
> regarding captured inputs to ghc. I am in favor of removing them. I
> always must have gcc-toolchain installed when using ghc anyways.

Adding gcc-toolchain fixes the issue.

I am closing. Let me know if I am missing something.


Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42480@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42480
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch