ruby: Add 2.7.3.

  • Done
  • quality assurance status badge
Details
5 participants
  • Diego Nicola Barbato
  • Thompson, David
  • Ludovic Courtès
  • Christopher Baines
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 3 May 2020 01:25
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
SU9SP1GK5ozN3dN1IbeZUa5ZoKn4OaknSmtIwyUgE1fVQxqE_kwEIeDhexuNNh-12mB4SmxOy_1hI86iYDwHrvkTQ_l5UNS3FhK2XvVFL6Y=@protonmail.com
This patch adds Ruby 2.7.3, the latest release.
Attachment: file
From 0c10fb29338bc118c3fa442615aa6217960bb03b Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Sat, 2 May 2020 18:17:00 -0500
Subject: [PATCH] gnu: Add ruby-2.7.

---
gnu/packages/ruby.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4d6d323442..67f344301c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -128,6 +128,48 @@ a focus on simplicity and productivity.")
(home-page "https://www.ruby-lang.org")
(license license:ruby)))
+(define-public ruby-2.7
+ (package
+ (inherit ruby)
+ (version "2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
+ (version-major+minor version)
+ "/ruby-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0674x98f542y02r7n2yv2qhmh97blqhi2mvh2dn5f000vlxlh66l"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ ;; Remove bundled libffi
+ (delete-file-recursively "ext/fiddle/libffi-3.2.1")
+ #t))))
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'replace-bin-sh-and-remove-libffi
+ (lambda _
+ (substitute* '("configure.ac"
+ "template/Makefile.in"
+ "lib/rubygems/installer.rb"
+ "ext/pty/pty.c"
+ "io.c"
+ "lib/mkmf.rb"
+ "process.c"
+ "test/rubygems/test_gem_ext_configure_builder.rb"
+ "test/rdoc/test_rdoc_parser.rb"
+ "test/ruby/test_rubyoptions.rb"
+ "test/ruby/test_process.rb"
+ "test/ruby/test_system.rb"
+ "tool/rbinstall.rb")
+ (("/bin/sh") (which "sh")))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)))))
+
(define-public ruby-2.4
(package
(inherit ruby)
--
2.17.1
R
R
Ryan Prior wrote on 3 May 2020 01:34
ruby: Add ruby-2.5 as an alias to ruby
(name . 41036@debbugs.gnu.org)(address . 41036@debbugs.gnu.org)
0Tf73-aW68ntY7sZUordbO84IwGThyoKZ6Nlv_rrl7RqBur9h9evoN9s6HuDhZZcGjs76mgSN_8aIvYAeFU3zgy8wNeJS0XhQ6xzR6KQjeQ=@protonmail.com
The current ruby in Guix is 2.5, this alias allows to explicitly depend on ruby@2.5.
Attachment: file
From 1dc232f14c8743fa0bd253ca470ef5f16c6baa0c Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Sat, 2 May 2020 18:18:00 -0500
Subject: [PATCH] gnu: Add ruby-2.5 as an alias to ruby.

---
gnu/packages/ruby.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 67f344301c..f9e687e775 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -170,6 +170,8 @@ a focus on simplicity and productivity.")
(native-inputs
`(("autoconf" ,autoconf)))))
+(define-public ruby-2.5 ruby)
+
(define-public ruby-2.4
(package
(inherit ruby)
--
2.17.1
R
R
Ryan Prior wrote on 3 May 2020 01:34
ruby: Update to 2.7.3
(name . 41036@debbugs.gnu.org)(address . 41036@debbugs.gnu.org)
D8B3EvY7sfpXMoK0_e6aD-G3eLizVuwzuKqTb1SxvrSiuF3xePrYUXcys-fgxLYkh3TewK92xlsOukDxtz3Vz84xBImPV_QahqFLCNIcYjs=@protonmail.com
Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.
Attachment: file
From 0f61f3897a69e8c1cd46a10dc710028d6de03962 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Sat, 2 May 2020 18:22:31 -0500
Subject: [PATCH] gnu: ruby: Update to 2.7.3.

---
gnu/packages/ruby.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f9e687e775..455469b03c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -74,7 +74,7 @@
#:use-module (guix build-system ruby)
#:use-module ((srfi srfi-1) #:select (alist-delete)))
-(define-public ruby
+(define-public ruby-2.5
(package
(name "ruby")
(version "2.5.3")
@@ -130,7 +130,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.7
(package
- (inherit ruby)
+ (inherit ruby-2.5)
(version "2.7.1")
(source
(origin
@@ -170,7 +170,7 @@ a focus on simplicity and productivity.")
(native-inputs
`(("autoconf" ,autoconf)))))
-(define-public ruby-2.5 ruby)
+(define-public ruby ruby-2.7)
(define-public ruby-2.4
(package
--
2.17.1
L
L
Ludovic Courtès wrote on 7 May 2020 09:47
(name . Ryan Prior)(address . rprior@protonmail.com)(name . 41036@debbugs.gnu.org)(address . 41036@debbugs.gnu.org)
87v9l8dw4e.fsf@gnu.org
Hi,

Ryan Prior <rprior@protonmail.com> skribis:

Toggle quote (2 lines)
> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.

‘guix refresh -l ruby@2.5’ says there are 4K packages depending on it
(which I didn’t expect). So this change should probably go to the next
‘core-updates’ according to our guidelines (info "(guix) Submitting
Patches").

Did you have a chance to test the impact of this change on Ruby
packages? Perhaps you should ping other people who last upgraded Ruby.

Thanks,
Ludo’.
R
R
Ryan Prior wrote on 7 May 2020 21:27
87lfm3bl6m.fsf@protonmail.com
Hi there! I'm Ryan Prior, a rubyist and Guix maintainer. I'm writing you
because I'd like your feedback on my patches to add Ruby 2.7.3 to Guix
and eventually to make that the default version of Ruby. I got your
email address from the Ruby package in Guix master.

You can find my version of the Ruby package here:

Discussion is in the Guix issue tracker here:

Thank you for contributing to Ruby and Guix, I appreciate your time!


Ludovic Courtès (cc'd) <ludo@gnu.org> writes:

Toggle quote (5 lines)
> ‘guix refresh -l ruby@2.5’ says there are 4K packages depending on it
> (which I didn’t expect). So this change should probably go to the next
> ‘core-updates’ according to our guidelines (info "(guix) Submitting
> Patches").

I think it's a high priority to get 2.7 into Guix so people can start
testing it and building off of it, but fine to hold off
making it the default until the next core-update cycle.

Toggle quote (4 lines)
> Did you have a chance to test the impact of this change on Ruby
> packages? Perhaps you should ping other people who last upgraded
> Ruby.

I've tried a few core things like irb and bundler but have yet to
undertake a more serious testing plan.

Thank you for the suggestion Ludo!


Warmly,
Ryan Prior
D
D
Diego Nicola Barbato wrote on 12 May 2020 10:10
(name . Ryan Prior)(address . rprior@protonmail.com)
871rnpmv42.fsf@GlaDOS.home
Hey Ryan,

Ryan Prior <rprior@protonmail.com> writes:

Toggle quote (5 lines)
> Hi there! I'm Ryan Prior, a rubyist and Guix maintainer. I'm writing you
> because I'd like your feedback on my patches to add Ruby 2.7.3 to Guix
> and eventually to make that the default version of Ruby. I got your
> email address from the Ruby package in Guix master.

The only reason for my copyright line in gnu/packages/ruby.scm is that I
added the package ruby-wayback-machine-downloader [0] for which I used
the importer. I know almost nothing about Ruby.

You might get more helpful feedback from the people who have contributed
to the Ruby package itself [1].

[...]

HTH,

Diego

T
T
Thompson, David wrote on 12 May 2020 14:47
Re: [EXT] [bug#41036] ruby: Update to 2.7.3
(name . 41036@debbugs.gnu.org)(address . 41036@debbugs.gnu.org)
CAJ=RwfZoD_oWx4+2VW7o2G443kJwUTpn7hmj8fcBohwt+t-9=g@mail.gmail.com
On Sat, May 2, 2020 at 7:35 PM Ryan Prior via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (3 lines)
>
> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.

According to the Ruby releases page the latest release is 2.7.1, not
2.7.3. Am I missing something?


- Dave
R
R
Ryan Prior wrote on 12 May 2020 19:55
(name . Thompson, David)(address . dthompson2@worcester.edu)(name . 41036@debbugs.gnu.org)(address . 41036@debbugs.gnu.org)
875zd12g3e.fsf@protonmail.com
Thompson, David <dthompson2@worcester.edu> writes:

Toggle quote (8 lines)
> On Sat, May 2, 2020 at 7:35 PM Ryan Prior via Guix-patches via
> <guix-patches@gnu.org> wrote:
>>
>> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.
>
> According to the Ruby releases page the latest release is 2.7.1, not
> 2.7.3. Am I missing something?

Hi David, I think I got confused when writing my email to debbugs. The
package says 2.7.1, which is correct, and all references in email
correspondence and patch titles to 2.7.3 should have been to 2.7.1.

Thank you for the correction!

Ryan
C
C
Christopher Baines wrote on 13 May 2020 19:54
Re: [bug#41036] ruby: Add 2.7.3.
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 41036@debbugs.gnu.org)
87pnb7oh46.fsf@cbaines.net
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> This patch adds Ruby 2.7.3, the latest release.

Hi Ryan,

Thanks for the patch, I've tweaked this to also pass --enable-shared to
ruby-2.7, as that's done for Ruby 2.6. I've pushed this to the master
branch as [1].

1: 1cc7d3404f8b6b9bf0407e4c752c38fcc188cdba

Perhaps we can use this bug now to track getting Ruby 2.7 as the default
Ruby in Guix. As Ludo said in a previous message, that'll need to happen
on core-updates, which I'll start looking in to...

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl68NFlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xe3Vg//e4wbVWNWuOtN7VuxJvm5j/tTnnmJfr5O2eNEB8JEOle1txNakC9196Yt
lMxJOloRsixfGhEdwbEF7B9FPW9ap+HIM2LnuqFO4QN5pALUXhSgyvCK+5cmtPOO
/BEzFpJH7j+kOvqjaYSCQCEZwV437RFJ0Yt23zQMMjWXjKV1cmTAw/37N7v57VZS
hcYpbulEyi6zp8Z29AtkgPYLteQn6tWqlpHStvVztzWxVzWWZV28CPSTuPFRr70s
6+C5r/H9zea8YR7TW84Ju2K5Y54aKIUOAwBV6bSY4OaOnLUu05IcbihSKlAGxZTF
xDM7FpHro//yvmVi3J6ZUHdbknPK/xUXxVviBJqfU+7gnwWT83zvb8BVE9emgbym
5WeIfpwClrea3EC49T0sYd4gJc7O3Ly4kDebhvDwqqUIf8tL92Z3MBlm6ZVCTmnp
F7K2q4nLzH+H4kM7B632P7n+b3ePYyjWWrL+xvXJL9rlCq/vX3n8wygb5HawSbJY
Yr+kinsNB6e737zdVXsqbSH8bGP9OJYHpuRRYEzGwDSpp6Sv9odx8YY+vK8DGukA
+heEmZ5tKg1rV0LmAdsZzx1m3kljNsBEIDHLQnXxflf0IB4QSg7eUcR3oyL+2bN6
VHBn8zQglGnPaC4i7y1F8FhwYMaOkMpKqo40waG3oOZ0WAebtNk=
=l7m/
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 17 Jun 2020 12:03
(name . Christopher Baines)(address . mail@cbaines.net)
871rmerou9.fsf@gnu.org
Hi Christopher,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (16 lines)
> Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:
>
>> This patch adds Ruby 2.7.3, the latest release.
>
> Hi Ryan,
>
> Thanks for the patch, I've tweaked this to also pass --enable-shared to
> ruby-2.7, as that's done for Ruby 2.6. I've pushed this to the master
> branch as [1].
>
> 1: 1cc7d3404f8b6b9bf0407e4c752c38fcc188cdba
>
> Perhaps we can use this bug now to track getting Ruby 2.7 as the default
> Ruby in Guix. As Ludo said in a previous message, that'll need to happen
> on core-updates, which I'll start looking in to...

Would now be a good time to apply it?

Thanks,
Ludo’.
C
C
Christopher Baines wrote on 19 Jun 2020 10:54
(address . 41036@debbugs.gnu.org)
874kr7mo4t.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
> Hi Christopher,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:
>>
>>> This patch adds Ruby 2.7.3, the latest release.
>>
>> Hi Ryan,
>>
>> Thanks for the patch, I've tweaked this to also pass --enable-shared to
>> ruby-2.7, as that's done for Ruby 2.6. I've pushed this to the master
>> branch as [1].
>>
>> 1: 1cc7d3404f8b6b9bf0407e4c752c38fcc188cdba
>>
>> Perhaps we can use this bug now to track getting Ruby 2.7 as the default
>> Ruby in Guix. As Ludo said in a previous message, that'll need to happen
>> on core-updates, which I'll start looking in to...
>
> Would now be a good time to apply it?

Yep, I've tried just now, but I was unsuccessful. Unfortunately I'm not
familiar with dealing with patches, and I couldn't seem to get this one
to apply at all.

Ryan, would you be able to rebase the relevant commit and share an
updated patch, that might help me apply it. Also, if there's a branch I
can pull from, that works as well.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7sfVJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XftvhAAmOn3X67jPGjMzOo+k3zmXQvfjXeERLGqyZgduaOLll9c3WuMJvdcM97/
cuy/I94S4dkTRvKGzN2gUEhuP/P9kuaxeSW/PRqs9CwXOIkuVtXinJZTf19XoEvm
DhmHV8JMQ+BvY5CYojkfqxIPBjWQf796DiYDXAZ7/p/9pJ014+zGsJOxF4jXSfv5
mpB1tpWs7/uG0A+ISHWojqjiarH7jth66EYCX18fvEkjPpBpl+lazBSUR/4WdeZM
mzDIDqcWe8XUFvJlsOlqbrtQnweyEiDXx9kNG2GAHadgtHsJWKLavXJ9TAKb0ECE
p7WzMUYV0W6Mzv6G3hVy5L67KVCU9KeC8j0HKB8uK6eEU6B77qNaQQYopym8hpY5
c8i2/FYq/FAHSeDVJqCBOuJ1LSjMycdPYRsWkHIe1yFJfSC4X6NQZgNUQA7QDHeF
b6285DM1FMZkpfxskIDR2bpPHclDE2CWpvoXtkMmfbRRck8+ZK/uk2p18PCWM9zM
2BA8uIBnHuUPmgXPXGRbwQ8tRhk1GU/POXVi1C6NkIm7qZ7u4YYLDFnfvfPfTNzJ
sezxusN/LCcATv5dEQiyET5LlYZqvmfL95xKLVGFTNDpZGmxkWQ3mjpII0xBwsDH
wgR6iSbAbPrqoV0sRqthCQUh0N0qVIBatkGbhB2qFMYe7y7sCsI=
=8GZh
-----END PGP SIGNATURE-----

R
R
Ryan Prior wrote on 21 Jun 2020 05:02
[PATCH 0/2] New patches to update Ruby to 2.7
(address . 41036@debbugs.gnu.org)
20200621030211.21346-1-rprior@protonmail.com
Here are the new patches you asked for, they should apply cleanly to master.

Ryan Prior (2):
gnu: Renames ruby to ruby-2.6.
gnu: Ruby: Update to 2.7.

gnu/packages/ruby.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

--
2.26.2
R
R
Ryan Prior wrote on 21 Jun 2020 05:02
[PATCH 1/2] gnu: Renames ruby to ruby-2.6.
(address . 41036@debbugs.gnu.org)
20200621030211.21346-2-rprior@protonmail.com
* gnu/packages/ruby.scm (ruby): Rename to ruby-2.6.
* gnu/packages/ruby.scm (ruby-2.7): Inherit from ruby-2.6.
* gnu/packages/ruby.scm (ruby-2.5): Inherit from ruby-2.6.
* gnu/packages/ruby.scm (ruby-2.4): Inherit from ruby-2.6.
---
gnu/packages/ruby.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 08c55e4e3c..a0fae70cc6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -75,7 +75,7 @@
#:use-module (guix build-system ruby)
#:use-module ((srfi srfi-1) #:select (alist-delete)))
-(define-public ruby
+(define-public ruby-2.6
(package
(name "ruby")
(version "2.6.5")
@@ -133,7 +133,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.7
(package
- (inherit ruby)
+ (inherit ruby-2.6)
(version "2.7.1")
(source
(origin
@@ -176,7 +176,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.5
(package
- (inherit ruby)
+ (inherit ruby-2.6)
(version "2.5.8")
(source
(origin
@@ -195,7 +195,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.4
(package
- (inherit ruby)
+ (inherit ruby-2.6)
(version "2.4.10")
(source
(origin
@@ -212,6 +212,8 @@ a focus on simplicity and productivity.")
(delete-file-recursively "ext/fiddle/libffi-3.2.1")
#t))))))
+(define-public ruby ruby-2.6)
+
(define-public mruby
(package
(name "mruby")
--
2.26.2
R
R
Ryan Prior wrote on 21 Jun 2020 05:02
[PATCH 2/2] gnu: Ruby: Update to 2.7.
(address . 41036@debbugs.gnu.org)
20200621030211.21346-3-rprior@protonmail.com
* gnu/packages/ruby.scm (ruby): Update to 2.7.
---
gnu/packages/ruby.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a0fae70cc6..b76b5fe411 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -212,7 +212,7 @@ a focus on simplicity and productivity.")
(delete-file-recursively "ext/fiddle/libffi-3.2.1")
#t))))))
-(define-public ruby ruby-2.6)
+(define-public ruby ruby-2.7)
(define-public mruby
(package
--
2.26.2
C
C
Christopher Baines wrote on 24 Jun 2020 22:28
Re: [bug#41036] [PATCH 0/2] New patches to update Ruby to 2.7
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 41036-done@debbugs.gnu.org)
87eeq46we4.fsf@cbaines.net
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (9 lines)
> Here are the new patches you asked for, they should apply cleanly to master.
>
> Ryan Prior (2):
> gnu: Renames ruby to ruby-2.6.
> gnu: Ruby: Update to 2.7.
>
> gnu/packages/ruby.scm | 10 ++++++----
> 1 file changed, 6 insertions(+), 4 deletions(-)

Great, thanks.

I've tweaked the commit messages a bit, and now pushed these patches to
core-updates.

I think the way ruby-2.7 inherits from ruby-2.6 is a bit odd, but I like
that this change is small in terms of the diff. Anyway, how to lay out
the package definitions is a lesser issue compared to what's actually
defined.

Now comes the challenge of actually fixing all the packages this change
will have broken. If updates to packages that fix issues with Ruby 2.7
don't cause too many rebuilds or break anything on master, then pushing
those to master is good. The master branch can then be merged in to
core-updates to get those changes applied there as well. Otherwise, the
fixes should be applied to core-updates.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl7zt4NfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfqexAAi0M3Wnf1nUf0iGmH3Hm/2YlyDR1uvp9FXgdtbOg/JpfO3vamEoeyvz60
Hd5vGbkL8ZckIwYXza8eaARmpMLJpBuUwaRZH+Nw5APlabDbBUfMbmP7Y9IwJ0tX
vgCjgEqgvNguCkLEhT20JSEbitIQhL0NWExySmowR1N6gA/BLVjAcgzJzBy0UGD5
cBLKGnqp6MZm7JCDNwddP0HSVL2Z5wx3NV3imQh2yZPfRRrTCc42jkqlYfyOoj/o
mhwI4v5w7sATcZ9A3N9cJeTBgObDDgtD1Jnf0NxvFvVlt3d2CaBxHO5xP6ECkgnY
LPQRV0GUUfarkp7BX+er71LbpSU0VzIQp2XYvNaovGIU2D+nEuOp5nvJCoIEz8iU
jOwwSJn+gvOCxXLOvDqx7JNs7/Oj++rV1fTKpBNHz29deBDsWmHI3HEmUCWOOWWJ
jsnaq0ZIgu5tiqwo313LIKeqnSHIsxw0RNivM9FIkZL/OnlfhI0AAaREN/2vNdWT
7q/I2dBFH2O+xpQzGxgLXrCg2GnmxnvftVlu0jiTUni3o+JarSq1DgUniRT/dSBY
qAkqjbpuuz/RXXIgWwp86F5Pq7dhuC1kzCa3PHzfBsnHresFvQMZs0VJQ4h8MEyW
q+I0dfaWVpADk1S1VV7vCjGgUpIRBzuATJHbqqvUD1VqFILDGxU=
=ACye
-----END PGP SIGNATURE-----

Closed
?