(address . guix-patches@gnu.org)
On 2020-03-22, Vagrant Cascadian wrote:
Toggle quote (26 lines)
> On 2020-03-19, Vagrant Cascadian wrote:
>> I've been working on trying to get a mainline or nearly mainline kernel
>> working for pinebook pro, and there's a little better support in
>> linux-libre 5.5.
>>
>> According to:
>>
>> https://linux-libre.fsfla.org/pub/linux-libre/releases/
>>
>> The 5.5 patches have been available since late January, and seem to be
>> getting regular updates as needed.
>>
>> So far, I haven't had time to test and update linux-libre 5.5 with the
>> kernel configs and so on, so I've been working on a
>> linux-libre-arm64-generic package that uses the defconfig (much like
>> linux-libre-arm-generic) and linux-libre 5.5.x.
>
> I was able to test linux-libre 5.5.10 on x86_64 by copying the 5.4
> kernel config over to 5.5 and building, and it seemed to work fine.
>
> I also did a build of linux-libre-arm-generic using 5.5.10, and it
> seemed to work fine as well.
>
> It also occurs to me that it would be nice to get a newer kernel into
> the upcoming release, unless there's a reason not to...
Updated patch series, which also includes updating the default
linux-libre to 5.5.
I haven't done a full audit of the changes from 5.4 to 5.5 in the kernel
config files generated, but these at least booted on x86_64, aarch64 and
armhf.
live well,
vagrant
From b0b7a8764f1c9cd7f680f55540ceb4d87c9def55 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 14 Mar 2020 18:54:50 -0700
Subject: [PATCH 1/4] gnu: Add linux-libre 5.5.
* gnu/packages/linux (deblob-scripts-5.5): New variable.
(linux-libre-5.5-version): New variable.
(linux-libre-5.5-pristine-source): New variable.
(linux-libre-5.5-source): New variable.
(linux-libre-headers-5.5): New variable.
(linux-libre-5.5): New variable.
---
gnu/packages/linux.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (70 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 27ea07bd48..4bea38abc3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -192,6 +192,12 @@ defconfig. Return the appropriate make target if applicable, otherwise return
"deblob-check"))
(sha256 deblob-check-hash))))
+(define deblob-scripts-5.5
+ (linux-libre-deblob-scripts
+ "5.5.10"
+ (base32 "1vj3rnrbkhj86lkabhrcm8qiqcz1lqi0lk54ysmg3lanf2vqgvab")
+ (base32 "1j44hx6kis6gz9r6yb0s3f17ham24qv0nih6sxsnd2gwxdsid535")))
+
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
"5.4.19"
@@ -362,6 +368,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
+(define-public linux-libre-5.5-version "5.5.10")
+(define-public linux-libre-5.5-pristine-source
+ (let ((version linux-libre-5.5-version)
+ (hash (base32 "08zw437i7zb4s90pciis843xvilgmbxbrkmq2alnyxnrswsqw7g3")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.5)))
+
(define-public linux-libre-5.4-version "5.4.27")
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
@@ -430,6 +444,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.5-source
+ (source-with-patches linux-libre-5.5-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source
(list %boot-logo-patch
@@ -525,6 +544,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.5
+ (make-linux-libre-headers* linux-libre-5.5-version
+ linux-libre-5.5-source))
+
(define-public linux-libre-headers-5.4
(make-linux-libre-headers* linux-libre-5.4-version
linux-libre-5.4-source))
@@ -789,6 +812,12 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.5
+ (make-linux-libre* linux-libre-5.5-version
+ linux-libre-5.5-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.4
(make-linux-libre* linux-libre-5.4-version
linux-libre-5.4-source
--
2.20.1
From 3e49cef160ec999cff069d6c287c54277469370c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Mon, 23 Mar 2020 03:01:27 +0000
Subject: [PATCH 3/4] gnu: linux-libre-arm64-generic: Build with linux-libre
5.5.
* gnu/packages/linux (linux-libre-arm64-generic): Use linux-libre 5.5.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 71c1aef627..463e1d9bf9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -912,8 +912,8 @@ It has been modified to remove all non-free binary blobs.")
#:extra-version "arm-omap2plus"))
(define-public linux-libre-arm64-generic
- (make-linux-libre* linux-libre-version
- linux-libre-source
+ (make-linux-libre* linux-libre-5.5-version
+ linux-libre-5.5-source
'("aarch64-linux")
#:defconfig "defconfig"
#:extra-version "arm64-generic"))
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXng2JAAKCRDcUY/If5cW
qnk5AQCeLSYAuwslQBrLMbtxAWXoof1qCwjRhjSawfE8WPFUeQD+NY8g4WF9XKCH
aJD2PIFHSzfXt1Cc3Z+hqWc8Vpwrwgw=
=QBYw
-----END PGP SIGNATURE-----