(address . bug-guix@gnu.org)
Hi Guix,
After a recent pull and system reconfigure, gdm does not start at boot.
Instead, I am left with a text console login. sirgazil also described the
problem on irc, "I just did guix pull and sudo system reconfigure, and GDM
never started after waiting for about 10 minutes. This may be the same
problem gnutec was having yesterday..."
The last known good guix for me is
7842ddcbc118cbc2799e22651732b7cdc06b93ee and the first known bad commit is
df6ce9fcb455ac59372f1025e450005ea3190614.
My operating system config is included below:
Best,
Jack
(use-modules (gnu) (gnu system nss) (gnu services xorg)
(gnu packages linux))
(use-service-modules desktop)
(use-package-modules certs gnome scanner security-token)
(operating-system
(host-name "alperton")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
;; Specify a mapped device for the encrypted root partition.
;; The UUID is that returned by 'cryptsetup luksUUID'.
(mapped-devices
(list (mapped-device
(source (uuid "f7776767-70c9-44e3-9973-c1334d301348"))
(target "alperton_root")
(type luks-device-mapping))))
(file-systems (cons
(file-system
(device (file-system-label "alperton_root"))
(mount-point "/")
(type "ext4")
(dependencies mapped-devices))
%base-file-systems))
(swap-devices (list "/root/swap"))
(users (cons (user-account
(name "jackhill")
(comment "Jack Hill")
(group "users")
(supplementary-groups '("wheel" "netdev"
"audio" "lp" "video"))
(home-directory "/home/jackhill"))
%base-user-accounts))
;; This is where we specify system-wide packages.
(packages (cons* nss-certs ;for HTTPS access
fuse-exfat
bluez
gvfs ;for user mounts
%base-packages))
;; Add GNOME and/or Xfce---we can choose at the log-in
;; screen with F1. Use the "desktop" services, which
;; include the X11 log-in service, networking with
;; NetworkManager, and more.
(services (cons* (service gnome-desktop-service-type)
(bluetooth-service)
(simple-service 'custom-udev-rules udev-service-type (list sane-backends libu2f-host))
%desktop-services))
(firmware %base-firmware)
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))