(address . guix-patches@gnu.org)
This patch updates CMake to version 3.15.5, which fixes some bugs as listed
I've been trying the package built from this patch for some days and it seems
to work ok and indeed fix the issues that were affecting us.
Thanks and cheers!
--
Ivan Vilata i Balaguer -- https://elvil.net/
From 4c0d54331144a6c213d87adc5699d861dd528adc Mon Sep 17 00:00:00 2001
From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
Date: Mon, 4 Nov 2019 11:47:13 -0500
Subject: [PATCH] gnu: CMake: Update to 3.15.5.
* gnu/packages/cmake.scm (cmake-minimal): Update to 3.15.5.
---
gnu/packages/cmake.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..7ab50aa336 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -50,7 +50,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.15.1")
+ (version "3.15.5")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -58,7 +58,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+ "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.23.0