[PATCH] gnu: CMake: Update to 3.15.5.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ivan Vilata i Balaguer
  • Mathieu Othacehe
  • Marius Bakke
Owner
unassigned
Submitted by
Ivan Vilata i Balaguer
Severity
normal
I
I
Ivan Vilata i Balaguer wrote on 4 Nov 2019 17:57
(address . guix-patches@gnu.org)
20191104165746.GJ17621@sax.terramar.selidor.net
This patch updates CMake to version 3.15.5, which fixes some bugs as listed

I've been trying the package built from this patch for some days and it seems
to work ok and indeed fix the issues that were affecting us.

Thanks and cheers!

--
Ivan Vilata i Balaguer -- https://elvil.net/
From 4c0d54331144a6c213d87adc5699d861dd528adc Mon Sep 17 00:00:00 2001
From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
Date: Mon, 4 Nov 2019 11:47:13 -0500
Subject: [PATCH] gnu: CMake: Update to 3.15.5.

* gnu/packages/cmake.scm (cmake-minimal): Update to 3.15.5.
---
gnu/packages/cmake.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..7ab50aa336 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -50,7 +50,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.15.1")
+ (version "3.15.5")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -58,7 +58,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+ "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.23.0
M
M
Mathieu Othacehe wrote on 5 Nov 2019 08:52
(address . guix-patches@gnu.org)
87h83irc8r.fsf@gmail.com
Hello!

Toggle quote (3 lines)
> I've been trying the package built from this patch for some days and it seems
> to work ok and indeed fix the issues that were affecting us.

Your patch seems fine. However, I think it will cause a rebuild of all
cmake based packages (even though they are not listed by guix refresh
-l). So I think we need to wait for the next staging cycle.

Marius, is that correct?

Mathieu
M
M
Marius Bakke wrote on 11 Nov 2019 00:00
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
87eeyfjq11.fsf@devup.no
Mathieu Othacehe <m.othacehe@gmail.com> writes:

Toggle quote (11 lines)
> Hello!
>
>> I've been trying the package built from this patch for some days and it seems
>> to work ok and indeed fix the issues that were affecting us.
>
> Your patch seems fine. However, I think it will cause a rebuild of all
> cmake based packages (even though they are not listed by guix refresh
> -l). So I think we need to wait for the next staging cycle.
>
> Marius, is that correct?

Indeed.

Ivan: if you need the newer CMake on 'master', can you submit a patch
that adds a separate 'cmake-3.15.5' variable? Then you can use that in
cmake-build-system with '#:cmake ,cmake-3.15.5'.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IlnoACgkQoqBt8qM6
VPrNPAf9EXdkqa3M3QLbnXbUV6ImPAu+k6E/pv5dTUczC0bXS8cl+YMgRGYwaKII
YmZdWgnZn2P6/zuj5O0Y2ZW0hjdWgdmp/ZrVu9bDFHFbGmbsHC+KJoo38n5qrI7w
sIwgRQwFU60VxyhDKIf7EnWPb29qtziH+FOv6EiVcxO63Z6jPbGYYwDm5bGDABbl
fEWDRcMD79p/tsqa4WcrGNrDf3maGvJ0fo84+hJqgjGwq7csOrOzJT+su4rttkt6
+vo1+Cmikk37uI8T6NmzDyad+w6uv6NXnSySSSqbK2CVz94xNgIY68Ge5oyMqVP+
CU1Bk6wO9ydD1VKnGFcpR/x4t+Xe8Q==
=IGiR
-----END PGP SIGNATURE-----

I
I
Ivan Vilata i Balaguer wrote on 12 Nov 2019 06:28
(name . Marius Bakke)(address . mbakke@fastmail.com)
20191112052811.GR17621@sax.terramar.selidor.net
Marius Bakke (2019-11-11 00:00:10 +0100) wrote:

Toggle quote (4 lines)
> Ivan: if you need the newer CMake on 'master', can you submit a patch
> that adds a separate 'cmake-3.15.5' variable? Then you can use that in
> cmake-build-system with '#:cmake ,cmake-3.15.5'.

Sure, I'm attaching the patch which I tried and seemed to work (at least for
installing `cmake@3.15.5` explicitly and using it).

Is it ok like this or shall I send it to guix-patches?

Cheers,

--
Ivan Vilata i Balaguer -- https://elvil.net/
From 2d4fc3d0121ef79cbd0f7f3492536f6475ad51e2 Mon Sep 17 00:00:00 2001
From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
Date: Mon, 11 Nov 2019 18:53:23 -0500
Subject: [PATCH] gnu: CMake: Add version 3.15.5.

Add CMake version 3.15.5 but do not replace the existing version to avoid
triggering the rebuild of all CMake-based packages.


* gnu/packages/cmake.scm (cmake-3.15.5): Add CMake 3.15.5.
---
gnu/packages/cmake.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..e2c244c1a7 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -219,6 +219,22 @@ and workspaces that can be used in the compiler environment of your choice.")
(append (search-patches "cmake-curl-certificates.patch")
(origin-patches (package-source cmake))))))))
+(define-public cmake-3.15.5
+ ;; CMake 3.15.5 fixes some issues, but declare another version to
+ ;; avoid triggering the rebuild of all CMake-based packages.
+ ;; See <https://issues.guix.gnu.org/issue/38060>.
+ (package
+ (inherit cmake)
+ (version "3.15.5")
+ (source (origin
+ (inherit (package-source cmake))
+ (uri (string-append "https://www.cmake.org/files/v"
+ (version-major+minor version)
+ "/cmake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
+
(define-public emacs-cmake-mode
(package
(inherit cmake)
--
2.23.0
M
M
Marius Bakke wrote on 15 Nov 2019 19:17
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)
87y2whf1hc.fsf@devup.no
Ivan Vilata i Balaguer <ivan@selidor.net> writes:

Toggle quote (11 lines)
> Marius Bakke (2019-11-11 00:00:10 +0100) wrote:
>
>> Ivan: if you need the newer CMake on 'master', can you submit a patch
>> that adds a separate 'cmake-3.15.5' variable? Then you can use that in
>> cmake-build-system with '#:cmake ,cmake-3.15.5'.
>
> Sure, I'm attaching the patch which I tried and seemed to work (at least for
> installing `cmake@3.15.5` explicitly and using it).
>
> Is it ok like this or shall I send it to guix-patches?

Attaching patches to bug reports is fine. Pushed as
528b52390d216d8a8cd13dfcd1e6e40a6448e6c2.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3O678ACgkQoqBt8qM6
VPrXPQgAiYqWh43rvrqU2vMfEhn3Jo3ZzE4cbsWhtCOwUwk/bNsIGU/nkKNIpyFb
4dyASvIlfSH6kwKeA2tjHlHgqqAMVcVE5NNnHMgTscM8kSc8FJgS2ZtNdXzMQ4Wk
GQ7u0t0ZZRA+9eiyZGPeOwWmr3St0HyorQX3PM6qqb29ZkPV0QdF7WXTkP8Y8xxO
wBZjluvrT3AuulA46fVhkZjkprWxDHu6yYEgeuO4TeWOKmW6kKNrKVMR1TtOOfUJ
Usa6NfylaUX0m3qi2NBbc29/upygMSNoVgmw/4U+/mfZFJNgadVTFMC8x5aIpp5x
tInfj1+Y00BGGfD+rpABHvKogIM8hw==
=CYGK
-----END PGP SIGNATURE-----

Closed
?