[PATCH 0/1] gnu: audacity: Update to 3.6.0.

  • Open
  • quality assurance status badge
Details
5 participants
  • Gabriel Wicki
  • Leo Famulari
  • Ludovic Courtès
  • Nicolas Graves
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 2 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1735565566.git.poptsov.artyom@gmail.com
This patch updates Audacity to the 3.6.0.

I checked audio playback and recording, and it seems to work okay, but when I
try to open an mp4 file it says that I need to compile Audacity with FFMpeg
support. Although in "Help"->"About Audacity"->"Build Information" dialog it
says that the FFMpeg support is enabled.

The "audacity-ffmpeg-fallback.patch" patch is no longer applies to the source
tree, but Audacity builds fine without the patch.

I appreciate any input on this patch; maybe I overlooked something.

Artyom V. Poptsov (1):
gnu: audacity: Update to 3.6.0.

gnu/local.mk | 1 -
gnu/packages/audio.scm | 6 +-
.../patches/audacity-ffmpeg-fallback.patch | 61 -------------------
3 files changed, 3 insertions(+), 65 deletions(-)
delete mode 100644 gnu/packages/patches/audacity-ffmpeg-fallback.patch


base-commit: e2bac72206b4de5b4c9cf0063ef2afbd848986cf
--
2.47.1
Artyom V. Poptsov wrote 2 months ago
[PATCH 1/1] gnu: audacity: Update to 3.6.0.
(address . 75200@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
fdbac2ca7bd32353a8cf7c91df77e0bdef079934.1735565566.git.poptsov.artyom@gmail.com
* gnu/packages/audio.scm (audacity): Update to 3.6.0.
[patches]: Remove "audacity-ffmpeg-fallback.patch".
* gnu/packages/patches/audacity-ffmpeg-fallback.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.

Change-Id: I411af73bfddf68b5fdbd52272b6253a91e2afd07
---
gnu/local.mk | 1 -
gnu/packages/audio.scm | 6 +-
.../patches/audacity-ffmpeg-fallback.patch | 61 -------------------
3 files changed, 3 insertions(+), 65 deletions(-)
delete mode 100644 gnu/packages/patches/audacity-ffmpeg-fallback.patch

Toggle diff (112 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 838c2a06b3..5123c1f988 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -988,7 +988,6 @@ dist_patch_DATA = \
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
%D%/packages/patches/ath9k-htc-firmware-gcc-compat.patch \
%D%/packages/patches/atlas-gfortran-compat.patch \
- %D%/packages/patches/audacity-ffmpeg-fallback.patch \
%D%/packages/patches/audiofile-fix-datatypes-in-tests.patch \
%D%/packages/patches/audiofile-fix-sign-conversion.patch \
%D%/packages/patches/audiofile-CVE-2015-7747.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c8e22643ee..40508d4ddd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2024 hapster <o.rojon@posteo.net>
;;; Copyright © 2024 mio <stigma@disroot.org>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -918,7 +919,7 @@ (define-public ardour
(define-public audacity
(package
(name "audacity")
- (version "3.5.1") ;for ffmpeg 6 support
+ (version "3.6.0") ;for ffmpeg 6 support
(source
(origin
(method git-fetch)
@@ -927,8 +928,7 @@ (define-public audacity
(commit (string-append "Audacity-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11sjyz6hxsr5dnndkkkiq7arjxvjl1sycl151xq3a3ggakgql3y1"))
- (patches (search-patches "audacity-ffmpeg-fallback.patch"))
+ (base32 "1mdszrdv54737krsdbip84qc0anz83nsbz1hcnymwa09rrcrrlv4"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
diff --git a/gnu/packages/patches/audacity-ffmpeg-fallback.patch b/gnu/packages/patches/audacity-ffmpeg-fallback.patch
deleted file mode 100644
index c845e10277..0000000000
--- a/gnu/packages/patches/audacity-ffmpeg-fallback.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 3c20057d0cbbbed453a692d4dd4589d865808024 Mon Sep 17 00:00:00 2001
-From: Liliana Marie Prikler <liliana.prikler@gmail.com>
-Date: Sat, 29 Jan 2022 10:44:44 +0100
-Subject: [PATCH] Add pkg-config fallback for locating ffmpeg.
-
-Audacity >=3.1.0 no longer links against ffmpeg, but instead dynamically loads
-it. This dynamic loading mechanism fails to properly locate libraries outside
-of LD_LIBRARY_PATH.
-
-See <https://issues.guix.gnu.org/53591>.
-
-Bugs-added-by: Marius Bakke <marius@gnu.org>
-
-diff --git a/libraries/lib-ffmpeg-support/CMakeLists.txt b/libraries/lib-ffmpeg-support/CMakeLists.txt
-index b8803a1f5..f86559cca 100644
---- a/modules/mod-ffmpeg/lib-ffmpeg-support/CMakeLists.txt
-+++ b/modules/mod-ffmpeg/lib-ffmpeg-support/CMakeLists.txt
-@@ -1,5 +1,7 @@
-
- if (${_OPT}use_ffmpeg)
-+ pkg_check_modules(FFMPEG libavcodec libavformat libavutil)
-+
- set( SOURCES
- FFmpegTypes.h
-
-@@ -107,6 +109,12 @@ if (${_OPT}use_ffmpeg)
- list(APPEND DEFINITIONS PRIVATE _DARWIN_C_SOURCE )
- endif()
-
-+ if (FFMPEG_FOUND)
-+ pkg_get_variable(LIBAVCODEC_LIBDIR libavcodec libdir)
-+ list(APPEND DEFINITIONS PRIVATE
-+ "-DFFMPEG_PC_LIBDIR=\"${LIBAVCODEC_LIBDIR}\"")
-+ endif()
-+
- audacity_library( lib-ffmpeg-support "${SOURCES}" "${LIBRARIES}"
- "${DEFINITIONS}" ""
- )
-diff --git a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-index 55d6f676b..46640ef83 100644
---- a/modules/mod-ffmpeg/lib-ffmpeg-support/FFmpegFunctions.cpp
-+++ b/modules/mod-ffmpeg/lib-ffmpeg-support/FFmpegFunctions.cpp
-@@ -246,6 +246,18 @@ struct FFmpegFunctions::Private final
- if (library->IsLoaded())
- return library;
-
-+#if defined(FFMPEG_PC_LIBDIR)
-+ {
-+ static const wxString libdir{FFMPEG_PC_LIBDIR};
-+ const wxString fullName = wxFileName(libdir, libraryName).GetFullPath();
-+
-+ auto library = std::make_shared<wxDynamicLibrary>(fullName);
-+
-+ if (library->IsLoaded())
-+ return library;
-+ }
-+#endif
-+
- return {};
- }
- };
--
2.47.1
Gabriel Wicki wrote 2 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 75200@debbugs.gnu.org)
87tta1owg5.fsf@erlikon.ch
Hi Artyom!

Thanks for your patch! It builds just fine.

Are you sure the ffmpeg-fallback.patch was to save the build and not to
prevent the error you describe yourself? Would you mind testing the
update without removing the patch and checking whether opening mp4 files
work like that? In the current version importing and playing .mp4 files
works without issues.

Thanks again,
gabber
Nicolas Graves wrote 1 months ago
[PATCH v2 2/2] gnu: audacity: Update to 3.7.1.
(address . 75200@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20250128135441.28018-2-ngraves@ngraves.fr
* gnu/packages/audio.scm (audacity): Update to 3.7.1.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 87e4d9e126..0fbd7760a1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -926,7 +926,7 @@ (define-public ardour
(define-public audacity
(package
(name "audacity")
- (version "3.6.0") ;for ffmpeg 6 support
+ (version "3.7.1") ;for ffmpeg 6 support
(source
(origin
(method git-fetch)
@@ -935,7 +935,7 @@ (define-public audacity
(commit (string-append "Audacity-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mdszrdv54737krsdbip84qc0anz83nsbz1hcnymwa09rrcrrlv4"))
+ (base32 "0f5lgj9phpgw07x0bd9wclsb4r0bn9358va70kkvq6rak6m9vb20"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
--
2.47.1
Nicolas Graves wrote 1 months ago
[PATCH v2 1/2] gnu: audacity: Update to 3.6.0.
(address . 75200@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
20250128135441.28018-1-ngraves@ngraves.fr
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>

* gnu/packages/audio.scm (audacity): Update to 3.6.0.
[patches]: Remove "audacity-ffmpeg-fallback.patch".
* gnu/packages/patches/audacity-ffmpeg-fallback.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.

Change-Id: I411af73bfddf68b5fdbd52272b6253a91e2afd07
---
gnu/local.mk | 1 -
gnu/packages/audio.scm | 6 +-
.../patches/audacity-ffmpeg-fallback.patch | 61 -------------------
3 files changed, 3 insertions(+), 65 deletions(-)
delete mode 100644 gnu/packages/patches/audacity-ffmpeg-fallback.patch

Toggle diff (112 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index e4a8220c83..e76a720e7c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -998,7 +998,6 @@ dist_patch_DATA = \
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
%D%/packages/patches/ath9k-htc-firmware-gcc-compat.patch \
%D%/packages/patches/atlas-gfortran-compat.patch \
- %D%/packages/patches/audacity-ffmpeg-fallback.patch \
%D%/packages/patches/audiofile-fix-datatypes-in-tests.patch \
%D%/packages/patches/audiofile-fix-sign-conversion.patch \
%D%/packages/patches/audiofile-CVE-2015-7747.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 41d3d0bf47..87e4d9e126 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2024 mio <stigma@disroot.org>
;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2024 Roman Scherer <roman@burningswell.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -925,7 +926,7 @@ (define-public ardour
(define-public audacity
(package
(name "audacity")
- (version "3.5.1") ;for ffmpeg 6 support
+ (version "3.6.0") ;for ffmpeg 6 support
(source
(origin
(method git-fetch)
@@ -934,8 +935,7 @@ (define-public audacity
(commit (string-append "Audacity-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11sjyz6hxsr5dnndkkkiq7arjxvjl1sycl151xq3a3ggakgql3y1"))
- (patches (search-patches "audacity-ffmpeg-fallback.patch"))
+ (base32 "1mdszrdv54737krsdbip84qc0anz83nsbz1hcnymwa09rrcrrlv4"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
diff --git a/gnu/packages/patches/audacity-ffmpeg-fallback.patch b/gnu/packages/patches/audacity-ffmpeg-fallback.patch
deleted file mode 100644
index c845e10277..0000000000
--- a/gnu/packages/patches/audacity-ffmpeg-fallback.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 3c20057d0cbbbed453a692d4dd4589d865808024 Mon Sep 17 00:00:00 2001
-From: Liliana Marie Prikler <liliana.prikler@gmail.com>
-Date: Sat, 29 Jan 2022 10:44:44 +0100
-Subject: [PATCH] Add pkg-config fallback for locating ffmpeg.
-
-Audacity >=3.1.0 no longer links against ffmpeg, but instead dynamically loads
-it. This dynamic loading mechanism fails to properly locate libraries outside
-of LD_LIBRARY_PATH.
-
-See <https://issues.guix.gnu.org/53591>.
-
-Bugs-added-by: Marius Bakke <marius@gnu.org>
-
-diff --git a/libraries/lib-ffmpeg-support/CMakeLists.txt b/libraries/lib-ffmpeg-support/CMakeLists.txt
-index b8803a1f5..f86559cca 100644
---- a/modules/mod-ffmpeg/lib-ffmpeg-support/CMakeLists.txt
-+++ b/modules/mod-ffmpeg/lib-ffmpeg-support/CMakeLists.txt
-@@ -1,5 +1,7 @@
-
- if (${_OPT}use_ffmpeg)
-+ pkg_check_modules(FFMPEG libavcodec libavformat libavutil)
-+
- set( SOURCES
- FFmpegTypes.h
-
-@@ -107,6 +109,12 @@ if (${_OPT}use_ffmpeg)
- list(APPEND DEFINITIONS PRIVATE _DARWIN_C_SOURCE )
- endif()
-
-+ if (FFMPEG_FOUND)
-+ pkg_get_variable(LIBAVCODEC_LIBDIR libavcodec libdir)
-+ list(APPEND DEFINITIONS PRIVATE
-+ "-DFFMPEG_PC_LIBDIR=\"${LIBAVCODEC_LIBDIR}\"")
-+ endif()
-+
- audacity_library( lib-ffmpeg-support "${SOURCES}" "${LIBRARIES}"
- "${DEFINITIONS}" ""
- )
-diff --git a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-index 55d6f676b..46640ef83 100644
---- a/modules/mod-ffmpeg/lib-ffmpeg-support/FFmpegFunctions.cpp
-+++ b/modules/mod-ffmpeg/lib-ffmpeg-support/FFmpegFunctions.cpp
-@@ -246,6 +246,18 @@ struct FFmpegFunctions::Private final
- if (library->IsLoaded())
- return library;
-
-+#if defined(FFMPEG_PC_LIBDIR)
-+ {
-+ static const wxString libdir{FFMPEG_PC_LIBDIR};
-+ const wxString fullName = wxFileName(libdir, libraryName).GetFullPath();
-+
-+ auto library = std::make_shared<wxDynamicLibrary>(fullName);
-+
-+ if (library->IsLoaded())
-+ return library;
-+ }
-+#endif
-+
- return {};
- }
- };
--
2.47.1
Ludovic Courtès wrote 1 months ago
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
877c5zqcs0.fsf@gnu.org
Hey Nicolas & Artyom,

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (9 lines)
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
>
> * gnu/packages/audio.scm (audacity): Update to 3.6.0.
> [patches]: Remove "audacity-ffmpeg-fallback.patch".
> * gnu/packages/patches/audacity-ffmpeg-fallback.patch: Delete file.
> * gnu/local.mk (dist_patch_DATA): De-register it.
>
> Change-Id: I411af73bfddf68b5fdbd52272b6253a91e2afd07

[...]

Toggle quote (2 lines)
> * gnu/packages/audio.scm (audacity): Update to 3.7.1.

Applied, thanks!

Ludo’.
Closed
Leo Famulari wrote 1 weeks ago
Re: bug#75200: [PATCH v2 1/2] gnu: audacity: Update to 3.6.0.
Z8SbIGCBK5lg16Gc@jasmine.lan
On Sun, Feb 09, 2025 at 05:54:39PM +0100, Ludovic Court�s wrote:
Toggle quote (19 lines)
> Hey Nicolas & Artyom,
>
> Nicolas Graves <ngraves@ngraves.fr> skribis:
>
> > From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> >
> > * gnu/packages/audio.scm (audacity): Update to 3.6.0.
> > [patches]: Remove "audacity-ffmpeg-fallback.patch".
> > * gnu/packages/patches/audacity-ffmpeg-fallback.patch: Delete file.
> > * gnu/local.mk (dist_patch_DATA): De-register it.
> >
> > Change-Id: I411af73bfddf68b5fdbd52272b6253a91e2afd07
>
> [...]
>
> > * gnu/packages/audio.scm (audacity): Update to 3.7.1.
>
> Applied, thanks!

Unfortunately, the code review process didn't work for this ticket.

Gabriel Wicki asked the salient question: "does this update take into
account the point of the removed 'ffmpeg-fallback.patch'?", but the
question was ignored:


Indeed, by removing the patch, important functionality of Audacity was
broken.

I've reverted both of these commits (the updates to 3.6.0 and 3.7.1)
pending a resolution of this problem.
Nicolas Graves wrote 1 weeks ago
Re: [bug#75200] [PATCH v2 1/2] gnu: audacity: Update to 3.6.0.
87y0xk6h13.fsf@ngraves.fr
On 2025-03-02 12:53, Leo Famulari wrote:

Toggle quote (11 lines)
> Unfortunately, the code review process didn't work for this ticket.
>
> Gabriel Wicki asked the salient question: "does this update take into
> account the point of the removed 'ffmpeg-fallback.patch'?", but the
> question was ignored:
>
> https://issues.guix.gnu.org/75200#2
>
> Indeed, by removing the patch, important functionality of Audacity was
> broken.

Hi Leo,

Could you be more precise about what you mean behind "functionality"?
IIRC, I've tested mp4 as suggested by Gabriel before sending the patch
(will retry, but I remember something along those lines).

--
Best regards,
Nicolas Graves
Nicolas Graves wrote 1 weeks ago
87v7so6gmo.fsf@ngraves.fr
On 2025-03-04 14:51, Nicolas Graves wrote:

Toggle quote (19 lines)
> On 2025-03-02 12:53, Leo Famulari wrote:
>
>> Unfortunately, the code review process didn't work for this ticket.
>>
>> Gabriel Wicki asked the salient question: "does this update take into
>> account the point of the removed 'ffmpeg-fallback.patch'?", but the
>> question was ignored:
>>
>> https://issues.guix.gnu.org/75200#2
>>
>> Indeed, by removing the patch, important functionality of Audacity was
>> broken.
>
> Hi Leo,
>
> Could you be more precise about what you mean behind "functionality"?
> IIRC, I've tested mp4 as suggested by Gabriel before sending the patch
> (will retry, but I remember something along those lines).

OK, indeed mp4 doesn't work. I must have tested something other video
format instead. I'll try and rebase the patch.

--
Best regards,
Nicolas Graves
Ludovic Courtès wrote 1 weeks ago
Re: bug#75200: [PATCH v2 1/2] gnu: audacity: Update to 3.6.0.
(name . Leo Famulari)(address . leo@famulari.name)
87frjsc1l1.fsf@gnu.org
Leo Famulari <leo@famulari.name> skribis:

Toggle quote (8 lines)
> Unfortunately, the code review process didn't work for this ticket.
>
> Gabriel Wicki asked the salient question: "does this update take into
> account the point of the removed 'ffmpeg-fallback.patch'?", but the
> question was ignored:
>
> https://issues.guix.gnu.org/75200#2

Oh, my bad. Apologies for overlooking this comment, and thanks for
rectifying this!

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75200@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75200
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help