[PATCH] gnu: artanis: update to 1.0.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Andy Tai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Merged with
A
A
Andy Tai wrote on 28 Nov 2024 07:36
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
6cff8f95632fe6f01696700f6a1f03ad32fdb599.1732775721.git.atai@atai.org
* gnu/packages/guile-xyz.scm (artanis): update to 1.0.0.
[source]: Remove code removing non-existent old directories.

Change-Id: I27b38eaff75cda008ae7de3eceb84dc5b7bf01aa
---
gnu/packages/guile-xyz.scm | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a21289d368..3a69300ffe 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -149,22 +149,19 @@ (define-module (gnu packages guile-xyz)
(define-public artanis
(package
(name "artanis")
- (version "0.6")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/artanis/artanis-"
version ".tar.gz"))
(sha256
(base32
- "1y4mf8vv2fwjg4z8c4d7an5rxi96sh7krk0djnafm2l66i97cj3m"))
+ "05sigqvm04x0r1gwpwrxjffb3i13bss3ff24frr477zqm54wv5d8"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; Unbundle guile-redis and guile-json
(delete-file-recursively "artanis/third-party/json.scm")
- (delete-file-recursively "artanis/third-party/json")
(delete-file-recursively "artanis/third-party/redis.scm")
- (delete-file-recursively "artanis/third-party/redis")
(substitute* '("artanis/artanis.scm"
"artanis/lpc.scm"
"artanis/oht.scm"

base-commit: ce877a777e6ec089dc347e9883387d3080b471cf
--
2.46.0
A
A
Andy Tai wrote on 2 Dec 2024 19:32
Fwd: Third-parties are back to upstream
(address . 74573@debbugs.gnu.org)
CAJsg1E_HeEj52VHO-jGeozOOtDv3w=xBMNmScgZ+9j+LmsUwuw@mail.gmail.com
---------- Forwarded message ---------
From: Andy Tai <atai@atai.org>

OK I guess I will need to update my patch for this.

On Mon, Dec 2, 2024 at 1:02?AM Nala Ginrut <mulei@gnu.org> wrote:
Toggle quote (7 lines)
> Hi Andy Tai and Guix folks!
> Recently Artanis-1.0.0 has released, I think there's still a thing to
> notice for Aarch64.
> You may need to pass --build=aarch64-unknown-linux-gnu to ./configure
> for Aarch64.
> Here's the related link:
> https://gitlab.com/hardenedlinux/artanis/-/issues/115#note_2054372084
A
A
Andy Tai wrote on 4 Dec 2024 07:33
[PATCH v2] gnu: artanis: update to 1.0.0.
(name . Andy Tai)(address . atai@atai.org)
928a869c00e7bf10e28f3abe46420824372a692a.1733293969.git.atai@atai.org
* gnu/packages/guile-xyz.scm (artanis): update to 1.0.0.
[source]: Remove code removing non-existent old directories.
[arguments]<#:configure-flags>: Add aarch64 specific flag.

Change-Id: I27b38eaff75cda008ae7de3eceb84dc5b7bf01aa
---
gnu/packages/guile-xyz.scm | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a21289d368..13b1f48e49 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -149,22 +149,19 @@ (define-module (gnu packages guile-xyz)
(define-public artanis
(package
(name "artanis")
- (version "0.6")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/artanis/artanis-"
version ".tar.gz"))
(sha256
(base32
- "1y4mf8vv2fwjg4z8c4d7an5rxi96sh7krk0djnafm2l66i97cj3m"))
+ "05sigqvm04x0r1gwpwrxjffb3i13bss3ff24frr477zqm54wv5d8"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; Unbundle guile-redis and guile-json
(delete-file-recursively "artanis/third-party/json.scm")
- (delete-file-recursively "artanis/third-party/json")
(delete-file-recursively "artanis/third-party/redis.scm")
- (delete-file-recursively "artanis/third-party/redis")
(substitute* '("artanis/artanis.scm"
"artanis/lpc.scm"
"artanis/oht.scm"
@@ -201,7 +198,9 @@ (define-public artanis
pkg-config
util-linux)) ;for the `script' command
(arguments
- `(#:modules (((guix build guile-build-system)
+ `(#:configure-flags
+ '( ,@(if (target-aarch64?) '("--build=aarch64-unknown-linux-gnu") '()))
+ #:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%default-gnu-modules)
#:imported-modules ((guix build guile-build-system)

base-commit: 2c700af42cbb17859a7d80807fef2000cab7f8ad
--
2.46.0
A
A
Andy Tai wrote on 13 Dec 2024 01:46
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_XfjpsaOVxb7KTpFjZ37E+qbH8-wHn5uBpfWOfUOQNng@mail.gmail.com
merge 74573 74649
thanks
L
L
Ludovic Courtès wrote on 26 Dec 2024 23:22
(name . Andy Tai)(address . atai@atai.org)
87r05uxex5.fsf@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (6 lines)
> * gnu/packages/guile-xyz.scm (artanis): update to 1.0.0.
> [source]: Remove code removing non-existent old directories.
> [arguments]<#:configure-flags>: Add aarch64 specific flag.
>
> Change-Id: I27b38eaff75cda008ae7de3eceb84dc5b7bf01aa

[...]

Toggle quote (5 lines)
> (arguments
> - `(#:modules (((guix build guile-build-system)
> + `(#:configure-flags
> + '( ,@(if (target-aarch64?) '("--build=aarch64-unknown-linux-gnu") '()))

Applied without the #:configure-flags above since that’s already exactly
what happens by default.

Thanks,
Ludo’.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74573@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74573
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch