[PATCH] gnu: Add owl.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Juliana Sims
  • Zheng Junjie
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 25 Oct 07:42 +0200
(address . guix-patches@gnu.org)(name . Juliana Sims)(address . juli@incana.org)
0211cc89227642600e9cdfbcc4098d9d4f84eee5.1729834975.git.juli@incana.org
* gnu/packages/scheme.scm (owl): New symbol.

Change-Id: Ibb242bbcdedb92419b59e05635e8a32e85afc24e
---

Hello,

This patch adds a package for Owl Lisp.

Thanks,
Juli
gnu/packages/scheme.scm | 44 ++++++++++++++++++++++++++++++++++++++---
1 file changed, 41 insertions(+), 3 deletions(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 0d6a662aaa..bbd7ee7bfa 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2023 Andrew Whatson <whatson@tailcall.au>
-;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023, 2024 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Skylar Hill <stellarskylark@posteo.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -71,6 +71,7 @@ (define-module (gnu packages scheme)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libevent)
@@ -1273,6 +1274,43 @@ (define-public emacs-gerbil-mode
"Gerbil mode provides font-lock, indentation, navigation, and REPL for
Gerbil code within Emacs.")))
+(define-public owl
+ (package
+ (name "owl")
+ (version "0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/owl-lisp/owl.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0jlmpw14rg63m1q7pjmhjicaqbqgc6gnp53bph0giwg8ha8wxyqr"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~`(,(string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'patch-source-shebangs 'patch-ol-shebangs
+ (lambda _
+ (map (lambda (f)
+ (substitute* f
+ (("/usr") #$output)))
+ (list "bin/feather"
+ "tests/hashbang.scm"
+ "tests/theorem-rand.scm")))))
+ #:test-target "test"))
+ (native-inputs (list pandoc which))
+ (home-page "https://haltp.org/owl")
+ (synopsis "Functional Scheme dialect")
+ (description
+ "Owl Lisp is a simple programming language. It is intended to provide a
+portable system for writing standalone programs in a subjectively pleasant
+dialect of Lisp. It has a minimal core and runtime, purely functional
+operation, and suppport for asynchronous evaluation.")
+ (license expat)))
+
(define-public stklos
(package
(name "stklos")
@@ -1294,8 +1332,8 @@ (define-public stklos
,@%default-gnu-modules)
#:configure-flags
#~(list (string-append "LDFLAGS=-L"
- #$(this-package-input "readline")
- "/lib -lreadline"))
+ #$(this-package-input "readline")
+ "/lib -lreadline"))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-sh-references

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
J
J
Juliana Sims wrote on 25 Oct 07:48 +0200
[PATCH v2] gnu: Add owl.
(address . guix-patches@gnu.org)(name . Juliana Sims)(address . juli@incana.org)
63a80a5b13302fb6cf77802eccffc484512773ea.1729835294.git.juli@incana.org
* gnu/packages/scheme.scm (owl): New symbol.

Change-Id: I3dbbe1143f4928c3ecfc42c6a7a6be8a6b524629
---

Woops, Emacs decided to reindent unrelated code!

This version is clean of such errors :)

-Juli
gnu/packages/scheme.scm | 40 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 0d6a662aaa..637893e0f1 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2023 Andrew Whatson <whatson@tailcall.au>
-;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023, 2024 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Skylar Hill <stellarskylark@posteo.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -71,6 +71,7 @@ (define-module (gnu packages scheme)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libevent)
@@ -1273,6 +1274,43 @@ (define-public emacs-gerbil-mode
"Gerbil mode provides font-lock, indentation, navigation, and REPL for
Gerbil code within Emacs.")))
+(define-public owl
+ (package
+ (name "owl")
+ (version "0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/owl-lisp/owl.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0jlmpw14rg63m1q7pjmhjicaqbqgc6gnp53bph0giwg8ha8wxyqr"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~`(,(string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'patch-source-shebangs 'patch-ol-shebangs
+ (lambda _
+ (map (lambda (f)
+ (substitute* f
+ (("/usr") #$output)))
+ (list "bin/feather"
+ "tests/hashbang.scm"
+ "tests/theorem-rand.scm")))))
+ #:test-target "test"))
+ (native-inputs (list pandoc which))
+ (home-page "https://haltp.org/owl")
+ (synopsis "Functional Scheme dialect")
+ (description
+ "Owl Lisp is a simple programming language. It is intended to provide a
+portable system for writing standalone programs in a subjectively pleasant
+dialect of Lisp. It has a minimal core and runtime, purely functional
+operation, and suppport for asynchronous evaluation.")
+ (license expat)))
+
(define-public stklos
(package
(name "stklos")

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
Z
Z
Zheng Junjie wrote 6 days ago
(name . Juliana Sims via Guix-patches via)(address . guix-patches@gnu.org)
875xpflzal.fsf@iscas.ac.cn
Juliana Sims via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (51 lines)
> * gnu/packages/scheme.scm (owl): New symbol.
>
> Change-Id: I3dbbe1143f4928c3ecfc42c6a7a6be8a6b524629
> ---
>
> Woops, Emacs decided to reindent unrelated code!
>
> This version is clean of such errors :)
>
> -Juli
> gnu/packages/scheme.scm | 40 +++++++++++++++++++++++++++++++++++++++-
> 1 file changed, 39 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
> index 0d6a662aaa..637893e0f1 100644
> --- a/gnu/packages/scheme.scm
> +++ b/gnu/packages/scheme.scm
> @@ -21,7 +21,7 @@
> ;;; Copyright © 2022 jgart <jgart@dismail.de>
> ;;; Copyright © 2022 Robby Zambito <contact@robbyzambito.me>
> ;;; Copyright © 2023 Andrew Whatson <whatson@tailcall.au>
> -;;; Copyright © 2023 Juliana Sims <juli@incana.org>
> +;;; Copyright © 2023, 2024 Juliana Sims <juli@incana.org>
> ;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2024 Skylar Hill <stellarskylark@posteo.net>
> ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
> @@ -71,6 +71,7 @@ (define-module (gnu packages scheme)
> #:use-module (gnu packages gl)
> #:use-module (gnu packages glib)
> #:use-module (gnu packages gtk)
> + #:use-module (gnu packages haskell-xyz)
> #:use-module (gnu packages image)
> #:use-module (gnu packages libedit)
> #:use-module (gnu packages libevent)
> @@ -1273,6 +1274,43 @@ (define-public emacs-gerbil-mode
> "Gerbil mode provides font-lock, indentation, navigation, and REPL for
> Gerbil code within Emacs.")))
>
> +(define-public owl
> + (package
> + (name "owl")
> + (version "0.2.2")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/owl-lisp/owl.git")
> + (commit (string-append "v" version))))
> + (sha256
> + (base32 "0jlmpw14rg63m1q7pjmhjicaqbqgc6gnp53bph0giwg8ha8wxyqr"))
> + (file-name (git-file-name name version))))

usually we put file-name after uri

Toggle quote (5 lines)
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:make-flags #~`(,(string-append "PREFIX=" #$output))

please set (string-append "CC=" #$(cc-for-target)) , allow cross-compiling.

like: #~(list (string-append "CC=" #$(cc-for-target))
(string-append "PREFIX=" #$output))

Toggle quote (3 lines)
> + #:phases #~(modify-phases %standard-phases
> + (delete 'configure)

please add ; No configure script
Let us know why it was deleted.

Toggle quote (8 lines)
> + (add-after 'patch-source-shebangs 'patch-ol-shebangs
> + (lambda _
> + (map (lambda (f)
> + (substitute* f
> + (("/usr") #$output)))
> + (list "bin/feather"
> + "tests/hashbang.scm"
> + "tests/theorem-rand.scm")))))
just

(substitute* (list "bin/feather"
"tests/hashbang.scm"
"tests/theorem-rand.scm")
(("/usr") #$output))

Toggle quote (3 lines)
> + #:test-target "test"))
> + (native-inputs (list pandoc which))

pandoc is development dependence, so no needed add it.


Toggle quote (2 lines)
> + (home-page "https://haltp.org/owl")

guix lint say: https://haltp.org/owl/

Toggle quote (13 lines)
> + (synopsis "Functional Scheme dialect")
> + (description
> + "Owl Lisp is a simple programming language. It is intended to provide a
> +portable system for writing standalone programs in a subjectively pleasant
> +dialect of Lisp. It has a minimal core and runtime, purely functional
> +operation, and suppport for asynchronous evaluation.")
> + (license expat)))
> +
> (define-public stklos
> (package
> (name "stklos")
>
> base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcc+xIACgkQO1qpk+Gi
3/A8/RAAuN/sQ8aHREK1+QP6euYmAYXd2hgrYOu6fFcetk6dxOLFqrAsK1M3/om4
PShtcllcUbQKkdsI42C7PZjH7obx0lC7Cd0F/eMTXzMyVGJ3suT/3RfwC20tKNcM
J3rhihYCyl2Ke+BqNxmDQzMgqK8m3w5DmRDbXHeLAwxQPcEr5HAWR/Z1CU2v90mi
buBMZZtk2oE96EqReHccvnkFNdCiPbHGMk7G8dESVU56LO384JeYSxX+FaMKkHAo
0kSR8s32G6AH7693fpF3htCZL3zdMIEPmVUxvHJv3mlIaPJAIMIejgiOjtX299a8
gULOfvh3XIHEW9qNfDoh1ehEvLT5Bup6dNu+d9weJZIe2doLb/8riQfy4F6GN/qj
GNG7E16/IOtLw5Im1IMrU7rFzjL7eQ8/YOX7iKQq0/CTUeLAmBlKNvKANj7Lfp8D
lJa/EPwl1h8zNLC8u/rKf9kYjCoTJaDMT+gJWmgI66JuuO8k/78Vp+uQD/sqQvIT
/Md3zjMqbxYQVdRSp2HL6jegeog4lOhQ+hq02DZjL/j+iXnhzgaQYr02KGcQ1HqL
Z36AmJ5Gi+ws2D7z1zEl9D+YzHClxwRVthYnrIApDPrOUUwONUsViZ2n58ty6D9e
rl2zOCE0VTj0arrSlx5ZdWVnFSZUkKoAMtiXBBNqBdzo3NMTP6o=
=JxLc
-----END PGP SIGNATURE-----

J
J
Juliana Sims wrote 5 days ago
[PATCH v3] gnu: Add owl.
(address . zhengjunjie@iscas.ac.cn)
f781f2b0af69d5d4518ec24330ad6d0143fc4e70.1729965281.git.juli@incana.org
* gnu/packages/scheme.scm (owl): New symbol.

Change-Id: I3dbbe1143f4928c3ecfc42c6a7a6be8a6b524629
---

Hi,

Thanks for the quick review! When I finished packaging this on a whim at 01:30,
I thought to myself, "Gee, that was fast! ...did I forget something?" And
indeed I did; I forgot to run guix lint, cross-compile, build for different
architectures, ensure reproducibility, and argue with guix style. So, here we
have a proper version of the patch! (I disagreed with some of guix style's
opinions.)

Thanks again!
-Juli

gnu/packages/scheme.scm | 40 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 0d6a662aaa..29142f474b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2023 Andrew Whatson <whatson@tailcall.au>
-;;; Copyright © 2023 Juliana Sims <juli@incana.org>
+;;; Copyright © 2023, 2024 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Skylar Hill <stellarskylark@posteo.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -71,6 +71,7 @@ (define-module (gnu packages scheme)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libevent)
@@ -1273,6 +1274,43 @@ (define-public emacs-gerbil-mode
"Gerbil mode provides font-lock, indentation, navigation, and REPL for
Gerbil code within Emacs.")))
+(define-public owl
+ (package
+ (name "owl")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/owl-lisp/owl.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jlmpw14rg63m1q7pjmhjicaqbqgc6gnp53bph0giwg8ha8wxyqr"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure) ;No configure script
+ (add-after 'patch-source-shebangs 'patch-ol-shebangs
+ (lambda _
+ (substitute* (list "bin/feather"
+ "tests/hashbang.scm"
+ "tests/theorem-rand.scm")
+ (("/usr") #$output)))))
+ #:test-target "test"))
+ (native-inputs (list which))
+ (home-page "https://haltp.org/posts/owl.html")
+ (synopsis "Functional Scheme dialect")
+ (description
+ "Owl Lisp is a simple programming language. It is intended to provide a
+portable system for writing standalone programs in a subjectively pleasant
+dialect of Lisp. It has a minimal core and runtime, purely functional
+operation, immutable lists, and suppport for asynchronous evaluation.")
+ (license expat)))
+
(define-public stklos
(package
(name "stklos")

base-commit: df666602c7936f7d87354374b148ef6269844c01
--
2.46.0
A
A
Andreas Enge wrote 4 days ago
Close
(address . 74000-done@debbugs.gnu.org)
Zx9RoexuCnNboVHZ@jurong
Pushed with a tiny change to the commit message, thanks!

Andreas
Closed
Z
Z
Z572 wrote 4 days ago
(address . 74000@debbugs.gnu.org)
87jzds4j52.fsf@iscas.ac.cn
Andreas Enge <andreas@enge.fr> writes:

Toggle quote (4 lines)
> Pushed with a tiny change to the commit message, thanks!
>
> Andreas

Seems to have applied the wrong version,
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmcfZxkACgkQO1qpk+Gi
3/C4Cg//a/G8js4Gkr3+3iDTXV8CB/6XMrWcdcFnRCn/CQcRHgFZXIg5KNlVGvEa
WTPXIJ+I27BIk8B3P6p01oiLBfLTX4WowsGKhVwm0XXo1qUfIBdtcFbp/ACE+Ays
uxyLrPIqMkAPit3gmSZngT/2ORvRksQyZfQ8ihsbyaARp/Mx94WsPc0tyB3mDV1N
FZq/Iv/AujFs0P4NP530JYVKdbEgRxLQ8e8+kzOK6N7/lWE9aM7X30Jct7T19KDq
s7MGv/oMFgmMRF0lrGTZUZuFbuEm5ezPM8UfSmHxwt+aalw7T0C25RWHiey3w1E+
uDXnHO1CWqlutY1vjpzBhhVQBttZjp9zOrKeGvpjNZbuLa1P3RIVTvxaD2MBKqnb
YvyUjAyNwgOipoQaGQ2A1VXjfLCQ4AExlhBFCjJ676NdlAmOJL7fOX7AHaEphYjG
MeAmjzOXfOFaZXvPQITblQS1+vNg9KsM3RqRLNiP1wAqGEg4UIJwvumhJUZMIT84
gNGX1F1hhJnlL1WvpM6esfSCQsSa16347eB825ASIVAnPOF7tNfJJl3PkX49kFHj
7QNSbYAKpuVDsMmZemRTcvVZrLt65DCkPrZmjgRYpIvGkCqc01J8R1aNycaPpFOl
dCnxfe1I2X9ZNLH9SV2n8O1Ag1MjanX+Q5hdR0znVV0Kg/qfKvk=
=EHRX
-----END PGP SIGNATURE-----

A
A
Andreas Enge wrote 4 days ago
(name . Z572)(address . zhengjunjie@iscas.ac.cn)
Zx9uTjubMszoOk7P@jurong
Am Mon, Oct 28, 2024 at 06:27:37PM +0800 schrieb Z572:
Toggle quote (3 lines)
> Seems to have applied the wrong version,
> https://issues.guix.gnu.org/74000#3 is rignt version

Sorry, I managed to completely miss the discussion of the patch!
I have applied the changes by hand and pushed an updated version.

Andreas
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74000@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74000
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch