[PATCH 1/2] gnu: pypandoc: Update to 1.13 and fix dependencies

  • Done
  • quality assurance status badge
Details
3 participants
  • Aaron Covrig
  • Aaron Covrig
  • Ludovic Courtès
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 18 Sep 23:14 +0200
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20240918211510.468854-1-aaron.covrig.us@ieee.org
* gnu/packages/python-xyz.scm (pypandoc): Update to 1.13
[inputs]: Add texlive-xpatch
---
gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++-----------------
1 file changed, 21 insertions(+), 18 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d402d4f94..055faef0de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32381,31 +32382,33 @@ (define-public python-safety
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.7.5")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
- (base32
- "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
+ (base32 "07hw2psqzaffskmgb789f0zbra9cc17ykl8baw1jn34nqxrj0r9i"))))
(build-system python-build-system)
- (inputs
- (list pandoc python-pandocfilters))
- (propagated-inputs
- `(("wheel" ,python-wheel)))
- (native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
+ (inputs (list pandoc python-pandocfilters texlive-xpatch))
+ (propagated-inputs `(("wheel" ,python-wheel)))
+ (native-inputs `(("texlive" ,(texlive-updmap.cfg (list texlive-lm
+ texlive-xcolor)))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-tests
- (lambda _
- ;; Disable test requiring network access
- (substitute* "tests.py"
- (("test_basic_conversion_from_http_url")
- "skip_test_basic_conversion_from_http_url"))
- #t)))))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ (substitute* "tests.py"
+ ;; Disable test requiring network access
+ (("test_basic_conversion_from_http_url")
+ "skip_test_basic_conversion_from_http_url")
+ ;; Disable tests with missing files
+ (("test_basic_conversion_from_file_pattern")
+ "skip_test_basic_conversion_from_file_pattern")
+ (("test_conversion_with_data_files")
+ "skip_test_conversion_with_data_files")
+ (("test_conversion_stderr")
+ "skip_test_conversion_stderr")) #t)))))
(home-page "https://github.com/bebraw/pypandoc")
(synopsis "Python wrapper for pandoc")
(description "pypandoc is a thin Python wrapper around pandoc

base-commit: 1b6ce1796abdf497f61f426d61339318f4f4f23d
--
2.46.0
A
A
Aaron Covrig wrote on 24 Sep 00:36 +0200
Incorrect multipart submission
(address . 73339@debbugs.gnu.org)
20240923183255.6292d3d4@mobile-dev
It would seem I did not do the multipart commit correctly, this issue
is the part 1/2
for https://issues.guix.gnu.org/73338;hopefully this one for pypandoc gets pickedup first by the build system.
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQSPXVwROJGaYSBOwhhfTkc5aZTD/QUCZvHtbQAKCRBfTkc5aZTD
/d32AP9OXLopM6r+5z4TjI1QojuntE16/wXNuflUxz2RJFnQHAD+M/xvXCdGzoIN
fCKpHjMPaus14ksPhOi4C198lG0hggo=
=ReeE
-----END PGP SIGNATURE-----


A
A
Aaron Covrig wrote on 24 Oct 23:16 +0200
[PATCH] gnu: pypandoc: Update to 1.14
(address . 73339@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241024211649.988530-1-aaron.covrig.us@ieee.org
* gnu/packages/python-xyz.scm (python-pypandoc): Update to 1.14
---
gnu/packages/python-xyz.scm | 42 +++++++++++++++++++------------------
1 file changed, 22 insertions(+), 20 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b58eb1ff88..adcd869229 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32530,33 +32531,34 @@ (define-public python-safety
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.7.5")
+ (version "1.14")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
- (base32
- "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
+ (base32 "15x161bxr7hky7rvq0jlgf1kxg6vdf069487casmpyxry7slak3b"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'disable-tests
- (lambda _
- ;; Disable test requiring network access
- (substitute* "tests.py"
- (("test_basic_conversion_from_http_url")
- "skip_test_basic_conversion_from_http_url")))))))
- (native-inputs
- (list python-poetry-core
- (texlive-updmap.cfg
- (list texlive-etoolbox texlive-lm texlive-xcolor))))
- (inputs
- (list pandoc python-pandocfilters))
- (propagated-inputs
- (list python-wheel))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ (substitute* "tests.py"
+ ;; Disable test requiring network access
+ (("test_basic_conversion_from_http_url")
+ "skip_test_basic_conversion_from_http_url")
+ ;; Disable tests with missing files
+ (("test_basic_conversion_from_file_pattern")
+ "skip_test_basic_conversion_from_file_pattern")
+ (("test_conversion_with_data_files")
+ "skip_test_conversion_with_data_files")) #t)))))
+ ;; Ideally, we would supersede texlive-xpatch with texlive-regexpatch once
+ ;; the missing etoolbox.sty file is added
+ (native-inputs (list python-poetry-core
+ (texlive-updmap.cfg (list texlive-xpatch texlive-lm
+ texlive-xcolor))))
+ (inputs (list pandoc python-pandocfilters))
+ (propagated-inputs (list python-wheel))
(home-page "https://github.com/bebraw/pypandoc")
(synopsis "Python wrapper for pandoc")
(description "pypandoc is a thin Python wrapper around pandoc

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
A
A
Aaron Covrig wrote on 24 Oct 23:28 +0200
merge 73338 73339
20241024172850.64b104bb@mobile-dev
merge 73338 73339
A
A
Aaron Covrig wrote on 25 Oct 01:33 +0200
[PATCH v3 1/2] gnu: pypandoc: Update to 1.14
(address . 73339@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241024233426.992569-1-aaron.covrig.us@ieee.org
* gnu/packages/python-xyz.scm (python-pypandoc): Update to 1.14
---
gnu/packages/python-xyz.scm | 42 +++++++++++++++++++------------------
1 file changed, 22 insertions(+), 20 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b58eb1ff88..adcd869229 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32530,33 +32531,34 @@ (define-public python-safety
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.7.5")
+ (version "1.14")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
- (base32
- "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
+ (base32 "15x161bxr7hky7rvq0jlgf1kxg6vdf069487casmpyxry7slak3b"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'disable-tests
- (lambda _
- ;; Disable test requiring network access
- (substitute* "tests.py"
- (("test_basic_conversion_from_http_url")
- "skip_test_basic_conversion_from_http_url")))))))
- (native-inputs
- (list python-poetry-core
- (texlive-updmap.cfg
- (list texlive-etoolbox texlive-lm texlive-xcolor))))
- (inputs
- (list pandoc python-pandocfilters))
- (propagated-inputs
- (list python-wheel))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ (substitute* "tests.py"
+ ;; Disable test requiring network access
+ (("test_basic_conversion_from_http_url")
+ "skip_test_basic_conversion_from_http_url")
+ ;; Disable tests with missing files
+ (("test_basic_conversion_from_file_pattern")
+ "skip_test_basic_conversion_from_file_pattern")
+ (("test_conversion_with_data_files")
+ "skip_test_conversion_with_data_files")) #t)))))
+ ;; Ideally, we would supersede texlive-xpatch with texlive-regexpatch once
+ ;; the missing etoolbox.sty file is added
+ (native-inputs (list python-poetry-core
+ (texlive-updmap.cfg (list texlive-xpatch texlive-lm
+ texlive-xcolor))))
+ (inputs (list pandoc python-pandocfilters))
+ (propagated-inputs (list python-wheel))
(home-page "https://github.com/bebraw/pypandoc")
(synopsis "Python wrapper for pandoc")
(description "pypandoc is a thin Python wrapper around pandoc

base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b
--
2.46.0
A
A
Aaron Covrig wrote on 25 Oct 01:33 +0200
[PATCH v3 2/2] gnu: impressive: Update to 13.2 and fix build
(address . 73339@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20241024233426.992569-2-aaron.covrig.us@ieee.org
* gnu/packages/pdf.scm (impressive): Update to 13.2
---
gnu/packages/pdf.scm | 59 ++++++++++++++++++++++----------------------
1 file changed, 29 insertions(+), 30 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 72aae8b002..24afadbe80 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2023 Benjamin Slade <slade@lambda-y.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1171,39 +1172,37 @@ (define-public python-reportlab
(define-public impressive
(package
(name "impressive")
- (version "0.13.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/impressive/Impressive/"
- version "/Impressive-" version ".tar.gz"))
- (sha256
- (base32
- "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+ ;; (version "0.13.1")
+ (version "0.13.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/impressive/Impressive/"
+ version "/Impressive-" version ".tar.gz"))
+ (sha256
+ (base32
+ ;; "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+ "0g15q67f992prkjndrk75hhd601iypfmkafhdx7hijs2byr26c83"))))
(build-system python-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (delete 'build)
- (delete 'configure)
- (delete 'check)
- (replace 'install
- (lambda* (#:key inputs #:allow-other-keys)
- ;; There's no 'setup.py' so install things manually.
- (let* ((bin (string-append #$output "/bin"))
- (impressive (string-append bin "/impressive"))
- (man1 (string-append #$output "/share/man/man1")))
- (mkdir-p bin)
- (copy-file "impressive.py" impressive)
- (chmod impressive #o755)
- (wrap-program (string-append bin "/impressive")
- `("LIBRARY_PATH" ":" prefix ;for ctypes
- (,(string-append #$(this-package-input "sdl")
- "/lib")))
- `("PATH" ":" prefix ;for pdftoppm
- (,(search-input-file inputs "bin/xpdf"))))
- (install-file "impressive.1" man1)))))))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; There's no 'setup.py' so install things manually.
+ (let* ((bin (string-append #$output "/bin"))
+ (impressive (string-append bin "/impressive"))
+ (man1 (string-append #$output "/share/man/man1")))
+ (mkdir-p bin)
+ (copy-file "impressive.py" impressive)
+ (chmod impressive #o755)
+ (wrap-program (string-append bin "/impressive")
+ `("PATH" ":" prefix ;for pdftoppm
+ (,(search-input-file inputs "bin/xpdf"))))
+ (install-file "impressive.1" man1)))))))
;; TODO: Add dependency on pdftk.
(inputs (list bash-minimal python-pygame python-pillow sdl xpdf))
(home-page "https://impressive.sourceforge.net")
--
2.46.0
L
L
Ludovic Courtès wrote 5 days ago
Re: [bug#73339] [PATCH v3 1/2] gnu: pypandoc: Update to 1.14
(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)(address . 73339-done@debbugs.gnu.org)
87ttc5h5w9.fsf@gnu.org
Aaron Covrig <aaron.covrig.us@ieee.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-pypandoc): Update to 1.14

[...]

Toggle quote (2 lines)
> * gnu/packages/pdf.scm (impressive): Update to 13.2

Applied, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73339@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73339
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch