[PATCH 2/2] gnu: impressive: Update to 13.2 and fix build

  • Open
  • quality assurance status badge
Details
2 participants
  • Aaron Covrig
  • Aaron Covrig
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 18 Sep 23:14 +0200
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
20240918211510.468854-2-aaron.covrig.us@ieee.org
* gnu/packages/pdf.scm (impressive): Update to 13.2
[inputs]: depends on fixed python-pypandoc from prior commit
---
gnu/packages/pdf.scm | 59 ++++++++++++++++++++++----------------------
1 file changed, 29 insertions(+), 30 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e743d51286..8efff540df 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2023 Benjamin Slade <slade@lambda-y.net>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1171,39 +1172,37 @@ (define-public python-reportlab
(define-public impressive
(package
(name "impressive")
- (version "0.13.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/impressive/Impressive/"
- version "/Impressive-" version ".tar.gz"))
- (sha256
- (base32
- "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+ ;; (version "0.13.1")
+ (version "0.13.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/impressive/Impressive/"
+ version "/Impressive-" version ".tar.gz"))
+ (sha256
+ (base32
+ ;; "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+ "0g15q67f992prkjndrk75hhd601iypfmkafhdx7hijs2byr26c83"))))
(build-system python-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (delete 'build)
- (delete 'configure)
- (delete 'check)
- (replace 'install
- (lambda* (#:key inputs #:allow-other-keys)
- ;; There's no 'setup.py' so install things manually.
- (let* ((bin (string-append #$output "/bin"))
- (impressive (string-append bin "/impressive"))
- (man1 (string-append #$output "/share/man/man1")))
- (mkdir-p bin)
- (copy-file "impressive.py" impressive)
- (chmod impressive #o755)
- (wrap-program (string-append bin "/impressive")
- `("LIBRARY_PATH" ":" prefix ;for ctypes
- (,(string-append #$(this-package-input "sdl")
- "/lib")))
- `("PATH" ":" prefix ;for pdftoppm
- (,(search-input-file inputs "bin/xpdf"))))
- (install-file "impressive.1" man1)))))))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; There's no 'setup.py' so install things manually.
+ (let* ((bin (string-append #$output "/bin"))
+ (impressive (string-append bin "/impressive"))
+ (man1 (string-append #$output "/share/man/man1")))
+ (mkdir-p bin)
+ (copy-file "impressive.py" impressive)
+ (chmod impressive #o755)
+ (wrap-program (string-append bin "/impressive")
+ `("PATH" ":" prefix ;for pdftoppm
+ (,(search-input-file inputs "bin/xpdf"))))
+ (install-file "impressive.1" man1)))))))
;; TODO: Add dependency on pdftk.
(inputs (list bash-minimal python-pygame python-pillow sdl xpdf))
(home-page "https://impressive.sourceforge.net")
--
2.46.0
A
A
Aaron Covrig wrote 5 days ago
multipart patch split across issues
(address . 73338@debbugs.gnu.org)
20240923183821.74deec97@mobile-dev
Looks like I messed up the multipart submission, this patch depends on
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQSPXVwROJGaYSBOwhhfTkc5aZTD/QUCZvHt3QAKCRBfTkc5aZTD
/RAoAQCuGTpNUV3v/HumB6Xzj+rIUXMNrNa54SYnix+asEdPnQEA2ewTU1Ssy4N3
EfqlMOcJFFAPBwl3cP1zXSaLBYfHqw0=
=x/wp
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73338@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73338
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch