Rodrigo Morales wrote 6 months ago
(address . guix-patches@gnu.org)
This is one of my first contributions to the Guix project. If I have
done something wrong, please let me know so that I don't make the same
mistake in the future.
From 209787022655d89b2395e3d9c8bbd2b5417dfaf8 Mon Sep 17 00:00:00 2001
From: Rodrigo Morales <rodrigo@morales.pe>
Date: Sat, 7 Sep 2024 12:09:21 -0500
Subject: [PATCH] gnu: Add font-monocraft
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (29 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 98c20ee90a..0a7e79a8cd 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3958,3 +3958,22 @@ (define-public font-teko
full support for the conjuncts and ligatures required by languages
written with the Devanagari script.")
(license license:silofl1.1))))
+
+(define-public font-monocraft
+ (package
+ (name "font-monocraft")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/IdreesInc/Monocraft/releases/download/"
+ "v" version
+ "/Monocraft-ttf-otf.zip"))
+ (sha256
+ (base32 "1zy4a73779kaac69v8zmqa8v8s0a016k8bf2slani2msa1wsrnyy"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/IdreesInc/Monocraft/")
+ (synopsis "Monospaced programming font inspired by the Minecraft typeface.")
+ (description "Monospaced programming font inspired by the Minecraft typeface.")
+ (license license:silofl1.1)))
--
2.34.1