[PATCH] gnu: Add font-monocraft.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Maxime Devos
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 7 Sep 2022 07:17
(address . guix-patches@gnu.org)
y768rmvahlr.wl-hako@ultrarare.space
* gnu/packages/fonts.scm (font-monocraft): New variable.
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 09445cd00c..87272fe46c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2816,3 +2816,22 @@ (define-public font-chiron-hei-hk
Kong variant of Adobe’s Source Han Sans. The font aims at providing a modern,
region-agnostic glyph set adopting the “modern” glyph style that is similar to
prevalent typefaces in Traditional Chinese regions.")))
+
+(define-public font-monocraft
+ (package
+ (name "font-monocraft")
+ (version "1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/IdreesInc/Monocraft")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a7ibdgzc900mfw0jmpqq8hb4lbx3m3sfmv0pl44b2bhmpqqg0l4"))))
+ (build-system font-build-system)
+ (home-page "https://idreesinc.com/")
+ (synopsis "The font for developers who like Minecraft a bit too much")
+ (description "A programming font based on the typeface used in Minecraft.")
+ (license license:silofl1.1)))

base-commit: b9fa04fb2cb32a0b08720bfab37a870fb7426eb7
--
2.37.2
H
H
Hilton Chain wrote on 7 Sep 2022 19:23
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 57637-close@debbugs.gnu.org)
C1A860DA-21B1-465A-AF5E-827502A03121@ultrarare.space
Oops, I didn't realize that!

Thank you for the explanation~ (?^?^?)
M
M
Maxime Devos wrote on 7 Sep 2022 19:40
Fwd: [bug#57637] [PATCH] gnu: Add font-monocraft.
(address . 57637@debbugs.gnu.org)
94b15e63-c20f-bd84-9fc1-84a38cc007d6@telenet.be
I forgot to keep 57637 in CC ... sending a copy for the record.
-------- Forwarded Message --------
Subject: Re: [bug#57637] [PATCH] gnu: Add font-monocraft.
Date: Wed, 7 Sep 2022 15:43:46 +0200
From: Maxime Devos <maximedevos@telenet.be>
To: Hilton Chain <hako@ultrarare.space>
On 07-09-2022 07:17, Hilton Chain via Guix-patches via wrote:
Toggle quote (19 lines)
> +(define-public font-monocraft
> + (package
> + (name "font-monocraft")
> + (version "1.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url"https://github.com/IdreesInc/Monocraft")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1a7ibdgzc900mfw0jmpqq8hb4lbx3m3sfmv0pl44b2bhmpqqg0l4"))))
> + (build-system font-build-system)
> + (home-page"https://idreesinc.com/")
> + (synopsis "The font for developers who like Minecraft a bit too much")
> + (description "A programming font based on the typeface used in Minecraft.")
> + (license license:silofl1.1)))
>
Going by the README.md, this font is based on
Toggle quote (5 lines)
> * The characters in this font were based around the typeface
> <https://github.com/IdreesInc/Minecraft-Font> (*) used in the
> Minecraft UI, with a select few glyphs updated for better
> readability and spacing
>
Toggle quote (1 lines)
> The font has been carefully recreated pixel-by-pixel
, it is the same font as used in Minecraft.
Minecraft is non-free software.  It is possible that Minecraft's fonts
have a separate free license,
but unless someone brings evidence of the contrary, I would assume that
the copy (*) is not
allowed by Minecraft's license and that it does not allow letting the
license of the modified font be silofl1.1.
As such, unfortunately it appears this cannot be included in Guix (and
neither anywhere else).
Greetings,
Maxime
Attachment: file
Attachment: OpenPGP_signature
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57637@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57637
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch