(address . bug-guile@gnu.org)
Hello,
Here are two modules where one refers to a binding from the other:
Toggle snippet (16 lines)
$ cat three-oh-nine.scm
(define-module (three-oh-nine)
#:export (proc-with-kw-arg)
#:declarative? #t)
(define* (proc-with-kw-arg one #:optional three #:key (two 2))
(format #t "one: ~s two: ~s three: ~s~%" one two three))
$ cat three-oh-ten.scm
(define-module (three-oh-ten)
#:use-module (three-oh-nine)
#:export (proc-with-kw-args-user))
(define (proc-with-kw-args-user one)
(pk (+ 42 (proc-with-kw-arg one))))
We’ll compile the first one with 3.0.9 and the second one with 3.0.10,
referring to the .go obtained with 3.0.9:
Toggle snippet (37 lines)
$ guix shell guile@3.0.9 -- guild compile -O3 three-oh-nine.scm -o three-oh-nine.go
wrote `three-oh-nine.go'
$ guix shell guile -- env GUILE_LOAD_COMPILED_PATH=$PWD guild compile -O3 -L. three-oh-ten.scm -o three-oh-ten.go
Backtrace:
In language/tree-il/peval.scm:
1015:20 19 (loop _ #<vlist ()> #f values)
833:6 18 (loop _ #<vhash 7f6c73a834e0 2 pairs> #f values)
1052:26 17 (loop _ _ #f values)
1015:20 16 (loop _ #<vhash 7f6c73aa1c60 4 pairs> #f values)
833:6 15 (loop _ #<vhash 7f6c73aa1b80 6 pairs> #f values)
833:6 14 (loop _ #<vhash 7f6c73aa1b80 6 pairs> #f effect)
1427:25 13 (loop _ #<vhash 7f6c73aa1b80 6 pairs> #f effect)
In srfi/srfi-1.scm:
702:29 12 (map1 (#<tree-il (lexical proc-with-kw-args-user #{ g113}#)> #<tree-il (lexi…>))
702:17 11 (map1 (#<tree-il (lexical proc-with-kw-args-user #{ g114}#)>))
In language/tree-il/peval.scm:
887:11 10 (loop _ _ #f value)
379:22 9 (visit-operand #<<operand> var: #<<var> name: proc-with-kw-args-user gensym: …> …)
833:6 8 (loop #<tree-il (lambda ((name . proc-with-kw-args-user)) (lambda-case (((one…> …)
1886:20 7 (loop _ #<vhash 7f6c73aa1c60 4 pairs> #<<counter> effort: #<variable 7f6c72c2…> …)
1558:45 6 (loop _ _ _ values)
In srfi/srfi-1.scm:
702:17 5 (map1 (#<tree-il (primcall + (const 42) (call (@ (three-oh-nine) proc-with-kw…>))
In language/tree-il/peval.scm:
1427:25 4 (loop _ #<vhash 7f6c73aa1940 6 pairs> #<<counter> effort: #<variable 7f6c72c2…> …)
In srfi/srfi-1.scm:
702:29 3 (map1 (#<tree-il (const 42)> #<tree-il (call (@ (three-oh-nine) proc-with-kw…>))
702:17 2 (map1 (#<tree-il (call (@ (three-oh-nine) proc-with-kw-arg) (lexical one one-…>))
In language/tree-il/peval.scm:
1762:18 1 (loop _ _ _ _)
In ice-9/boot-9.scm:
1676:22 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1676:22: In procedure raise-exception:
internal error: unexpected kwarg syms ((#:two two #f)) (t123)
It doesn’t crash when using the same version for both compilations, or
when ignoring the .go file of the previous step.
Could it be related to f95bf6921e13799abca6a0a13087609c42baba6b?
The context in which this bug was found is described at
https://issues.guix.gnu.org/72183#6: building the ‘guix’ package with
3.0.10 against ‘guile-gcrypt’ built with 3.0.9 would trigger this
compiler bug.
Ludo’.