ffmpeg@{3,4,5} build failures on i686-linux

  • Done
  • quality assurance status badge
Details
3 participants
  • Dariqq
  • Ludovic Courtès
  • André Batista
Owner
unassigned
Submitted by
Dariqq
Severity
normal
D
D
Dariqq wrote on 31 Aug 17:46 +0200
(address . bug-guix@gnu.org)
d381c49b-69bd-4b17-a76f-3676bdac09a1@posteo.net
Hi,

Upgraded my old i686 machine to after core updates merge
(b8327cb31199fb9f4ebed6c53a59601d41def5a1) and now earlier versions of
ffmpeg fail to build.


phase `patch-source-shebangs' succeeded after 0.6 seconds
starting phase `bypass-openal-check'
phase `bypass-openal-check' succeeded after 0.0 seconds
starting phase `configure'
ERROR: openal not found



I can't find the "alGetError ||" string in the configure script which is
used to bypass the check on ffmepg@6 in the earlier versions (#72838).
D
D
Dariqq wrote on 1 Sep 14:15 +0200
(address . 72917@debbugs.gnu.org)
72c0e937-289b-47cc-a701-aadafdd162d9@posteo.net
I was able to reconfigure the system on core updates by adding the
following snippet into openals phases

#$@(if (target-x86-32?)
#~((add-before 'configure 'unprotect
(lambda* _
(substitute* "CMakeLists.txt"
(("if\\(HAVE_GCC_PROTECTED_VISIBILITY\\)") "if(0)")))))
#~())

which disables the protection causing problems. I don't know what the
implications of this change are.
A
A
André Batista wrote on 3 Sep 16:24 +0200
(name . Dariqq)(address . dariqq@posteo.net)
ZtccDScq0qAQwkhG@andel
Hi Dariqq,

s�b 31 ago 2024 �s 15:46:01 (1725129961), dariqq@posteo.net enviou:
Toggle quote (16 lines)
> Hi,
>
> Upgraded my old i686 machine to after core updates merge
> (b8327cb31199fb9f4ebed6c53a59601d41def5a1) and now earlier versions of
> ffmpeg fail to build.
>
> phase `patch-source-shebangs' succeeded after 0.6 seconds
> starting phase `bypass-openal-check'
> phase `bypass-openal-check' succeeded after 0.0 seconds
> starting phase `configure'
> ERROR: openal not found
>
> I can't find the "alGetError ||" string in the configure script which is
> used to bypass the check on ffmepg@6 in the earlier versions (#72838).
>

I'm sorry for that, I should've checked that this string would match on
earlier versions of ffmpeg. Looking back, replacing the 'die' clause
would make more sense. However, since changing it now would trigger
many rebuilds, I'll send a patch which changes the match only for the
broken earlier versions.

Thanks for reporting and feel free to CC me if/when you see that a patch
of mine has been incomplete or otherwise has caused issues.
A
A
André Batista wrote on 3 Sep 16:30 +0200
[PATCH] gnu: ffmpeg-{5,4,3}: Fix build on i686 with binutils 2.41.
(address . 72917@debbugs.gnu.org)
20240903143059.5704-1-nandre@riseup.net

* gnu/packages/video.scm (ffmpeg-5): Replace 'bypass-openal-check
string substitution with one that matches on this and earlier
versions of ffmpeg.
(ffmpeg-4): Inherit package arguments from ffmpeg-5.

Reported-by: Dariqq <dariqq@posteo.net>

Change-Id: Ie5b51a174be45b511757dece369563975e498bac
---
gnu/packages/video.scm | 18 ++++++++++++++++--
1 file changed, 16 insertions(+), 2 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ac9fabeb38..8b4da65836 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1845,6 +1845,9 @@ (define-public ffmpeg
;; https://lists.gnu.org/archive/html/guix-devel/2024-08/msg00159.html
(lambda _
(substitute* "configure"
+ ;; This string only matches on ffmpeg v6 and above.
+ ;; Replace it with the one defined at ffmpeg-5 which
+ ;; matches on all ffmpeg versions. See #71917.
(("alGetError \\|\\|")
"alGetError \|\| true \|\|")))))
#~())
@@ -1889,7 +1892,18 @@ (define-public ffmpeg-5
version ".tar.xz"))
(sha256
(base32
- "0qwhyhil805hns7yksdxagnrcc90h60al7lz1rc65kd1j2w3nf2l"))))))
+ "0qwhyhil805hns7yksdxagnrcc90h60al7lz1rc65kd1j2w3nf2l"))))
+ (arguments
+ (if (target-x86-32?)
+ (substitute-keyword-arguments (package-arguments ffmpeg)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'bypass-openal-check
+ (lambda _
+ (substitute* "configure"
+ (("die \"ERROR: openal not found\"")
+ "true")))))))
+ (package-arguments ffmpeg)))))
(define-public ffmpeg-4
(package
@@ -1907,7 +1921,7 @@ (define-public ffmpeg-4
(inputs (modify-inputs (package-inputs ffmpeg)
(replace "sdl2" sdl2-2.0)))
(arguments
- (substitute-keyword-arguments (package-arguments ffmpeg)
+ (substitute-keyword-arguments (package-arguments ffmpeg-5)
((#:configure-flags flags ''())
#~(cons "--enable-avresample" #$flags))))))

base-commit: 778dd796bff808f1f8520533bab239ecbe83cd87
--
2.45.2
A
A
André Batista wrote on 3 Sep 16:44 +0200
Re: bug#72917: ffmpeg@{3,4,5} build failures on i686-linux
(name . Dariqq)(address . dariqq@posteo.net)(address . 72917@debbugs.gnu.org)
ZtcgwwqAuxmpnXVe@andel
dom 01 set 2024 �s 12:15:01 (1725203701), dariqq@posteo.net enviou:
Toggle quote (13 lines)
> I was able to reconfigure the system on core updates by adding the following
> snippet into openals phases
>
> #$@(if (target-x86-32?)
> #~((add-before 'configure 'unprotect
> (lambda* _
> (substitute* "CMakeLists.txt"
> (("if\\(HAVE_GCC_PROTECTED_VISIBILITY\\)") "if(0)")))))
> #~())
>
> which disables the protection causing problems. I don't know what the
> implications of this change are.

The problem with this solution is twofold: first we would loose this
safety check for all packages that depend on openal and even for devs on
guix working with this library; second, since there are many packages
which use it as an input, this would trigger lots os rebuilds.

I think the reasons why this was implemented were described here:


Cheers!
A
A
André Batista wrote on 3 Sep 16:47 +0200
Patch: 72917
(address . control@debbugs.gnu.org)
ZtchfVHKNm9QgRDX@andel
tags 72917 + patch
thanks
D
D
Dariqq wrote on 3 Sep 19:39 +0200
Re: bug#72917: ffmpeg@{3,4,5} build failures on i686-linux
(name . André Batista)(address . nandre@riseup.net)
e2ef4ecd-3775-4f1b-8c5d-ddf452f067a9@posteo.net
Hi André,

On 03.09.24 16:24, André Batista wrote:

Toggle quote (8 lines)
>
> I'm sorry for that, I should've checked that this string would match on
> earlier versions of ffmpeg. Looking back, replacing the 'die' clause
> would make more sense. However, since changing it now would trigger
> many rebuilds, I'll send a patch which changes the match only for the
> broken earlier versions.
>

Thanks, your patch looks a lot more sensible than my bruteforce way. I
have successfully rebuild my system with your patch applied.

What would be the best way to get it to master? QA seems to think the
issue contains no patch.

Toggle quote (3 lines)
> Thanks for reporting and feel free to CC me if/when you see that a patch
> of mine has been incomplete or otherwise has caused issues.

Have a nice day,
Dariqq
L
L
Ludovic Courtès wrote on 4 Sep 19:10 +0200
Re: [PATCH] gnu: ffmpeg-{5, 4, 3}: Fix build on i686 with binutils 2.41.
(name . André Batista)(address . nandre@riseup.net)
87y147bazx.fsf@gnu.org
Hi André,

André Batista <nandre@riseup.net> skribis:

Toggle quote (11 lines)
>
> * gnu/packages/video.scm (ffmpeg-5): Replace 'bypass-openal-check
> string substitution with one that matches on this and earlier
> versions of ffmpeg.
> (ffmpeg-4): Inherit package arguments from ffmpeg-5.
>
> Reported-by: Dariqq <dariqq@posteo.net>
>
> Change-Id: Ie5b51a174be45b511757dece369563975e498bac

Applied, thanks! And thank you Dariqq for reporting the issue and
testing the patch.

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 5 Sep 09:25 +0200
Re: bug#72917: ffmpeg@{3,4,5} build failures on i686-linux
(name . André Batista)(address . nandre@riseup.net)
87plpia7f3.fsf_-_@gnu.org
Hello,

André Batista <nandre@riseup.net> skribis:

Toggle quote (11 lines)
>
> * gnu/packages/video.scm (ffmpeg-5): Replace 'bypass-openal-check
> string substitution with one that matches on this and earlier
> versions of ffmpeg.
> (ffmpeg-4): Inherit package arguments from ffmpeg-5.
>
> Reported-by: Dariqq <dariqq@posteo.net>
>
> Change-Id: Ie5b51a174be45b511757dece369563975e498bac

As it turns out, while all 3 variants built fine for i686 on a machine
of mine, there are test failures at ci.guix:


Toggle snippet (32 lines)
--- ./tests/ref/fate/filter-lavd-scalenorm 2023-11-09 23:38:51.000000000 +0000
+++ tests/data/fate/filter-lavd-scalenorm 2024-09-04 17:57:08.701821746 +0000
@@ -1,15 +0,0 @@
-#tb 0: 1/5
-#media_type 0: video
-#codec_id 0: rawvideo
-#dimensions 0: 128x96
-#sar 0: 1/1
-0, 0, 0, 1, 18432, 0xac484db5
-0, 1, 1, 1, 18432, 0x94734db6
-0, 2, 2, 1, 18432, 0x3fac4db3
-0, 3, 3, 1, 18432, 0x37a94dcd
-0, 4, 4, 1, 18432, 0x2b3e4dbb
-0, 5, 5, 1, 18432, 0xd23a67bf
-0, 6, 6, 1, 18432, 0x898368e1
-0, 7, 7, 1, 18432, 0x79466438
-0, 8, 8, 1, 18432, 0x458c5d95
-0, 9, 9, 1, 18432, 0x9d9a56ee
Test filter-lavd-scalenorm failed. Look at tests/data/fate/filter-lavd-scalenorm.err for details.
make: *** [tests/Makefile:304: fate-filter-lavd-scalenorm] Error 1
make: *** Waiting for unfinished jobs....
TEST filter-refcmp-psnr-rgb

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("fate" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 8.7 seconds
command "make" "fate" "-j" "24" failed with status 2
build process 18 exited with status 256
builder for `/gnu/store/7wsa154li4w974z2p6qnaaw97ng9m8hq-ffmpeg-5.1.4.drv' failed with exit code 1

Toggle snippet (29 lines)
--- ./tests/ref/lavf/fits 1970-01-01 00:00:01.000000000 +0000
+++ tests/data/fate/lavf-fits 2024-09-04 17:57:17.900035764 +0000
@@ -1,9 +1,9 @@
ed9fd697d0d782df6201f6a2db184552 *./tests/data/lavf/graylavf.fits
5328000 ./tests/data/lavf/graylavf.fits
-./tests/data/lavf/graylavf.fits CRC=0xbacf446c
+./tests/data/lavf/graylavf.fits CRC=0xeb450e41
48e6caf6a59e32f9a8a39979c9183a7f *./tests/data/lavf/gray16belavf.fits
10368000 ./tests/data/lavf/gray16belavf.fits
-./tests/data/lavf/gray16belavf.fits CRC=0xae2b58d4
+./tests/data/lavf/gray16belavf.fits CRC=0xcc6d0df7
be2f7112fd193c9a909304c81e662769 *./tests/data/lavf/gbrplavf.fits
15408000 ./tests/data/lavf/gbrplavf.fits
./tests/data/lavf/gbrplavf.fits CRC=0x04ed3828
TEST filter-pixdesc-yuv422p
TEST filter-pixdesc-yuv444p
Test lavf-fits failed. Look at tests/data/fate/lavf-fits.err for details.
make: *** [tests/Makefile:226: fate-lavf-fits] Error 1
make: *** Waiting for unfinished jobs....

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("fate" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 17.3 seconds
command "make" "fate" "-j" "24" failed with status 2
build process 18 exited with status 256
builder for `/gnu/store/90fv07zbjc92dscaj42c2yzrqpl1qlza-ffmpeg-3.4.13.drv' failed with exit code 1

Are you seeing this? Does the Internet have something to say about
these?

Thanks,
Ludo’.
D
D
Dariqq wrote on 5 Sep 21:43 +0200
(address . 72917@debbugs.gnu.org)
1c45931c-6787-4f9f-8165-fd66b8c17b25@posteo.net
Hi,

On 05.09.24 09:25, Ludovic Courtès wrote:
Toggle quote (77 lines)
> Hello,

>
> As it turns out, while all 3 variants built fine for i686 on a machine
> of mine, there are test failures at ci.guix:
>
> From <https://ci.guix.gnu.org/build/5613329/details>:
>
> --8<---------------cut here---------------start------------->8---
> --- ./tests/ref/fate/filter-lavd-scalenorm 2023-11-09 23:38:51.000000000 +0000
> +++ tests/data/fate/filter-lavd-scalenorm 2024-09-04 17:57:08.701821746 +0000
> @@ -1,15 +0,0 @@
> -#tb 0: 1/5
> -#media_type 0: video
> -#codec_id 0: rawvideo
> -#dimensions 0: 128x96
> -#sar 0: 1/1
> -0, 0, 0, 1, 18432, 0xac484db5
> -0, 1, 1, 1, 18432, 0x94734db6
> -0, 2, 2, 1, 18432, 0x3fac4db3
> -0, 3, 3, 1, 18432, 0x37a94dcd
> -0, 4, 4, 1, 18432, 0x2b3e4dbb
> -0, 5, 5, 1, 18432, 0xd23a67bf
> -0, 6, 6, 1, 18432, 0x898368e1
> -0, 7, 7, 1, 18432, 0x79466438
> -0, 8, 8, 1, 18432, 0x458c5d95
> -0, 9, 9, 1, 18432, 0x9d9a56ee
> Test filter-lavd-scalenorm failed. Look at tests/data/fate/filter-lavd-scalenorm.err for details.
> make: *** [tests/Makefile:304: fate-filter-lavd-scalenorm] Error 1
> make: *** Waiting for unfinished jobs....
> TEST filter-refcmp-psnr-rgb
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("fate" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 8.7 seconds
> command "make" "fate" "-j" "24" failed with status 2
> build process 18 exited with status 256
> builder for `/gnu/store/7wsa154li4w974z2p6qnaaw97ng9m8hq-ffmpeg-5.1.4.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> And from <https://ci.guix.gnu.org/build/5613330/details>:
>
> --8<---------------cut here---------------start------------->8---
> --- ./tests/ref/lavf/fits 1970-01-01 00:00:01.000000000 +0000
> +++ tests/data/fate/lavf-fits 2024-09-04 17:57:17.900035764 +0000
> @@ -1,9 +1,9 @@
> ed9fd697d0d782df6201f6a2db184552 *./tests/data/lavf/graylavf.fits
> 5328000 ./tests/data/lavf/graylavf.fits
> -./tests/data/lavf/graylavf.fits CRC=0xbacf446c
> +./tests/data/lavf/graylavf.fits CRC=0xeb450e41
> 48e6caf6a59e32f9a8a39979c9183a7f *./tests/data/lavf/gray16belavf.fits
> 10368000 ./tests/data/lavf/gray16belavf.fits
> -./tests/data/lavf/gray16belavf.fits CRC=0xae2b58d4
> +./tests/data/lavf/gray16belavf.fits CRC=0xcc6d0df7
> be2f7112fd193c9a909304c81e662769 *./tests/data/lavf/gbrplavf.fits
> 15408000 ./tests/data/lavf/gbrplavf.fits
> ./tests/data/lavf/gbrplavf.fits CRC=0x04ed3828
> TEST filter-pixdesc-yuv422p
> TEST filter-pixdesc-yuv444p
> Test lavf-fits failed. Look at tests/data/fate/lavf-fits.err for details.
> make: *** [tests/Makefile:226: fate-lavf-fits] Error 1
> make: *** Waiting for unfinished jobs....
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("fate" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 17.3 seconds
> command "make" "fate" "-j" "24" failed with status 2
> build process 18 exited with status 256
> builder for `/gnu/store/90fv07zbjc92dscaj42c2yzrqpl1qlza-ffmpeg-3.4.13.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> Are you seeing this? Does the Internet have something to say about
> these?
>

ffmpeg@5 builds without issues for me. For ffmpeg@3 the tests always
fail at the lavf-fits tests same as the ci system.

For ffmpeg@4 which has by far the most dependants (including things like
webkitgtk etc) i have no test issues.

Toggle quote (3 lines)
> Thanks,
> Ludo’.

I hope this helps,
Dariqq
A
A
André Batista wrote on 6 Sep 01:47 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)
ZtpDG7e_KsKno6II@andel
Hi,

qui 05 set 2024 �s 09:25:36 (1725539136), ludo@gnu.org enviou:
Toggle quote (66 lines)
> Hello,
>
> As it turns out, while all 3 variants built fine for i686 on a machine
> of mine, there are test failures at ci.guix:
>
> From <https://ci.guix.gnu.org/build/5613329/details>:
>
> --8<---------------cut here---------------start------------->8---
> --- ./tests/ref/fate/filter-lavd-scalenorm 2023-11-09 23:38:51.000000000 +0000
> +++ tests/data/fate/filter-lavd-scalenorm 2024-09-04 17:57:08.701821746 +0000
> @@ -1,15 +0,0 @@
> -#tb 0: 1/5
> -#media_type 0: video
> -#codec_id 0: rawvideo
> -#dimensions 0: 128x96
> -#sar 0: 1/1
> -0, 0, 0, 1, 18432, 0xac484db5
> -0, 1, 1, 1, 18432, 0x94734db6
> -0, 2, 2, 1, 18432, 0x3fac4db3
> -0, 3, 3, 1, 18432, 0x37a94dcd
> -0, 4, 4, 1, 18432, 0x2b3e4dbb
> -0, 5, 5, 1, 18432, 0xd23a67bf
> -0, 6, 6, 1, 18432, 0x898368e1
> -0, 7, 7, 1, 18432, 0x79466438
> -0, 8, 8, 1, 18432, 0x458c5d95
> -0, 9, 9, 1, 18432, 0x9d9a56ee
> Test filter-lavd-scalenorm failed. Look at tests/data/fate/filter-lavd-scalenorm.err for details.
> make: *** [tests/Makefile:304: fate-filter-lavd-scalenorm] Error 1
> make: *** Waiting for unfinished jobs....
> TEST filter-refcmp-psnr-rgb
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("fate" "-j" "24") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 8.7 seconds
> command "make" "fate" "-j" "24" failed with status 2
> build process 18 exited with status 256
> builder for `/gnu/store/7wsa154li4w974z2p6qnaaw97ng9m8hq-ffmpeg-5.1.4.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> And from <https://ci.guix.gnu.org/build/5613330/details>:
>
> --8<---------------cut here---------------start------------->8---
> --- ./tests/ref/lavf/fits 1970-01-01 00:00:01.000000000 +0000
> +++ tests/data/fate/lavf-fits 2024-09-04 17:57:17.900035764 +0000
> @@ -1,9 +1,9 @@
> ed9fd697d0d782df6201f6a2db184552 *./tests/data/lavf/graylavf.fits
> 5328000 ./tests/data/lavf/graylavf.fits
> -./tests/data/lavf/graylavf.fits CRC=0xbacf446c
> +./tests/data/lavf/graylavf.fits CRC=0xeb450e41
> 48e6caf6a59e32f9a8a39979c9183a7f *./tests/data/lavf/gray16belavf.fits
> 10368000 ./tests/data/lavf/gray16belavf.fits
> -./tests/data/lavf/gray16belavf.fits CRC=0xae2b58d4
> +./tests/data/lavf/gray16belavf.fits CRC=0xcc6d0df7
> be2f7112fd193c9a909304c81e662769 *./tests/data/lavf/gbrplavf.fits
> 15408000 ./tests/data/lavf/gbrplavf.fits
> ./tests/data/lavf/gbrplavf.fits CRC=0x04ed3828
> TEST filter-pixdesc-yuv422p
> TEST filter-pixdesc-yuv444p
> Test lavf-fits failed. Look at tests/data/fate/lavf-fits.err for details.
> make: *** [tests/Makefile:226: fate-lavf-fits] Error 1
> make: *** Waiting for unfinished jobs....
>
> Are you seeing this? Does the Internet have something to say about
> these?

No I did not see this here, all tests passed. I've tried searching
ffmpeg bug tracker and commit logs but nothing useful came up.

Is it possible to see that 'tests/data/fate/lavf-fits.err' file on
CI somehow? I don't actually expect it to be of much help though.

I also see errors on ffmpeg-3, as Dariqq mentioned, but looking at
the build history on CI it had also appeared on
the core-updates merge, so it seems unrelated.
A
A
André Batista wrote on 11 Sep 22:10 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)
ZuH5Sbq8WVk8zOeM@andel
Hi,

qui 05 set 2024 �s 20:47:39 (1725580059), nandre@riseup.net enviou:
Toggle quote (48 lines)
>
> qui 05 set 2024 �s 09:25:36 (1725539136), ludo@gnu.org enviou:
> >
> > As it turns out, while all 3 variants built fine for i686 on a machine
> > of mine, there are test failures at ci.guix:
> >
> > From <https://ci.guix.gnu.org/build/5613329/details>:
> >
> > [...]
> >
> > And from <https://ci.guix.gnu.org/build/5613330/details>:
> >
> > --8<---------------cut here---------------start------------->8---
> > --- ./tests/ref/lavf/fits 1970-01-01 00:00:01.000000000 +0000
> > +++ tests/data/fate/lavf-fits 2024-09-04 17:57:17.900035764 +0000
> > @@ -1,9 +1,9 @@
> > ed9fd697d0d782df6201f6a2db184552 *./tests/data/lavf/graylavf.fits
> > 5328000 ./tests/data/lavf/graylavf.fits
> > -./tests/data/lavf/graylavf.fits CRC=0xbacf446c
> > +./tests/data/lavf/graylavf.fits CRC=0xeb450e41
> > 48e6caf6a59e32f9a8a39979c9183a7f *./tests/data/lavf/gray16belavf.fits
> > 10368000 ./tests/data/lavf/gray16belavf.fits
> > -./tests/data/lavf/gray16belavf.fits CRC=0xae2b58d4
> > +./tests/data/lavf/gray16belavf.fits CRC=0xcc6d0df7
> > be2f7112fd193c9a909304c81e662769 *./tests/data/lavf/gbrplavf.fits
> > 15408000 ./tests/data/lavf/gbrplavf.fits
> > ./tests/data/lavf/gbrplavf.fits CRC=0x04ed3828
> > TEST filter-pixdesc-yuv422p
> > TEST filter-pixdesc-yuv444p
> > Test lavf-fits failed. Look at tests/data/fate/lavf-fits.err for details.
> > make: *** [tests/Makefile:226: fate-lavf-fits] Error 1
> > make: *** Waiting for unfinished jobs....
> >
> > Are you seeing this? Does the Internet have something to say about
> > these?
>
> No I did not see this here, all tests passed. I've tried searching
> ffmpeg bug tracker and commit logs but nothing useful came up.
>
> Is it possible to see that 'tests/data/fate/lavf-fits.err' file on
> CI somehow? I don't actually expect it to be of much help though.
>
> I also see errors on ffmpeg-3, as Dariqq mentioned, but looking at
> the build history on CI it had also appeared on
> <https://ci.guix.gnu.org/build/5382581/log/raw> which was before
> the core-updates merge, so it seems unrelated.
>

Sorry, I think my previous message was a bit confusing. What I meant to
say was that ffmpeg-5 had build fine here, but ffmpeg-3 didn't and I did
hit the same error as above shown on CI.

Since then, CI has successfully built ffmpeg-5[1]. So I'm guessing its
test failure was transient, even though this latest success originated
from a commit[2] which was afterwards reverted[3].

However, ffmpeg-3 is still failing[4] with that same lavf.fits error,
even on that same commit. I've dabbed here increasing the verbosity to
debug level, but I still don't have any clue as to what is triggering
this failure.

I'll report this upstream and see if ffmpeg devs can help us out here.
Otherwise, as a last resource, we could disable that test and live with
a slightly broken ffmpeg-3.




A
A
André Batista wrote on 11 Sep 23:14 +0200
Re: bug#72917: ffmpeg-3 build failures is duplicate of bug#67308
(name . Ludovic Courtès)(address . ludo@gnu.org)
ZuIIKVP0Fo5Z5WVj@andel
qua 11 set 2024 �s 17:10:49 (1726085449), nandre@riseup.net enviou:
Toggle quote (45 lines)
>
> qui 05 set 2024 �s 20:47:39 (1725580059), nandre@riseup.net enviou:
> >
> > qui 05 set 2024 �s 09:25:36 (1725539136), ludo@gnu.org enviou:
> > >
> > > [...]
> > >
> > > And from <https://ci.guix.gnu.org/build/5613330/details>:
> > >
> > > --8<---------------cut here---------------start------------->8---
> > > --- ./tests/ref/lavf/fits 1970-01-01 00:00:01.000000000 +0000
> > > +++ tests/data/fate/lavf-fits 2024-09-04 17:57:17.900035764 +0000
> > > @@ -1,9 +1,9 @@
> > > ed9fd697d0d782df6201f6a2db184552 *./tests/data/lavf/graylavf.fits
> > > 5328000 ./tests/data/lavf/graylavf.fits
> > > -./tests/data/lavf/graylavf.fits CRC=0xbacf446c
> > > +./tests/data/lavf/graylavf.fits CRC=0xeb450e41
> > > 48e6caf6a59e32f9a8a39979c9183a7f *./tests/data/lavf/gray16belavf.fits
> > > 10368000 ./tests/data/lavf/gray16belavf.fits
> > > -./tests/data/lavf/gray16belavf.fits CRC=0xae2b58d4
> > > +./tests/data/lavf/gray16belavf.fits CRC=0xcc6d0df7
> > > be2f7112fd193c9a909304c81e662769 *./tests/data/lavf/gbrplavf.fits
> > > 15408000 ./tests/data/lavf/gbrplavf.fits
> > > ./tests/data/lavf/gbrplavf.fits CRC=0x04ed3828
> > > TEST filter-pixdesc-yuv422p
> > > TEST filter-pixdesc-yuv444p
> > > Test lavf-fits failed. Look at tests/data/fate/lavf-fits.err for details.
> > > make: *** [tests/Makefile:226: fate-lavf-fits] Error 1
> > > make: *** Waiting for unfinished jobs....
> > >
> >
> > I also see errors on ffmpeg-3, as Dariqq mentioned, but looking at
> > the build history on CI it had also appeared on
> > <https://ci.guix.gnu.org/build/5382581/log/raw> which was before
> > the core-updates merge, so it seems unrelated.
> >
>
> [...]
>
> However, ffmpeg-3 is still failing[4] with that same lavf.fits error,
> even on that same commit. I've dabbed here increasing the verbosity to
> debug level, but I still don't have any clue as to what is triggering
> this failure.
>

This ffmpeg-3 error was already reported at #67308[1]. So I suggest we
discuss it there, if anyone makes any progress.

+CC 67308 for reference.

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72917@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72917
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch