[PATCH python-team] gnu: python-pygments: Update to 2.18.0.

  • Open
  • quality assurance status badge
Details
3 participants
  • Felix Gruber
  • jgart
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 7 Jul 20:34 +0200
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
ff408ae39ce3d8311a087dc17fb574dbbccbed34.1720377247.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Remove python-setuptools and python-wheel;
add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..33bb2ef599 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7125,14 +7125,14 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7141,7 +7141,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest python-setuptools python-wheel))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description

base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.2
J
(address . 71984@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
87msmrj4jl.fsf@dismail.de
Hi Felix,

This patch is empty according to `mumi am -- -s -S`.

Did you send this patch with git send-email or by some other means like
email attachment?

Just trying to understand why this failed.
--
all the best,
jgart
F
F
Felix Gruber wrote on 8 Jul 18:20 +0200
7f411e6a-5ab0-4f56-96e6-339159c93ca0@posteo.net
Hi jgart,

On 7/8/24 5:18 PM, jgart wrote:
Toggle quote (7 lines)
> This patch is empty according to `mumi am -- -s -S`.
>
> Did you send this patch with git send-email or by some other means like
> email attachment?
>
> Just trying to understand why this failed.

That's weird. I generated the patch with git send-email from a commit
that I had on top of the python-team branch.
If I download my email as .mbox from https://issues.guix.gnu.org/71984
via the "Download raw message" button, I'm able to apply it on top of
the python-team branch with git am.

I never tried mumi. I wonder what it does differently from git am.

Kind regards,
Felix
J
f345b96c813ff7090064a498628a4be599bf9048@dismail.de
Hi Felix,

Oops my fault, I was trying to apply this on master. ?

Can you rebase this patch on the master branch? I can review it there.

The python-team branch is already overloaded, stale, and requires a ton of merge conflict resolving.

Adding python-pygments to the python-team branch will only add to that ?

Can you also CC Sharlatan, and ask Sharlatan to try building all the dependents that this patch triggers?

Sharlatan Hellseher <sharlatanus@gmail.com>

I won't be able to test that on my old Thinkpad X230 machine.

all the best,

jgart
F
F
Felix Gruber wrote on 8 Jul 20:43 +0200
[PATCH v2 0/2] gnu: python-pygments: Update to 2.18.0.
cover.1720464214.git.felgru@posteo.net
Hi jgart, hi Sharlatan,

I've rebased my patch from the python-team branch to master, like jgart
asked for.

Sharlatan, could you try to build all the dependents that my patch
triggers?

I've also included an older commit from the python-team branch that
updated python-pygments to use the pyproject-build-system and enabled
some of its tests.

Kind regards,
Felix


Felix Gruber (1):
gnu: python-pygments: Update to 2.18.0.

Ricardo Wurmus (1):
gnu: python-pygments: Update to 2.15.1.

gnu/packages/python-xyz.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: 13f0f52314244f08eb9fdd626d907c0c3976e06a
--
2.43.0
F
F
Felix Gruber wrote on 8 Jul 20:43 +0200
[PATCH v2 1/2] gnu: python-pygments: Update to 2.15.1.
0f57c0f06155f605c76e24e2ef8655f7a8a9d738.1720464215.git.felgru@posteo.net
From: Ricardo Wurmus <rekado@elephly.net>

* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
---
gnu/packages/python-xyz.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c432e9b65..05d4a8b710 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,18 +7019,23 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.12.0")
+ (version "2.15.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
- (build-system python-build-system)
+ "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Tests require sphinx, which depends on this.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ ;; Some tests require sphinx, which depends on this, so we only run
+ ;; basic tests.
+ '(list "--ignore-glob=tests/*/*")))
+ (native-inputs
+ (list python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description
--
2.43.0
F
F
Felix Gruber wrote on 8 Jul 20:43 +0200
[PATCH v2 2/2] gnu: python-pygments: Update to 2.18.0.
b94b1caa87460dba9aa63a985e9729d86ac7321b.1720464215.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 05d4a8b710..4cd971fbaa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,14 +7019,14 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7035,7 +7035,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description
--
2.43.0
J
33bbb1dccec6ec80519fb00395c87fefc02bdc58@dismail.de
Hi Sharlatan,

You had mentioned previously being able to test patches that require a lot of builds on your own build machine.

Could you test this v2 that Felix just sent to bug#71984 along with all top-level dependent packages that would need to be rebuilt as a result of it (guix refresh -l) when you get a chance and reply back to us with the result?

QA doesn't seem to be working for ticket #71984.

Thanks!

jgart
R
R
Ricardo Wurmus wrote on 18 Jul 16:56 +0200
Re: [PATCH v2 1/2] gnu: python-pygments: Update to 2.15.1.
(name . Felix Gruber)(address . felgru@posteo.net)
87le1y21h6.fsf@elephly.net
Felix Gruber <felgru@posteo.net> writes:

Toggle quote (7 lines)
> From: Ricardo Wurmus <rekado@elephly.net>
>
> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-pytest.

I don't understand why this should go to he master branch. It's already
on the python-team branch and it hasn't been merged, because there has
been quite a bit of fallout from this change and the changes it
prompted.

I'd prefer to just bring the python-team branch in order and merge it
once core-updates is ready.

--
Ricardo
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71984@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71984
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch