(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Remove python-setuptools and python-wheel;
add python-hatchling.
Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..33bb2ef599 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7125,14 +7125,14 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7141,7 +7141,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest python-setuptools python-wheel))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description
base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.2