[PATCH python-team] gnu: python-pygments: Update to 2.18.0.

  • Open
  • quality assurance status badge
Details
4 participants
  • Felix Gruber
  • jgart
  • Ricardo Wurmus
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal

Debbugs page

Felix Gruber wrote 8 months ago
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
ff408ae39ce3d8311a087dc17fb574dbbccbed34.1720377247.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Remove python-setuptools and python-wheel;
add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..33bb2ef599 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7125,14 +7125,14 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7141,7 +7141,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest python-setuptools python-wheel))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description

base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.2
jgart wrote 8 months ago
(address . 71984@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
87msmrj4jl.fsf@dismail.de
Hi Felix,

This patch is empty according to `mumi am -- -s -S`.

Did you send this patch with git send-email or by some other means like
email attachment?

Just trying to understand why this failed.
--
all the best,
jgart
Felix Gruber wrote 8 months ago
(name . jgart)(address . jgart@dismail.de)(address . 71984@debbugs.gnu.org)
7f411e6a-5ab0-4f56-96e6-339159c93ca0@posteo.net
Hi jgart,

On 7/8/24 5:18 PM, jgart wrote:
Toggle quote (7 lines)
> This patch is empty according to `mumi am -- -s -S`.
>
> Did you send this patch with git send-email or by some other means like
> email attachment?
>
> Just trying to understand why this failed.

That's weird. I generated the patch with git send-email from a commit
that I had on top of the python-team branch.
If I download my email as .mbox from https://issues.guix.gnu.org/71984
via the "Download raw message" button, I'm able to apply it on top of
the python-team branch with git am.

I never tried mumi. I wonder what it does differently from git am.

Kind regards,
Felix
jgart wrote 8 months ago
(name . Felix Gruber)(address . felgru@posteo.net)(address . 71984@debbugs.gnu.org)
f345b96c813ff7090064a498628a4be599bf9048@dismail.de
Hi Felix,

Oops my fault, I was trying to apply this on master. 🦆

Can you rebase this patch on the master branch? I can review it there.

The python-team branch is already overloaded, stale, and requires a ton of merge conflict resolving.

Adding python-pygments to the python-team branch will only add to that 🙃

Can you also CC Sharlatan, and ask Sharlatan to try building all the dependents that this patch triggers?

Sharlatan Hellseher <sharlatanus@gmail.com>

I won't be able to test that on my old Thinkpad X230 machine.

all the best,

jgart
Felix Gruber wrote 8 months ago
[PATCH v2 0/2] gnu: python-pygments: Update to 2.18.0.
(address . 71984@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)(name . Felix Gruber)(address . felgru@posteo.net)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1720464214.git.felgru@posteo.net
Hi jgart, hi Sharlatan,

I've rebased my patch from the python-team branch to master, like jgart
asked for.

Sharlatan, could you try to build all the dependents that my patch
triggers?

I've also included an older commit from the python-team branch that
updated python-pygments to use the pyproject-build-system and enabled
some of its tests.

Kind regards,
Felix


Felix Gruber (1):
gnu: python-pygments: Update to 2.18.0.

Ricardo Wurmus (1):
gnu: python-pygments: Update to 2.15.1.

gnu/packages/python-xyz.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: 13f0f52314244f08eb9fdd626d907c0c3976e06a
--
2.43.0
Felix Gruber wrote 8 months ago
[PATCH v2 1/2] gnu: python-pygments: Update to 2.15.1.
(address . 71984@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)(name . Ricardo Wurmus)(address . rekado@elephly.net)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
0f57c0f06155f605c76e24e2ef8655f7a8a9d738.1720464215.git.felgru@posteo.net
From: Ricardo Wurmus <rekado@elephly.net>

* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
---
gnu/packages/python-xyz.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c432e9b65..05d4a8b710 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,18 +7019,23 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.12.0")
+ (version "2.15.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
- (build-system python-build-system)
+ "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Tests require sphinx, which depends on this.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ ;; Some tests require sphinx, which depends on this, so we only run
+ ;; basic tests.
+ '(list "--ignore-glob=tests/*/*")))
+ (native-inputs
+ (list python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description
--
2.43.0
Felix Gruber wrote 8 months ago
[PATCH v2 2/2] gnu: python-pygments: Update to 2.18.0.
(address . 71984@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)(name . Felix Gruber)(address . felgru@posteo.net)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
b94b1caa87460dba9aa63a985e9729d86ac7321b.1720464215.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 05d4a8b710..4cd971fbaa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,14 +7019,14 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7035,7 +7035,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description
--
2.43.0
jgart wrote 8 months ago
(name . Felix Gruber)(address . felgru@posteo.net)(address . 71984@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(name . Munyoki Kilyungi)(address . me@bonfacemunyoki.com)(name . Lars-Dominik Braun)(address . lars@6xq.net)(name . Marius Bakke)(address . marius@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
33bbb1dccec6ec80519fb00395c87fefc02bdc58@dismail.de
Hi Sharlatan,

You had mentioned previously being able to test patches that require a lot of builds on your own build machine.

Could you test this v2 that Felix just sent to bug#71984 along with all top-level dependent packages that would need to be rebuilt as a result of it (guix refresh -l) when you get a chance and reply back to us with the result?

QA doesn't seem to be working for ticket #71984.

Thanks!

jgart
Ricardo Wurmus wrote 8 months ago
Re: [PATCH v2 1/2] gnu: python-pygments: Update to 2.15.1.
(name . Felix Gruber)(address . felgru@posteo.net)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(name . jgart)(address . jgart@dismail.de)(address . 71984@debbugs.gnu.org)
87le1y21h6.fsf@elephly.net
Felix Gruber <felgru@posteo.net> writes:

Toggle quote (7 lines)
> From: Ricardo Wurmus <rekado@elephly.net>
>
> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-pytest.

I don't understand why this should go to he master branch. It's already
on the python-team branch and it hasn't been merged, because there has
been quite a bit of fallout from this change and the changes it
prompted.

I'd prefer to just bring the python-team branch in order and merge it
once core-updates is ready.

--
Ricardo
Felix Gruber wrote 2 months ago
[PATCH] gnu: python-pygments: Update to 2.19.1.
(address . 71984@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
8ccc3cbfc77315c3e72f1735401a3ac535e3032c.1737661651.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.19.1.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Add python-hatchling; remove python-setuptools and
python-wheel.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9e5fa9a26c..c8b5ed1424 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7729,14 +7729,14 @@ (define-public python-pygdbmi
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.15.1")
+ (version "2.19.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Pygments" version))
+ (uri (pypi-uri "pygments" version))
(sha256
(base32
- "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ "07qm8mx3y5r8ri6zpn0hp9zx5g02bydhi7pkv54hdp3nhlm6vhb1"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -7745,7 +7745,7 @@ (define-public python-pygments
;; basic tests.
'(list "--ignore-glob=tests/*/*")))
(native-inputs
- (list python-pytest python-setuptools python-wheel))
+ (list python-hatchling python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description

base-commit: 253c7c309a03612d8ff8c37ff6af364aaa044e1b
--
2.47.1
Sharlatan Hellseher wrote 2 months ago
[PATCH python-team] gnu: python-pygments: Update to 2.18.0.
(address . 71984@debbugs.gnu.org)
87cygaqwkm.fsf@gmail.com
Hi,

With this patch Sphinx 6 fails to build it's default version in Guix
right now. Upstream is on 8+ already, maybe we may include Sphinx
refresh in this iteration as well.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmeVeZkACgkQdtcnv/Ys
0rXgFhAAsrCighI50UkPIKIDT8OEvEDovVUpHcfno1soCbM4X6hQQtTN0ho8BNpQ
GMuU+8+xld5EQfnAcpjUcjDzrXRwKuqNmklJBXFl8XkxQZRw+dQqA3yH0Jug4FlC
gndQq2FNetH7ggzapSI7h2endWcol1L1iY1mUi8olVgLncXrYoYovMHpafciU5e3
g4CzEs64HBgTwm/2qgifaeiqWbW4FSlObUhZxC6kd4xRHBGtq2Wbw0oIbWHaoEGy
3lLgMZGfxd1frAYfCIqjqjy/+G4i1Cw+98gA0IOMHoKNYWI+FBYnuN/qJzTHRx+x
vVX1Kx1IsN0YdlnwRi059xuY1riixujXN3CSWIob3z4h0sNCo46ZgwXEkZB4gn5G
r7VFXVzWHTm+LHqfnBWOPnpackrQoBRGxlQp3RoDvAZk1tyNN1wyUovd0+ZqTBtD
Jo715kHsm/9l2CzIOblYIV9JsNRLKSbxf2bABxtJecvKRNdTDzV6rHtVXxHdsE5d
AaMByJrdQ+fxePBQv2HwQStRM9pCNx8s/znRA4kZyCT/pkB5oqMQzj0dstHzXbkt
uAKYfy0ZUUDXUCDTCI75B1TgjxpNyz565Elbh2Q0EQBAdxA4hVt877ycs3KIO7p9
c5/s0aoRx5FYrp7TUEkyC5r+NOCUl7Ac1qvuQnVtkYJv/1Vju7o=
=xceF
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71984@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71984
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help