Thanos Apollo wrote 8 months ago
(address . guix-patches@gnu.org)
Hello,
Attaching patches below.
From aa45d9415cb30716299192b4c8e4e70d36857522 Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:12:47 +0300
Subject: [PATCH] gnu: Add emacs-eshell-git-prompt
* gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.
Change-Id: Ib4d98aed6345aa8b1275449e1e627afa22212604
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab6a4cf4ab..a13af2a5a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35181,6 +35181,28 @@ (define-public emacs-eshell-did-you-mean
commands that bear resemblance to the input command.")
(license license:gpl3+)))
+(define-public emacs-eshell-git-prompt
+ (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+ (package
+ (name "emacs-eshell-git-prompt")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-git-prompt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+ (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+ (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+ (license license:gpl3+))))
+
(define-public emacs-unfill
(package
(name "emacs-unfill")
--
2.45.2
From edd0b102e842cc7f48a1dba5e9cab6a665a8690f Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:19:13 +0300
Subject: [PATCH] gnu: Add emacs-gnosis
* gnu/packages/emacs-xyz.scm (emacs-gnosis): New variable.
Change-Id: If72164b931a308198e25b80038e1d6557aa18c8b
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a13af2a5a1..af0bae0bd0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17982,6 +17982,33 @@ (define-public emacs-gn-mode
are common in Chromium-derived projects.")
(license license:bsd-3)))
+(define-public emacs-gnosis
+ (let ((commit "6df4a3d342bee27ef6891dc4930dd3ff17c52c31"))
+ (package
+ (name "emacs-gnosis")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/gnosis")
+ (commit commit)))
+ (sha256
+ (base32
+ "18d59gw9k1aj7ki2555vb4mdbrpsz9ib5lkcshf6k0p0qxkzqcxz"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-emacsql
+ emacs-compat))
+ (home-page "https://thanosapollo.org/projects/gnosis")
+ (synopsis "Spaced Repetition System for GNU Emacs")
+ (description "Spaced repetition system for note taking & self
+testing, where notes are taken in a Question/Answer/Explanation
+format & reviewed in spaced intervals, determined by the success or
+failure to recall a given answer for question.")
+ (license license:gpl3+))))
+
(define-public emacs-drag-stuff
(package
(name "emacs-drag-stuff")
--
2.45.2
From 4a9c333b932ea35599d056221ddd2f8f1792a854 Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:21:37 +0300
Subject: [PATCH] gnu: emacs-jabber: Update
* gnu/packages/emacs-xyz.scm (emacs-outshine): Update to a recent commit
Change-Id: I1af6e75fca7f2886eef1d62629d6add0a073991c
---
gnu/packages/emacs-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index af0bae0bd0..176262f584 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20298,7 +20298,7 @@ (define-public emacs-eglot-x
(define-public emacs-jabber
;; No releases available.
- (let ((commit "af0315e174fa6446d5c4dd3e6465d48912950e58")
+ (let ((commit "e766d84b81d5df6abc30fcbbb94f7c8640ea54e2")
(revision "0"))
(package
(name "emacs-jabber")
@@ -20311,7 +20311,7 @@ (define-public emacs-jabber
(file-name (git-file-name name version))
(sha256
(base32
- "08q0hbm4pvp8sf261w1ihqa93sg8blfybfkhq7wrnvgs6kasgwvq"))))
+ "0b6msdyvhjr4v4j8hl6kmcjks88iq001w1fhjgfvg8ii9n77n6xn"))))
(build-system emacs-build-system)
(arguments
(list
--
2.45.2