Add update emacs packages

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Nicolas Goaziou
  • Thanos Apollo
Owner
unassigned
Submitted by
Thanos Apollo
Severity
normal

Debbugs page

Thanos Apollo wrote 8 months ago
(address . guix-patches@gnu.org)
87sewrhkw4.fsf@thanosapollo.org
Hello,

Attaching patches below.
From aa45d9415cb30716299192b4c8e4e70d36857522 Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:12:47 +0300
Subject: [PATCH] gnu: Add emacs-eshell-git-prompt

* gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.

Change-Id: Ib4d98aed6345aa8b1275449e1e627afa22212604
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab6a4cf4ab..a13af2a5a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35181,6 +35181,28 @@ (define-public emacs-eshell-did-you-mean
commands that bear resemblance to the input command.")
(license license:gpl3+)))
+(define-public emacs-eshell-git-prompt
+ (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+ (package
+ (name "emacs-eshell-git-prompt")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-git-prompt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+ (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+ (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+ (license license:gpl3+))))
+
(define-public emacs-unfill
(package
(name "emacs-unfill")
--
2.45.2
From edd0b102e842cc7f48a1dba5e9cab6a665a8690f Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:19:13 +0300
Subject: [PATCH] gnu: Add emacs-gnosis

* gnu/packages/emacs-xyz.scm (emacs-gnosis): New variable.

Change-Id: If72164b931a308198e25b80038e1d6557aa18c8b
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a13af2a5a1..af0bae0bd0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17982,6 +17982,33 @@ (define-public emacs-gn-mode
are common in Chromium-derived projects.")
(license license:bsd-3)))
+(define-public emacs-gnosis
+ (let ((commit "6df4a3d342bee27ef6891dc4930dd3ff17c52c31"))
+ (package
+ (name "emacs-gnosis")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/gnosis")
+ (commit commit)))
+ (sha256
+ (base32
+ "18d59gw9k1aj7ki2555vb4mdbrpsz9ib5lkcshf6k0p0qxkzqcxz"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-emacsql
+ emacs-compat))
+ (home-page "https://thanosapollo.org/projects/gnosis")
+ (synopsis "Spaced Repetition System for GNU Emacs")
+ (description "Spaced repetition system for note taking & self
+testing, where notes are taken in a Question/Answer/Explanation
+format & reviewed in spaced intervals, determined by the success or
+failure to recall a given answer for question.")
+ (license license:gpl3+))))
+
(define-public emacs-drag-stuff
(package
(name "emacs-drag-stuff")
--
2.45.2
From 4a9c333b932ea35599d056221ddd2f8f1792a854 Mon Sep 17 00:00:00 2001
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 18:21:37 +0300
Subject: [PATCH] gnu: emacs-jabber: Update

* gnu/packages/emacs-xyz.scm (emacs-outshine): Update to a recent commit

Change-Id: I1af6e75fca7f2886eef1d62629d6add0a073991c
---
gnu/packages/emacs-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index af0bae0bd0..176262f584 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20298,7 +20298,7 @@ (define-public emacs-eglot-x
(define-public emacs-jabber
;; No releases available.
- (let ((commit "af0315e174fa6446d5c4dd3e6465d48912950e58")
+ (let ((commit "e766d84b81d5df6abc30fcbbb94f7c8640ea54e2")
(revision "0"))
(package
(name "emacs-jabber")
@@ -20311,7 +20311,7 @@ (define-public emacs-jabber
(file-name (git-file-name name version))
(sha256
(base32
- "08q0hbm4pvp8sf261w1ihqa93sg8blfybfkhq7wrnvgs6kasgwvq"))))
+ "0b6msdyvhjr4v4j8hl6kmcjks88iq001w1fhjgfvg8ii9n77n6xn"))))
(build-system emacs-build-system)
(arguments
(list
--
2.45.2
--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Thanos Apollo wrote 8 months ago
[FIX] Fix git commits & typos
(address . 71903@debbugs.gnu.org)
87cynvhh48.fsf@thanosapollo.org
I've fixed the previous patches, had a couple typos and incorrectly
formatted git commits. Any input is appreciated, new to guix packaging
& workflow.
From 7237eda343973e49920e29c9d4bb08a8f4250cb5 Mon Sep 17 00:00:00 2001
Message-ID: <7237eda343973e49920e29c9d4bb08a8f4250cb5.1719938340.git.public@thanosapollo.org>
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 19:27:22 +0300
Subject: [PATCH] gnu: Add emacs-eshell-git-prompt.

gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.

Change-Id: I13234fd0bfc394c5265bb6d6c7882a476f843a62
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab6a4cf4ab..a13af2a5a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35181,6 +35181,28 @@ (define-public emacs-eshell-did-you-mean
commands that bear resemblance to the input command.")
(license license:gpl3+)))
+(define-public emacs-eshell-git-prompt
+ (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+ (package
+ (name "emacs-eshell-git-prompt")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-git-prompt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+ (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+ (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+ (license license:gpl3+))))
+
(define-public emacs-unfill
(package
(name "emacs-unfill")

base-commit: 69089674bb9fb2cc7b3285b73fb7dda7d99a2550
--
2.45.2
From 0a5b74478ee3c67d81ec26b833a0f6b892192c0c Mon Sep 17 00:00:00 2001
Message-ID: <0a5b74478ee3c67d81ec26b833a0f6b892192c0c.1719938350.git.public@thanosapollo.org>
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 19:31:35 +0300
Subject: [PATCH] gnu: Add emacs-gnosis.

* gnu/packages/emacs-xyz.scm (emacs-gnosis): New variable.

Change-Id: I5757adf1b1b5f19f34fce60e487f4420e8785521
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a13af2a5a1..300de93d0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17982,6 +17982,33 @@ (define-public emacs-gn-mode
are common in Chromium-derived projects.")
(license license:bsd-3)))
+(define-public emacs-gnosis
+ (let ((commit "6df4a3d342bee27ef6891dc4930dd3ff17c52c31"))
+ (package
+ (name "emacs-gnosis")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/gnosis")
+ (commit commit)))
+ (sha256
+ (base32
+ "18d59gw9k1aj7ki2555vb4mdbrpsz9ib5lkcshf6k0p0qxkzqcxz"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-emacsql
+ emacs-compat))
+ (home-page "https://thanosapollo.org/projects/gnosis")
+ (synopsis "Spaced Repetition System for GNU Emacs")
+ (description "Gnosis is a spaced repetition system for note taking & self
+testing, where notes are taken in a Question/Answer/Explanation
+format & reviewed in spaced intervals, determined by the success or
+failure to recall a given answer for question.")
+ (license license:gpl3+))))
+
(define-public emacs-drag-stuff
(package
(name "emacs-drag-stuff")

base-commit: 69089674bb9fb2cc7b3285b73fb7dda7d99a2550
prerequisite-patch-id: d920223ad4dd8c4e1b3e2e95b047ace057eeddf8
--
2.45.2
From 9e5caf5bfda6b6e8990d31618f54028be0473059 Mon Sep 17 00:00:00 2001
Message-ID: <9e5caf5bfda6b6e8990d31618f54028be0473059.1719938357.git.public@thanosapollo.org>
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 19:33:31 +0300
Subject: [PATCH] gnu: emacs-jabber: Update to 0.8.92-1-0b6msd.

gnu/packages/emacs-xyz.scm (emacs-jabber): Update to a recent commit

Change-Id: I0a9b6bd32b6b6df6f46ad648cf3e165a4cbaa750
---
gnu/packages/emacs-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 300de93d0d..4c4bce5cb4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20298,8 +20298,8 @@ (define-public emacs-eglot-x
(define-public emacs-jabber
;; No releases available.
- (let ((commit "af0315e174fa6446d5c4dd3e6465d48912950e58")
- (revision "0"))
+ (let ((commit "0b6msdyvhjr4v4j8hl6kmcjks88iq001w1fhjgfvg8ii9n77n6xn")
+ (revision "1"))
(package
(name "emacs-jabber")
(version (git-version "0.8.92" revision commit))
@@ -20311,7 +20311,7 @@ (define-public emacs-jabber
(file-name (git-file-name name version))
(sha256
(base32
- "08q0hbm4pvp8sf261w1ihqa93sg8blfybfkhq7wrnvgs6kasgwvq"))))
+ "0b6msdyvhjr4v4j8hl6kmcjks88iq001w1fhjgfvg8ii9n77n6xn"))))
(build-system emacs-build-system)
(arguments
(list

base-commit: 69089674bb9fb2cc7b3285b73fb7dda7d99a2550
prerequisite-patch-id: d920223ad4dd8c4e1b3e2e95b047ace057eeddf8
prerequisite-patch-id: 07ac296867bd8fc715b37af46b67823932c5ea75
--
2.45.2
--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Thanos Apollo wrote 8 months ago
[Fix] emacs-gnosis: Use proper desc & alph order of inputs
(address . 71903@debbugs.gnu.org)
878qyjhgjl.fsf@thanosapollo.org
Fixing the patch for adding gnosis by having proper description & order
of inputs alphabetically.
From d16353d974eab6ad2a9d6511ba7d0183f8368ebc Mon Sep 17 00:00:00 2001
Message-ID: <d16353d974eab6ad2a9d6511ba7d0183f8368ebc.1719939707.git.public@thanosapollo.org>
From: Thanos Apollo <public@thanosapollo.org>
Date: Tue, 2 Jul 2024 19:31:35 +0300
Subject: [PATCH] gnu: Add emacs-gnosis.

* gnu/packages/emacs-xyz.scm (emacs-gnosis): New variable.

Change-Id: I5757adf1b1b5f19f34fce60e487f4420e8785521
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a13af2a5a1..2156bfbee6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17982,6 +17982,30 @@ (define-public emacs-gn-mode
are common in Chromium-derived projects.")
(license license:bsd-3)))
+(define-public emacs-gnosis
+ (let ((commit "6df4a3d342bee27ef6891dc4930dd3ff17c52c31"))
+ (package
+ (name "emacs-gnosis")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/gnosis")
+ (commit commit)))
+ (sha256
+ (base32
+ "18d59gw9k1aj7ki2555vb4mdbrpsz9ib5lkcshf6k0p0qxkzqcxz"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-compat
+ emacs-emacsql))
+ (home-page "https://thanosapollo.org/projects/gnosis")
+ (synopsis "Spaced Repetition System for GNU Emacs")
+ (description "Gnosis is a spaced repetition system for note-taking and self-testing where notes are formatted as Question/Answer/Explanation. Notes are reviewed at spaced intervals based on the success or failure in recalling the answer to each question.")
+ (license license:gpl3+))))
+
(define-public emacs-drag-stuff
(package
(name "emacs-drag-stuff")

base-commit: 69089674bb9fb2cc7b3285b73fb7dda7d99a2550
prerequisite-patch-id: d920223ad4dd8c4e1b3e2e95b047ace057eeddf8
--
2.45.2
--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Liliana Marie Prikler wrote 8 months ago
Re: [FIX] Fix git commits & typos
61b5c9a72356ab962a0b4707fc103d9f24175277.camel@gmail.com
Hello,

Am Dienstag, dem 02.07.2024 um 19:51 +0300 schrieb Thanos Apollo:
Toggle quote (3 lines)
> I've fixed the previous patches, had a couple typos and incorrectly
> formatted git commits.  Any input is appreciated, new to guix
> packaging & workflow.
It would be nice if you could format your patches using git format-
patch or send them directly via git send-email. We also have a wrapper
called mumi, which takes care of these things for you.

Use the --reroll-count to version your patches, so that folks can
easily fetch the latest one.

Cheers
Thanos Apollo wrote 8 months ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87zfqx3zd7.fsf@thanosapollo.org
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (7 lines)
> Hello,
>
> Am Dienstag, dem 02.07.2024 um 19:51 +0300 schrieb Thanos Apollo:
>> I've fixed the previous patches, had a couple typos and incorrectly
>> formatted git commits.  Any input is appreciated, new to guix
>> packaging & workflow.

Thanks, gnosis does not work properly with the current packaged version
of emacsql. This thread/issue should be closed & the patches discarded.

emacs-eshell-git-prompt patch can be found here


--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Nicolas Goaziou wrote 8 months ago
Re: [bug#71903] [Fix] emacs-gnosis: Use proper desc & alph order of inputs
(name . Thanos Apollo)(address . public@thanosapollo.org)(address . 71903-done@debbugs.gnu.org)
87tth0thge.fsf@nicolasgoaziou.fr
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

Toggle quote (3 lines)
> Fixing the patch for adding gnosis by having proper description & order
> of inputs alphabetically.

I applied the two missing patches (Liliana already had applied the
first one).

I used the tag for Gnosis, instead of a raw commit. For emacs-jabber,
there was a mistake in the commit hash, so I used the last one to date
from upstream.

Thank you!

Regards,
--
Nicolas Goaziou
Closed
Thanos Apollo wrote 8 months ago
(address . 71903-done@debbugs.gnu.org)
8734ojrgwm.fsf@thanosapollo.org
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:


[...]

Toggle quote (2 lines)
> I used the tag for Gnosis, instead of a raw commit.

Thanks. Although gnosis builds successfully, it relies on
'emacsql-sqlite-open[1] which is not available in the current version of
emacsql packaged for Guix.

To ensure it works properly, we need to update emacs-emacsql. This
update would also benefit many newer versions of other emacs packages.

/Newer versions of emacsql take advantage of the built-in support for sqlite./



--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Closed
Nicolas Goaziou wrote 8 months ago
(name . Thanos Apollo)(address . public@thanosapollo.org)(address . 71903-done@debbugs.gnu.org)
87o777u9fd.fsf@nicolasgoaziou.fr
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

Toggle quote (7 lines)
> Thanks. Although gnosis builds successfully, it relies on
> 'emacsql-sqlite-open[1] which is not available in the current version of
> emacsql packaged for Guix.
>
> To ensure it works properly, we need to update emacs-emacsql. This
> update would also benefit many newer versions of other emacs packages.

OK. Would you want to prepare a patch for that?

Regards,
--
Nicolas Goaziou
Closed
Thanos Apollo wrote 8 months ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 71903-done@debbugs.gnu.org)
87y16bpy5w.fsf@thanosapollo.org
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:


[...]
Toggle quote (6 lines)
>> To ensure it works properly, we need to update emacs-emacsql. This
>> update would also benefit many newer versions of other emacs packages.
>
> OK. Would you want to prepare a patch for that?
>


(also made a duplicate of this on yeetube issue, forgot to use 'mumi new')


Cheers,

--

Thanos Apollo

62B7 58D0 F671 9938 BC09 CECA 339F 736C 3A72 0928
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71903@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71903
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help