[PATCH] gnu: Add emacs-eshell-git-prompt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Thanos Apollo
Owner
unassigned
Submitted by
Thanos Apollo
Severity
normal
T
T
Thanos Apollo wrote on 3 Jul 07:02 +0200
(address . guix-patches@gnu.org)(name . Thanos Apollo)(address . public@thanosapollo.org)
3a11fc4804f3b1fe372031b7580ec8beaa405f17.1719982934.git.public@thanosapollo.org
gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.

Change-Id: If3e7f918708d9b57295b368f5d7c5fc7b18d73cf
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..c82e264930 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35182,6 +35182,28 @@ (define-public emacs-eshell-did-you-mean
commands that bear resemblance to the input command.")
(license license:gpl3+)))
+(define-public emacs-eshell-git-prompt
+ (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+ (package
+ (name "emacs-eshell-git-prompt")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-git-prompt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+ (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+ (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+ (license license:gpl3+))))
+
(define-public emacs-unfill
(package
(name "emacs-unfill")

base-commit: 972c06dc79641864b05590b2cd905cc8b810062b
--
2.45.2
L
L
Liliana Marie Prikler wrote on 7 Jul 08:17 +0200
b1519157f567d8145245560b5ca67a13d57982e1.camel@gmail.com
Am Mittwoch, dem 03.07.2024 um 08:02 +0300 schrieb Thanos Apollo:
Toggle quote (4 lines)
> gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.
>
> Change-Id: If3e7f918708d9b57295b368f5d7c5fc7b18d73cf
> ---
Pushed as fee360f85384fb06f7d0c46891126b1f85c9c740.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71910@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71910
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch