[PATCH] gnu: Add emacs-dape.

  • Done
  • quality assurance status badge
Details
3 participants
  • Jelle Licht
  • Nicolas Goaziou
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Blocked by
N
N
Nicolas Graves wrote on 28 May 11:57 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240528095800.20728-1-ngraves@ngraves.fr
* gnu/packages/emacs-xyz.scm (emacs-dape): New variable.

Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
---
gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c890a5b008..9f93d582f3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31088,6 +31088,58 @@ (define-public emacs-lsp-docker
in Docker environment.")
(license license:gpl3+))))
+(define-public emacs-dape
+ (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
+ (revision "0"))
+ (package
+ (name "emacs-dape")
+ (version (git-version "0.12.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/svaante/dape")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
+ (build-system emacs-build-system)
+ (arguments
+ ;; FIXME python tests pass, JS tests require additional dependencies
+ ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
+ (list #:tests? #f
+ #:test-command #~'("emacs" "--batch" "-l" "dape.el"
+ "-l" "dape-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'support-unwrapped-python
+ (lambda _
+ (substitute* "dape.el"
+ (("command \"python\"")
+ "command \"python3\""))))
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (setenv
+ "PATH"
+ (string-append
+ (getenv "PATH")
+ ":" (dirname (search-input-file inputs "/bin/python3"))
+ ":" (dirname (search-input-file inputs "/bin/node"))))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list node-lts python-minimal python-debugpy))
+ (propagated-inputs (list emacs-jsonrpc))
+ (home-page "https://github.com/svaante/dape")
+ (synopsis "Debug Adapter Protocol for Emacs")
+ (description
+ "Dape is a debug adapter client for Emacs. The debug adapter protocol,
+much like its more well-known counterpart, the language server protocol,
+aims to establish a common API for programming tools. However, instead of
+functionalities such as code completions, it provides a standardized
+interface for debuggers.")
+ (license license:gpl3+))))
+
(define-public emacs-dap-mode
(package
(name "emacs-dap-mode")
--
2.41.0
J
J
Jelle Licht wrote on 9 Jun 22:52 +0200
(address . ngraves@ngraves.fr)
87r0d5et4f.fsf@fsfe.org
Hi Nicolas,

I've got some nitpicks, and one question as the package does not seem to
run for me, which could very well be an issue on my end.

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (21 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dape): New variable.
>
> Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
> ---
> gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 52 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1c890a5b008..9f93d582f3f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -31088,6 +31088,58 @@ (define-public emacs-lsp-docker
> in Docker environment.")
> (license license:gpl3+))))
>
> +(define-public emacs-dape
> + (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
> + (revision "0"))
> + (package
> + (name "emacs-dape")
> + (version (git-version "0.12.0" revision commit))
Is there a particular reason not to stick to the 'proper' releases?
If so, could you add a comment explaining why?

Toggle quote (14 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/svaante/dape")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
> + (build-system emacs-build-system)
> + (arguments
> + ;; FIXME python tests pass, JS tests require additional dependencies
> + ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
> + (list #:tests? #f
Can't we patch out or disable the JS tests, instead of not running any tests?

Toggle quote (11 lines)
> + #:test-command #~'("emacs" "--batch" "-l" "dape.el"
> + "-l" "dape-tests.el"
> + "-f" "ert-run-tests-batch-and-exit")
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'support-unwrapped-python
> + (lambda _
> + (substitute* "dape.el"
> + (("command \"python\"")
> + "command \"python3\""))))

I don't think we do this kind of patching for other packages, but I
could be mistaken of course. If this was needed to get the python tests
to succeed, maybe it could also work with python-minimal-wrapper instead
of patching.

Toggle quote (10 lines)
> + (add-before 'check 'pre-check
> + (lambda* (#:key tests? inputs #:allow-other-keys)
> + (if tests?
> + (setenv
> + "PATH"
> + (string-append
> + (getenv "PATH")
> + ":" (dirname (search-input-file inputs "/bin/python3"))
> + ":" (dirname (search-input-file inputs "/bin/node"))))

Ditto wrt my earlier remark about the JS tests.

Toggle quote (4 lines)
> + (format #t "test suite not run~%")))))))
> + (native-inputs (list node-lts python-minimal python-debugpy))
> + (propagated-inputs (list emacs-jsonrpc))

Did running this package once installed actually work on your local
setup? If so, I'd love to know how you are running this package, as I'm
running into the issue as the one I reported at

Toggle quote (17 lines)
> + (synopsis "Debug Adapter Protocol for Emacs")
> + (description
> + "Dape is a debug adapter client for Emacs. The debug adapter protocol,
> +much like its more well-known counterpart, the language server protocol,
> +aims to establish a common API for programming tools. However, instead of
> +functionalities such as code completions, it provides a standardized
> +interface for debuggers.")
> + (license license:gpl3+))))
> +
> (define-public emacs-dap-mode
> (package
> (name "emacs-dap-mode")
> --
> 2.41.0


Thanks for the package,
- Jelle
N
N
Nicolas Graves wrote on 10 Jun 09:50 +0200
87o789tewr.fsf@ngraves.fr
On 2024-06-09 22:52, Jelle Licht wrote:

Toggle quote (10 lines)
> Hi Nicolas,
>
> I've got some nitpicks, and one question as the package does not seem to
> run for me, which could very well be an issue on my end.
>
>> + (name "emacs-dape")
>> + (version (git-version "0.12.0" revision commit))
> Is there a particular reason not to stick to the 'proper' releases?
> If so, could you add a comment explaining why?

There are no upstream tags, this is simply the commit of the tag,
IIRC. So it's the proper release. Maybe I should simply put the version
here and use git-version in the origin field instead ?

Toggle quote (7 lines)
>> + (arguments
>> + ;; FIXME python tests pass, JS tests require additional dependencies
>> + ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
>> + (list #:tests? #f
> Can't we patch out or disable the JS tests, instead of not running any
> tests?

Doable, although using I'm not sure there's a light approach for this
rather than patching half the file, which I think is not worth it. Will
investigate.

Toggle quote (16 lines)
>> + #:test-command #~'("emacs" "--batch" "-l" "dape.el"
>> + "-l" "dape-tests.el"
>> + "-f" "ert-run-tests-batch-and-exit")
>> + #:phases
>> + #~(modify-phases %standard-phases
>> + (add-after 'unpack 'support-unwrapped-python
>> + (lambda _
>> + (substitute* "dape.el"
>> + (("command \"python\"")
>> + "command \"python3\""))))
>
> I don't think we do this kind of patching for other packages, but I
> could be mistaken of course. If this was needed to get the python tests
> to succeed, maybe it could also work with python-minimal-wrapper instead
> of patching.

Since python is not propagated, this would mean that we expect the user
to have python-wrapper instead of python, I'm not sure we want to
enforce that because it might cause users to have to debug this. We
can of course propagate python-wrapper instead, but then we increase the
closure size.

Toggle quote (9 lines)
>> + (format #t "test suite not run~%")))))))
>> + (native-inputs (list node-lts python-minimal python-debugpy))
>> + (propagated-inputs (list emacs-jsonrpc))
>
> Did running this package once installed actually work on your local
> setup? If so, I'd love to know how you are running this package, as I'm
> running into the issue as the one I reported at
> https://issues.guix.gnu.org/71065

No, actually I couldn't, but I didn't settled for a stable
configuration, I wanted to send that to RDE, but haven't done it
yet.

Toggle quote (3 lines)
> Thanks for the package,
> - Jelle

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 10 Jun 09:56 +0200
87le3dtemm.fsf@ngraves.fr
On 2024-06-09 22:52, Jelle Licht wrote:

Toggle quote (5 lines)
> Hi Nicolas,
>
> I've got some nitpicks, and one question as the package does not seem to
> run for me, which could very well be an issue on my end.

Ow I probably have forgotten to block the patch, but it depends on
emacs-jsonrpc@0.25, which is not the current version in Guix.

I've sent a patch in 70998. Although I understand now that updating
native emacs packages is not that simple - I've seen a mail thread about
this.
Toggle quote (100 lines)
>
> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-dape): New variable.
>>
>> Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
>> ---
>> gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 52 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 1c890a5b008..9f93d582f3f 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -31088,6 +31088,58 @@ (define-public emacs-lsp-docker
>> in Docker environment.")
>> (license license:gpl3+))))
>>
>> +(define-public emacs-dape
>> + (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
>> + (revision "0"))
>> + (package
>> + (name "emacs-dape")
>> + (version (git-version "0.12.0" revision commit))
> Is there a particular reason not to stick to the 'proper' releases?
> If so, could you add a comment explaining why?
>
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/svaante/dape")
>> + (commit commit)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
>> + (build-system emacs-build-system)
>> + (arguments
>> + ;; FIXME python tests pass, JS tests require additional dependencies
>> + ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
>> + (list #:tests? #f
> Can't we patch out or disable the JS tests, instead of not running any tests?
>
>> + #:test-command #~'("emacs" "--batch" "-l" "dape.el"
>> + "-l" "dape-tests.el"
>> + "-f" "ert-run-tests-batch-and-exit")
>> + #:phases
>> + #~(modify-phases %standard-phases
>> + (add-after 'unpack 'support-unwrapped-python
>> + (lambda _
>> + (substitute* "dape.el"
>> + (("command \"python\"")
>> + "command \"python3\""))))
>
> I don't think we do this kind of patching for other packages, but I
> could be mistaken of course. If this was needed to get the python tests
> to succeed, maybe it could also work with python-minimal-wrapper instead
> of patching.
>
>> + (add-before 'check 'pre-check
>> + (lambda* (#:key tests? inputs #:allow-other-keys)
>> + (if tests?
>> + (setenv
>> + "PATH"
>> + (string-append
>> + (getenv "PATH")
>> + ":" (dirname (search-input-file inputs "/bin/python3"))
>> + ":" (dirname (search-input-file inputs "/bin/node"))))
>
> Ditto wrt my earlier remark about the JS tests.
>
>> + (format #t "test suite not run~%")))))))
>> + (native-inputs (list node-lts python-minimal python-debugpy))
>> + (propagated-inputs (list emacs-jsonrpc))
>
> Did running this package once installed actually work on your local
> setup? If so, I'd love to know how you are running this package, as I'm
> running into the issue as the one I reported at
> https://issues.guix.gnu.org/71065
>
>> + (home-page "https://github.com/svaante/dape")
>> + (synopsis "Debug Adapter Protocol for Emacs")
>> + (description
>> + "Dape is a debug adapter client for Emacs. The debug adapter protocol,
>> +much like its more well-known counterpart, the language server protocol,
>> +aims to establish a common API for programming tools. However, instead of
>> +functionalities such as code completions, it provides a standardized
>> +interface for debuggers.")
>> + (license license:gpl3+))))
>> +
>> (define-public emacs-dap-mode
>> (package
>> (name "emacs-dap-mode")
>> --
>> 2.41.0
>
>
> Thanks for the package,
> - Jelle

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 10 Jun 09:57 +0200
control message for bug #71239
(address . control@debbugs.gnu.org)
87ikyhtel8.fsf@ngraves.fr
block 71239 by 70998
quit


--
Best regards,
Nicolas Graves
N
N
Nicolas Goaziou wrote on 19 Jun 09:58 +0200
Re: [bug#71239] [PATCH] gnu: Add emacs-dape.
(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
87le315pod.fsf@nicolasgoaziou.fr
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dape): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71239@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71239
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch