(address . bug-guix@gnu.org)
The guix-daemon's libutil/util.cc uses copy_file_range to copy a
downloaded file into the store. copy_file_range fails on files larger
than 4GB with an error like this:
guix build: error: short write in copy_file_range `15' to `16': No such file or directory
The man page for copy_file_range says that it could return EFBIG when
the range exceeds the maximum range. The daemon code does not check any
limits and will attempt to copy the whole file.
I believe our code ought to check the value of st.size and fall back to
a boring copy if it exceeds some "reasonable" value.
This is where copy_file_range is used:
Here is a little reproducer:
(use-modules (guix download)
(guix packages)
(guix build-system trivial))
(package
(name "chungus")
(version "1")
(source
(origin
(method url-fetch)
(uri "http://localhost:1111/chungus")
(sha256
(base32 "0nx67d4ls2nfwcfdmg81vf240z6lpwpdqypssr1wzn3hyz4szci4"))))
(build-system trivial-build-system)
(home-page "")
(synopsis "")
(description "")
(license #f))
Toggle snippet (10 lines)
# generate a big file
dd bs=1M count=4096 if=/dev/zero of=/tmp/chungus
# serve it
guix shell woof -- woof -i 127.0.0.1 -p 1111 -c 1 /tmp/chungus
# build the source derivation
guix build --no-grafts -Sf bug.scm
# observe the error
# guix build: error: short write in copy_file_range `15' to `16': No such file or directory
--
Ricardo