[PATCH 0/4] Update and restyle Khronos OpenCL packages

  • Open
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal
A
A
Ahmad Draidi wrote on 7 Apr 10:05 +0200
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1712473796.git.a.r.draidi@redscript.org
Hello Guix,

All 3 packages have to be updated at the same time, which is why the
first patch is a bit unusual.

Thanks!

Ahmad Draidi (4):
gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to
2023.12.14.
gnu: opencl-clhpp: Update package style.
gnu: opencl-headers: Update package style.
gnu: opencl-icd-loader: Update package style.

gnu/packages/opencl.scm | 33 ++++++++++++++++++---------------
1 file changed, 18 insertions(+), 15 deletions(-)


base-commit: eaccfececd0eec362b247efd47861e2118dd9dd8
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 10:09 +0200
[PATCH 1/4] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.12.14.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
2db9669b9140789d3d01894dd87e73e3c6bb550f.1712473796.git.a.r.draidi@redscript.org
These packages should be updated together.

* gnu/packages/opencl.scm (opencl-headers): Update to 2023.12.14.
[home-page]: Update URL.
(opencl-clhpp): Update to 2023.12.14.
(opencl-icd-loader): Update to 2023.12.14.
[source]: Update origin URI to fix lint.

Change-Id: I56ee52a6df3fbbe7aa44743f09b28b07e5442b9f
---
gnu/packages/opencl.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 036834f567..f265d983f0 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -55,7 +55,7 @@ (define-module (gnu packages opencl)
(define-public opencl-headers
(package
(name "opencl-headers")
- (version "2023.02.06")
+ (version "2023.12.14")
(source
(origin
(method git-fetch)
@@ -64,13 +64,13 @@ (define-public opencl-headers
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+ (base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
- (home-page "https://www.khronos.org/registry/OpenCL/")
+ (home-page "https://registry.khronos.org/OpenCL/")
(license license:asl2.0)))
(define (make-opencl-headers major-version subversion)
@@ -96,7 +96,7 @@ (define-public opencl-headers-1.0
(define-public opencl-clhpp
(package
(name "opencl-clhpp")
- (version "2023.02.06")
+ (version "2023.12.14")
(source
(origin
(method git-fetch)
@@ -104,7 +104,7 @@ (define-public opencl-clhpp
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+ (base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
(file-name (git-file-name name version))))
(native-inputs
`(("python" ,python-wrapper)))
@@ -125,16 +125,16 @@ (define-public opencl-clhpp
(define-public opencl-icd-loader
(package
(name "opencl-icd-loader")
- (version "2023.02.06")
+ (version "2023.12.14")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+ (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+ "03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 10:09 +0200
[PATCH 2/4] gnu: opencl-clhpp: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
0d1d94fc85b738bb978fb4b38755911e54db3acf.1712473796.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm: Add #:use-module (guix gexp).
(opencl-clhpp): [native-inputs]: Remove labels.
[arguments]: Use G-expressions.

Change-Id: I5de85d6c1ed9d62bc481626ec3df2d0f0f939f32
---
gnu/packages/opencl.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index f265d983f0..c70dc4655f 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -24,6 +24,7 @@ (define-module (gnu packages opencl)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -107,14 +108,16 @@ (define-public opencl-clhpp
(base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
(file-name (git-file-name name version))))
(native-inputs
- `(("python" ,python-wrapper)))
+ (list python-wrapper))
(propagated-inputs
(list opencl-headers))
(arguments
- `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
- "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
- ;; The regression tests require a lot more dependencies.
- #:tests? #f))
+ (list #:configure-flags #~(list "-DBUILD_EXAMPLES=OFF"
+ "-DBUILD_TESTS=OFF"
+ ;; CTest needs this to be turned off
+ "-DBUILD_TESTING=OFF")
+ ;; The regression tests require a lot more dependencies.
+ #:tests? #f))
(build-system cmake-build-system)
(home-page "https://github.khronos.org/OpenCL-CLHPP/")
(synopsis "Khronos OpenCL-CLHPP")
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 10:09 +0200
[PATCH 3/4] gnu: opencl-headers: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
6a4a7988807d1d9c0441b34827634813700365f6.1712473796.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm (opencl-headers): [arguments]: Use G-expressions.

Change-Id: Ib8b5aa7cebf7757466e237a4eed868f0fb7ece9c
---
gnu/packages/opencl.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index c70dc4655f..f6f9b76c85 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -67,7 +67,7 @@ (define-public opencl-headers
(sha256
(base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; Not enabled during build.
+ (arguments (list #:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 10:09 +0200
[PATCH 4/4] gnu: opencl-icd-loader: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
868dc7837f672024f9ed8328cbef2a48bdcac6c8.1712473796.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm (opencl-icd-loader): [arguments]: Use G-expressions.

Change-Id: Ibb78b54186b268b8cd5a8c97177a31e36b4ca69d
---
gnu/packages/opencl.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index f6f9b76c85..1e985f7039 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -139,7 +139,7 @@ (define-public opencl-icd-loader
(base32
"03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; Tests need stub loader setup.
+ (arguments (list #:tests? #f)) ; Tests need stub loader setup.
(native-search-paths
(list (search-path-specification
(variable "OCL_ICD_VENDORS")
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:19 +0200
[PATCH v2 0/5] Update and restyle Khronos OpenCL packages
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1712521108.git.a.r.draidi@redscript.org
Hello Guix,

Version 2 of this patch series uses a common version variable.

While working on Vulkan packages, I noticed the common version variable
%vulkan-sdk-version so I thought I'd use the same pattern here. Upstream
seems to be unified or unifying also[1].

I avoided using the full version string with the "v" included (e.g. v2023.12.14)
to minimize changes, though it might be more future proof to use the whole string.


Ahmad Draidi (5):
gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Replace
version with %opencl-sdk-version.
gnu: %opencl-sdk-version: Update to 2023.12.14.
gnu: opencl-clhpp: Update package style.
gnu: opencl-headers: Update package style.
gnu: opencl-icd-loader: Update package style.

gnu/packages/opencl.scm | 42 +++++++++++++++++++++++------------------
1 file changed, 24 insertions(+), 18 deletions(-)


base-commit: 298aed72a2a76be33f9a55bed22636acd7a4f9b9
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:33 +0200
[PATCH v2 1/5] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Replace version with %opencl-sdk-version.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
115cf4bdbf2e5fc78b167f8dcf0f90d60d0e0185.1712521108.git.a.r.draidi@redscript.org
These packages must be updated together. Therefore, we use a common version
variable.

* gnu/packages/opencl.scm (%opencl-sdk-version): New variable.
(opencl-headers)[version]: Replace with %opencl-sdk-version.
(opencl-clhpp)[version]: Likewise.
(opencl-icd-loader)[version]: Likewise.

Change-Id: I2cf25e2e7b951f0c0ff54a48c4e4a4fb470bff6a
---
gnu/packages/opencl.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 036834f567..d6fb344458 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -49,13 +49,16 @@ (define-module (gnu packages opencl)
;; tests that require such devices are all disabled.
;; Check https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00293.html
-;; If you update either of opencl-headers, opencl-clhpp or opencl-icd-loader
-;; note that they are released together (lockstep) and must be updated
-;; together.
+;; The packages opencl-headers, opencl-clhpp and opencl-icd-loader are released
+;; together (lockstep) and must be updated together. The following variable
+;; facilitates that.
+
+(define %opencl-sdk-version "2023.02.06")
+
(define-public opencl-headers
(package
(name "opencl-headers")
- (version "2023.02.06")
+ (version %opencl-sdk-version)
(source
(origin
(method git-fetch)
@@ -96,7 +99,7 @@ (define-public opencl-headers-1.0
(define-public opencl-clhpp
(package
(name "opencl-clhpp")
- (version "2023.02.06")
+ (version %opencl-sdk-version)
(source
(origin
(method git-fetch)
@@ -125,7 +128,7 @@ (define-public opencl-clhpp
(define-public opencl-icd-loader
(package
(name "opencl-icd-loader")
- (version "2023.02.06")
+ (version %opencl-sdk-version)
(source (origin
(method git-fetch)
(uri (git-reference
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:33 +0200
[PATCH v2 2/5] gnu: %opencl-sdk-version: Update to 2023.12.14.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cf8ce5b04c2faf9097683fc4acbf4fd0641909d9.1712521108.git.a.r.draidi@redscript.org
This updates opencl-headers, opencl-clhpp and opencl-icd-loader.

* gnu/packages/opencl.scm (opencl-headers)[source]: Update hash.
[home-page]: Update URL.
(opencl-clhpp)[source]: Update hash.
(opencl-icd-loader)[source]: Update hash. Update origin URI to fix lint.

Change-Id: I674fc8aa79d1d98bac7ff66ba3a0e0fcb9b243cb
---
gnu/packages/opencl.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index d6fb344458..b3d917d28b 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -53,7 +53,7 @@ (define-module (gnu packages opencl)
;; together (lockstep) and must be updated together. The following variable
;; facilitates that.
-(define %opencl-sdk-version "2023.02.06")
+(define %opencl-sdk-version "2023.12.14")
(define-public opencl-headers
(package
@@ -67,13 +67,13 @@ (define-public opencl-headers
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+ (base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
- (home-page "https://www.khronos.org/registry/OpenCL/")
+ (home-page "https://registry.khronos.org/OpenCL/")
(license license:asl2.0)))
(define (make-opencl-headers major-version subversion)
@@ -107,7 +107,7 @@ (define-public opencl-clhpp
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+ (base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
(file-name (git-file-name name version))))
(native-inputs
`(("python" ,python-wrapper)))
@@ -132,12 +132,12 @@ (define-public opencl-icd-loader
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+ (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+ "03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:33 +0200
[PATCH v2 3/5] gnu: opencl-clhpp: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
96284e35b3e28d33c436efa31b3a6f8983c9f693.1712521108.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm: Add #:use-module (guix gexp).
(opencl-clhpp): [native-inputs]: Remove labels.
[arguments]: Use G-expressions.

Change-Id: I9c61aad824b5a57f941853635f30d2ec2dad38d8
---
gnu/packages/opencl.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index b3d917d28b..e62cea52eb 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -24,6 +24,7 @@ (define-module (gnu packages opencl)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -110,14 +111,16 @@ (define-public opencl-clhpp
(base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
(file-name (git-file-name name version))))
(native-inputs
- `(("python" ,python-wrapper)))
+ (list python-wrapper))
(propagated-inputs
(list opencl-headers))
(arguments
- `(#:configure-flags (list "-DBUILD_EXAMPLES=OFF" "-DBUILD_TESTS=OFF"
- "-DBUILD_TESTING=OFF") ;; CTest needs this to be turned off
- ;; The regression tests require a lot more dependencies.
- #:tests? #f))
+ (list #:configure-flags #~(list "-DBUILD_EXAMPLES=OFF"
+ "-DBUILD_TESTS=OFF"
+ ;; CTest needs this to be turned off
+ "-DBUILD_TESTING=OFF")
+ ;; The regression tests require a lot more dependencies.
+ #:tests? #f))
(build-system cmake-build-system)
(home-page "https://github.khronos.org/OpenCL-CLHPP/")
(synopsis "Khronos OpenCL-CLHPP")
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:33 +0200
[PATCH v2 4/5] gnu: opencl-headers: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
b872146145ac655dd57c6578515d8b2af6812ddd.1712521108.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm (opencl-headers)[arguments]: Use G-expressions.

Change-Id: I3704206aa0d92dafc99953753914f5090192785d
---
gnu/packages/opencl.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index e62cea52eb..9495cb59a4 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -70,7 +70,7 @@ (define-public opencl-headers
(sha256
(base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; Not enabled during build.
+ (arguments (list #:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
--
2.41.0
A
A
Ahmad Draidi wrote on 7 Apr 22:33 +0200
[PATCH v2 5/5] gnu: opencl-icd-loader: Update package style.
(address . 70252@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
d6c0ef9bce10d4677d6ff60d6e059485848ecd0a.1712521108.git.a.r.draidi@redscript.org
* gnu/packages/opencl.scm (opencl-icd-loader)[arguments]: Use G-expressions.

Change-Id: I0d2e2a6e1b267d01c75ea560c8ef7fde12fdec4a
---
gnu/packages/opencl.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 9495cb59a4..2d7f9fc15b 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -142,7 +142,7 @@ (define-public opencl-icd-loader
(base32
"03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; Tests need stub loader setup.
+ (arguments (list #:tests? #f)) ; Tests need stub loader setup.
(native-search-paths
(list (search-path-specification
(variable "OCL_ICD_VENDORS")
--
2.41.0
L
L
Ludovic Courtès wrote on 4 May 18:40 +0200
Re: [bug#70252] [PATCH v2 0/5] Update and restyle Khronos OpenCL packages
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
8734qxttrb.fsf@gnu.org
Hello Ahmad,

Ahmad Draidi <a.r.draidi@redscript.org> skribis:

Toggle quote (7 lines)
> gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Replace
> version with %opencl-sdk-version.
> gnu: %opencl-sdk-version: Update to 2023.12.14.
> gnu: opencl-clhpp: Update package style.
> gnu: opencl-headers: Update package style.
> gnu: opencl-icd-loader: Update package style.

I think this is very much under the scope of the “MESA team”, so I’m
Cc’ing John who’s more familiar with this area than I am.


(BTW, there’s actually no “MESA team” in etc/teams.scm. Should we add
one, John?)

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70252@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70252
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch