[PATCH] doc: Add message for common error about make check-system

  • Done
  • quality assurance status badge
Details
2 participants
  • pelzflorian (Florian Pelz)
  • Richard Sent
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
Merged with
R
R
Richard Sent wrote on 4 Apr 23:17 +0200
(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
48fbd1ae2d78597caa12a7a3e96085d8ab1082b7.1712265423.git.richard@freakingpenguin.com
* doc/guix.texi: Mention that make clean may need to be run before running
make check-system when previous builds were run with different work trees. See

Change-Id: I39d465961637d9fc6b11f59e1500770220780b4c
---
Hi Guix!

Ran into this issue myself. It seems common enough to be worth
mentioning in the docs, similar to the message in (guix) Building from
Git.

I found my solution from https://issues.guix.gnu.org/47573.

Toggle quote (5 lines)
> If you get an error like this one:
>
> configure.ac:46: error: possibly undefined macro: PKG_CHECK_MODULES


doc/guix.texi | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (32 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ef9e4216b4..72cac183a5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1177,6 +1177,23 @@ Running the Test Suite
substitutes are available for their dependencies (@pxref{Substitutes}).
Some of them require a lot of storage space to hold VM images.
+If you encounter an error like this one:
+
+@example
+Compiling Scheme modules...
+ice-9/eval.scm:142:16: In procedure compile-top-call:
+error: all-system-tests: unbound variable
+hint: Did you forget `(use-modules (gnu tests))'?
+@end example
+
+@noindent
+there may be inconsistency in the work tree from previous builds. Try
+running:
+
+@example
+make clean && make
+@end example
+
Again in case of test failures, please send @email{bug-guix@@gnu.org}
all the details.

base-commit: ade6845da6cec99f3bca46faac9b2bad6877817e
--
2.41.0
R
R
Richard Sent wrote on 15 Jun 23:44 +0200
control message for bug #71580
(address . control@debbugs.gnu.org)
87wmmpanji.fsf@freakingpenguin.com
merge 71580 70202
quit
P
P
pelzflorian (Florian Pelz) wrote on 17 Jun 13:50 +0200
Re: [bug#70202] [PATCH] doc: Add message for common error about make check-system
(name . Richard Sent)(address . richard@freakingpenguin.com)(address . 70202@debbugs.gnu.org)
87tthrpz3n.fsf@pelzflorian.de
Hello Richard, I am hesitant because I cannot reproduce the error and it
might be better to fix it rather than document it. Looking at,

Richard Sent <richard@freakingpenguin.com> writes:
Toggle quote (4 lines)
> * doc/guix.texi: Mention that make clean may need to be run before running
> make check-system when previous builds were run with different work trees. See
> https://issues.guix.gnu.org/47573.

I assume by work tree you do not mean a work tree produced by `git
worktree`, but the state of the source directory. So:

Léo Le Bouter <lle-bout@zaclys.net> writes
Toggle quote (8 lines)
> $ make check-system
> Compiling Scheme modules...
> ice-9/eval.scm:142:16: In procedure compile-top-call:
> error: channel-source->package: unbound variable
> hint: Did you forget `(use-modules (gnu ci))'?
>
> make: *** [Makefile:6305: check-system] Error 1

and:

Richard Sent <richard@freakingpenguin.com> writes:
Toggle quote (5 lines)
> +Compiling Scheme modules...
> +ice-9/eval.scm:142:16: In procedure compile-top-call:
> +error: all-system-tests: unbound variable
> +hint: Did you forget `(use-modules (gnu tests))'?

I do not understand Guix well enough why this could happen. Since `make
clean-go` helps, the cause must be in Guix’ .go files and not some
cache. In Makefile.am, the check-system target depends on $(GOBJECTS).

I presume gnu/tests.go and gnu/ci.go should be added to GOBJECTS?
Or gnu/tests.scm and gnu/ci.scm should be added to MODULES?

But I do not really understand.

Regards,
Florian
R
R
Richard Sent wrote on 17 Jun 14:13 +0200
(name . pelzflorian (Florian Pelz))(address . pelzflorian@pelzflorian.de)(address . 70202@debbugs.gnu.org)
87ed8v22eo.fsf@freakingpenguin.com
Hi Florian,

"pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> writes:

Toggle quote (3 lines)
> Hello Richard, I am hesitant because I cannot reproduce the error and it
> might be better to fix it rather than document it. Looking at,

I can't reliably reproduce the error myself. It simply "comes up" every
now and then if I switch between branches with an existing build and try
rebuilding Guix and rerunning the tests. Agreed, a fix would be
preferred. I have absolutely no idea how.

Toggle quote (7 lines)
> I do not understand Guix well enough why this could happen. Since `make
> clean-go` helps, the cause must be in Guix’ .go files and not some
> cache. In Makefile.am, the check-system target depends on $(GOBJECTS).
>
> I presume gnu/tests.go and gnu/ci.go should be added to GOBJECTS?
> Or gnu/tests.scm and gnu/ci.scm should be added to MODULES?

I don't believe the issue is limited to those two files in particular
(although it could be). That just happened to be the file causing the
problem when I caught the error and pasted it in the doc.

Toggle quote (2 lines)
> But I do not really understand.

That makes two of us. :)

--
Take it easy,
Richard Sent
Making my computer weirder one commit at a time.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70202@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70202
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch