[PATCH v2 1/1] gnu: Add clojure.java-time.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Steve George
Owner
unassigned
Submitted by
Steve George
Severity
normal
Merged with

Debbugs page

Steve George wrote 1 years ago
(address . 69091@debbugs.gnu.org)(address . guix-patches@gnu.org)(name . Steve George)(address . steve@futurile.net)
866de51f2018bbad4a69a325a062b39d6e845e98.1707900811.git.steve@futurile.net
* gnu/packages/clojure.scm (clojure.java-time): New variable.

Change-Id: Id76d3e073525bff619fddb92096ec99a3917faeb
---
gnu/packages/clojure.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 27fce6f368e..f7c5530e35a 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -661,3 +661,28 @@ (define-public clojure-tools-gitlibs
indicated by git SHAs. This library provides this functionality and also
keeps a cache of git directories and working trees that can be reused.")
(license license:epl1.0)))
+
+(define-public clojure.java-time
+ (package
+ (name "clojure.java-time")
+ (version "1.4.2")
+ (home-page "https://github.com/dm3/clojure.java-time")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rykvgslxaxw6qc1lpv21299d9kx3waj34wi1jvzqlnbs2x1p9fh"))))
+ (build-system clojure-build-system)
+ (arguments
+ `(#:tests? #f ;;FIXME: tests requires math.combinatorics dependency
+ #:doc-dirs '("docs")
+ #:aot-exclude '(#:all)))
+ (synopsis "A Clojure wrapper for Java's @code{java.time} API.")
+ (description "This library wraps Java's @code{java.time} API. It provides
+a set of Clojure functions for dealing with Date-Time without requiring any
+additional packages.")
+ (license license:epl1.0)))

base-commit: b64862e5cb8209c92aa2eff4cec0be328e38c45d
--
2.41.0
Steve George wrote 1 years ago
merging 69091 69119
(address . control@debbugs.gnu.org)
1708271254-1011-bts-steve@futurile.net
merge 69091 69119
thanks
Ludovic Courtès wrote 1 years ago
Re: bug#69119: [PATCH v2 1/1] gnu: Add clojure.java-time.
(name . Steve George)(address . steve@futurile.net)(address . 69091@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)(address . 69119@debbugs.gnu.org)
87cyscd2w4.fsf_-_@gnu.org
Hi Steve,

Did you have a chance to look into Andreas’ comments about this patch?


Ludo’.

Andreas Enge <andreas@enge.fr> skribis:

Toggle quote (16 lines)
> Hello,
>
> according to our naming convention
> https://guix.gnu.org/de/manual/devel/en/html_node/Package-Naming.html
> https://guix.gnu.org/de/manual/devel/en/html_node/Python-Modules.html
> I think the package should be called clojure-java-time (well, this is not
> spelt out precisely, but we could argue by analogy, and by consistency with
> the existing clojure packages).
>
> I know nothing about clojure, but am wondering about two things:
> - There is one other package with #:aot-exclude '(#:all), which gives
> an explanation why the line is there; could you add one here as well?
> - Would it make sense to package math.combinatorics first to enable the
> tests? If we do not test now, I am afraid we will forget it later...
>
> Andreas
Steve George wrote 1 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 69091@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)(address . 69119@debbugs.gnu.org)
ZeSpFh+a2XkGWk8c@t25sg
Hi Ludo,

I got blocked as this patch caused me to look at whether we should be compiling to byte-code by default. I have not been able to achieve consensus so far (and have taken some time off from the thread):


Having been unable to convince others I also asked the Clojure community:


Their perspective is that:

a. We should not byte-code compile libraries (what Clojure calls AOT), but we could do so for tools/apps.
b. We should not package libraries at all

From both interactions I'm unsure if packaging this (or any other Clojure libs/tools) is the right move.

Steve

On 2 Mar, Ludovic Courtès wrote:
Toggle quote (26 lines)
> Hi Steve,
>
> Did you have a chance to look into Andreas’ comments about this patch?
>
> https://issues.guix.gnu.org/69119
>
> Ludo’.
>
> Andreas Enge <andreas@enge.fr> skribis:
>
> > Hello,
> >
> > according to our naming convention
> > https://guix.gnu.org/de/manual/devel/en/html_node/Package-Naming.html
> > https://guix.gnu.org/de/manual/devel/en/html_node/Python-Modules.html
> > I think the package should be called clojure-java-time (well, this is not
> > spelt out precisely, but we could argue by analogy, and by consistency with
> > the existing clojure packages).
> >
> > I know nothing about clojure, but am wondering about two things:
> > - There is one other package with #:aot-exclude '(#:all), which gives
> > an explanation why the line is there; could you add one here as well?
> > - Would it make sense to package math.combinatorics first to enable the
> > tests? If we do not test now, I am afraid we will forget it later...
> >
> > Andreas
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69119@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69119
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help