[PATCH] Add rdfind package

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Noé LOPEZ
  • Tomás Ortín
Owner
unassigned
Submitted by
Noé LOPEZ
Severity
normal
Merged with
N
N
Noé LOPEZ wrote on 31 Jan 17:38 +0100
(address . guix-patches@gnu.org)
f54030f9d5941ff9f1c4313729486912@free.fr
Hi,

Here's a patch to add a package for rdfind.

Good evening,
Noé Lopez
From bf43dbbaf9ebaa33be609f291f1bdc9aad07fe13 Mon Sep 17 00:00:00 2001
Message-ID: <bf43dbbaf9ebaa33be609f291f1bdc9aad07fe13.1706718647.git.noelopez@free.fr>
From: =?UTF-8?q?No=C3=A9=20Lopez?= <noelopez@free.fr>
Date: Wed, 31 Jan 2024 17:26:07 +0100
Subject: [PATCH] gnu: Add rdfind.

* gnu/packages/rdfind.scm: Add rdfind.

Change-Id: I0666a68a3a457326a329ba41bf6eba92b71eccbb
---
gnu/packages/rdfind.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
create mode 100644 gnu/packages/rdfind.scm

Toggle diff (38 lines)
diff --git a/gnu/packages/rdfind.scm b/gnu/packages/rdfind.scm
new file mode 100644
index 0000000000..810f96c602
--- /dev/null
+++ b/gnu/packages/rdfind.scm
@@ -0,0 +1,28 @@
+(define-module (gnu packages rdfind)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (gnu packages nettle)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses))
+
+(define-public rdfind
+ (package
+ (name "rdfind")
+ (version "1.6.0")
+ (inputs (list nettle))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://rdfind.pauldreik.se/rdfind-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0y9j1w3nbgjks0k4kgm6qq92yrwgv66n212ncmlmhsl8y676wh3s"))))
+ (build-system gnu-build-system)
+ ;; Need to delete check because it tries to use /bin/echo
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check))))
+ (synopsis "Find duplicate files utility")
+ (description "Rdfind is a command line tool that finds duplicate files.")
+ (home-page "https://rdfind.pauldreik.se/")
+ (license gpl2+)))

base-commit: 7a45f7b9e1b34912ee087daf4014aa4f67b11bf0
--
2.41.0
T
T
Tomás Ortín wrote on 7 Feb 12:44 +0100
(no subject)
(address . 68854@debbugs.gnu.org)
29958b87-9025-666c-5f87-24a6362b66c4@mailbox.org
Hello Noe, I already sent a patch to add rdfind some time ago:

I point it out more than anything so you can take a look at a way to
deal with issues such as the attempt to call "/bin/echo" without
disabling tests.
Also, tests can be disabled by passing "#:tests? #f", no need to delete
the phase :-)
L
L
Ludovic Courtès wrote on 20 Feb 10:52 +0100
control message for bug #67363
(address . control@debbugs.gnu.org)
87frxnmphr.fsf@gnu.org
merge 67363 68854
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68854@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68854
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch