[PATCH] Add rdfind

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomás Ortín
Owner
unassigned
Submitted by
Tomás Ortín
Severity
normal
Merged with
T
T
Tomás Ortín wrote on 22 Nov 2023 11:04
(address . guix-patches@gnu.org)
f0aebb7a-4387-9e7e-66b2-f780090c9bc9@mailbox.org
* gnu/packages/admin.scm (rdfind): New variable.

Change-Id: Ie25bb6b8f5f9a3942eec8d9346da99d73e3bf1dd
---
gnu/packages/admin.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 17225863d7..c8cf375f49 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -61,6 +61,7 @@
;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Tobias Kortkamp <tobias.kortkamp@gmail.com>
+;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -148,6 +149,7 @@ (define-module (gnu packages admin)
#:use-module (gnu packages mcrypt)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages nettle)
#:use-module (gnu packages networking)
#:use-module (gnu packages openldap)
#:use-module (gnu packages package-management)
@@ -6038,3 +6040,34 @@ (define-public bfs
versions of command{find}, including POSIX, GNU, and *BSD find.")
(home-page "https://tavianator.com/projects/bfs.html")
(license license:bsd-0)))
+
+(define-public rdfind
+ (package
+ (name "rdfind")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://rdfind.pauldreik.se/" name "-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0y9j1w3nbgjks0k4kgm6qq92yrwgv66n212ncmlmhsl8y676wh3s"))))
+ (build-system gnu-build-system)
+ (native-inputs (list which))
+ (inputs (list nettle))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda _
+ (display (which "echo"))
+ (substitute* "testcases/common_funcs.sh"
+ (("/bin/echo")
+ (which "echo"))))))))
+ (home-page "https://rdfind.pauldreik.se")
+ (synopsis "Find duplicate files")
+ (description
+ "Rdfind is a command line tool that finds duplicate files based on
+their content instead of their file names. It is useful for compressing
+backup directories or just finding duplicate files.")
+ (license license:gpl2+)))

base-commit: d20ece07dbb09382f361c8bbf0bcab9e83d8b73e
--
2.41.0
L
L
Ludovic Courtès wrote on 20 Feb 10:52 +0100
control message for bug #67363
(address . control@debbugs.gnu.org)
87frxnmphr.fsf@gnu.org
merge 67363 68854
quit
L
L
Ludovic Courtès wrote on 20 Feb 10:56 +0100
Re: [bug#67363] [PATCH] Add rdfind
(name . Tomás Ortín)(address . tomasortin@mailbox.org)(address . 67363-done@debbugs.gnu.org)
87bk8bmpcf.fsf@gnu.org
Tomás Ortín <tomasortin@mailbox.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/admin.scm (rdfind): New variable.
>
> Change-Id: Ie25bb6b8f5f9a3942eec8d9346da99d73e3bf1dd

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67363@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67363
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch