[PATCH 0/1] scripts: size: Add ‘system’ argument to ‘ensure-store-item’.

  • Open
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 13 Jan 08:25 +0100
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1705127855.git.hako@ultrarare.space
This patch is a follow-up to https://issues.guix.gnu.org/68363.

Since the issue hasn't been found for a long time, I think it's better to pass
the system explicitly.

Thanks

Hilton Chain (1):
scripts: size: Add ‘system’ argument to ‘ensure-store-item’.

guix/scripts/size.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)


base-commit: c0b303aaa3d6154acbe054120d11467eb98e6d33
--
2.41.0
H
H
Hilton Chain wrote on 13 Jan 08:29 +0100
[PATCH 1/1] scripts: size: Add ‘system’ argument to ‘ensure-store-item’.
(address . 68420@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
bb8fa8defba6b656280a2f59f5291789965fbd0f.1705127855.git.hako@ultrarare.space
This is a follow-up to c245a54aab348642178129a9aad501b81a3089b4.

‘%current-system’ is already parameterized within ‘run-with-store’, the root
cause is that ‘mlet*’ bindings are evaluated before the parameterization.

* guix/scripts/size.scm (ensure-store-item): Add ‘system’ argument and pass it
to ‘package->derivation’.
(guix-size): Adjust accordingly.

Change-Id: I910af7c137737bcd0ee079e57a81c4114ab5ae32
---
guix/scripts/size.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/guix/scripts/size.scm b/guix/scripts/size.scm
index 8a8676a16f..0603c0498a 100644
--- a/guix/scripts/size.scm
+++ b/guix/scripts/size.scm
@@ -168,7 +168,7 @@ (define (store-profile items)
(return (profile item size dependencies)))))
sizes)))

-(define* (ensure-store-item spec-or-item)
+(define* (ensure-store-item spec-or-item #:optional (system (%current-system)))
"Return a store file name. If SPEC-OR-ITEM is a store file name, return it
as is. Otherwise, assume SPEC-OR-ITEM is a package output specification such
as \"guile:debug\" or \"gcc-4.8\" and return its store file name."
@@ -177,7 +177,7 @@ (define* (ensure-store-item spec-or-item)
(return spec-or-item)
(let-values (((package output)
(specification->package+output spec-or-item)))
- (mlet %store-monad ((drv (package->derivation package)))
+ (mlet %store-monad ((drv (package->derivation package system)))
;; Note: we don't try building DRV like 'guix archive' does
;; because we don't have to since we can instead rely on
;; substitute meta-data.
@@ -317,8 +317,7 @@ (define-command (guix-size . args)
;; Turn off grafts because (1) substitute servers do not serve grafted
;; packages, and (2) they do not make any difference on the
;; resulting size.
- (parameterize ((%graft? #f)
- (%current-system system))
+ (parameterize ((%graft? #f))
(with-store store
(set-build-options store
#:use-substitutes? #t
@@ -326,7 +325,9 @@ (define-command (guix-size . args)

(run-with-store store
(mlet* %store-monad ((items (mapm %store-monad
- ensure-store-item files))
+ (cut ensure-store-item <>
+ system)
+ files))
(profile (store-profile items)))
(if map-file
(begin
--
2.41.0
M
M
Mathieu Othacehe wrote on 13 Jan 10:36 +0100
Re: [bug#68420] [PATCH 1/1] scripts: size: Add ‘sys tem’ argument to ‘ensure-store-item’.
(name . Hilton Chain)(address . hako@ultrarare.space)
8734v1inh6.fsf@gnu.org
Hey,

Toggle quote (2 lines)
> -(define* (ensure-store-item spec-or-item)

When I have a look to the derivation that is computed in that procedure,
it looks like it has the expected system (the one passed as a cli
argument). Do you have any evidence of `guix size` doing the wrong thing
after c245a54aab?

Thanks,

Mathieu
H
H
Hilton Chain wrote on 1 Feb 07:02 +0100
Re: [bug#68420] [PATCH 1/1] scripts: size: Add ‘ system’ argument to ‘ensure-store-it em’.
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
87mssk4t95.wl-hako@ultrarare.space
Hi Mathieu,

On Sat, 13 Jan 2024 17:36:37 +0800,
Mathieu Othacehe wrote:
Toggle quote (11 lines)
>
>
> Hey,
>
> > -(define* (ensure-store-item spec-or-item)
>
> When I have a look to the derivation that is computed in that procedure,
> it looks like it has the expected system (the one passed as a cli
> argument). Do you have any evidence of `guix size` doing the wrong thing
> after c245a54aab?

Sorry for the confusion, c245a54aab did fix the issue, I should remove the
"follow-up" line in the commit message.

This patch is more of a style change:

Since system has been passed to ‘run-with-store’ and parameterized within it, we
only have to deal with the ‘mlet*’ bindings which are evaluated earlier.

For this specefic case, only ‘ensure-store-item’ used in ‘mlet*’ bindings needs
the system, so we can simply handle it there. And I think parameterizing system
around ‘run-with-store’ again made the procedure less clear.

Thanks
?