[PATCH] size: fix `guix size` with system arg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 10 Jan 08:24 +0100
(address . guix-patches@gnu.org)
b36ede93bbd046dad59bcd9b9b959d15852d101b.1704871440.git.zhengjunjie@iscas.ac.cn
guix/scripts/size.scm(guix-size): parameterize %current-system.

Change-Id: Ia0c1ebff4397aa211f73360925f7c688d59b515a
---
guix/scripts/size.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/guix/scripts/size.scm b/guix/scripts/size.scm
index d26ed98388..8a8676a16f 100644
--- a/guix/scripts/size.scm
+++ b/guix/scripts/size.scm
@@ -317,7 +317,8 @@ (define-command (guix-size . args)
;; Turn off grafts because (1) substitute servers do not serve grafted
;; packages, and (2) they do not make any difference on the
;; resulting size.
- (parameterize ((%graft? #f))
+ (parameterize ((%graft? #f)
+ (%current-system system))
(with-store store
(set-build-options store
#:use-substitutes? #t

base-commit: 9018c6af4907c4532a95017df9f45d9439c30064
prerequisite-patch-id: 04bf8c9efad61111b0e3334c0a5a12d2b468c385
--
2.41.0
M
M
Mathieu Othacehe wrote on 12 Jan 17:26 +0100
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
87zfxaplgl.fsf@gnu.org
Toggle quote (2 lines)
> guix/scripts/size.scm(guix-size): parameterize %current-system.

Seems to work fine!

Applied, thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68363@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68363
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch