Inconsistent use of space before ellipsis

  • Open
  • quality assurance status badge
Details
5 participants
  • Adriel Dumas--Jondeau
  • Ludovic Courtès
  • pelzflorian (Florian Pelz)
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 10 Nov 2023 10:12
(address . bug-guix@gnu.org)
87wmuq9dfy.fsf@elephly.net
When running “guix shell python python-numpy” we see output like this:

Toggle snippet (14 lines)
applying 3 grafts for python-pytest-bootstrap-7.1.3 ...
applying 9 grafts for libxslt-1.1.37 ...
applying 6 grafts for python-lxml-4.9.1 ...
waiting for locks or build slots...
applying 4 grafts for python-xmlschema-1.2.5 ...
applying 7 grafts for python-pytest-7.1.3 ...
applying 11 grafts for python-numpy-1.23.2 ...
building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building directory of Info manuals...
building profile with 2 packages...

Note the inconsistency in whether we separate the ellipses from the
preceding text with a space or not.

--
Ricardo
S
S
Simon Tournier wrote on 16 Nov 2023 10:43
86r0kqvxsa.fsf@gmail.com
Hi,

On Fri, 10 Nov 2023 at 10:12, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (18 lines)
> --8<---------------cut here---------------start------------->8---
> applying 3 grafts for python-pytest-bootstrap-7.1.3 ...
> applying 9 grafts for libxslt-1.1.37 ...
> applying 6 grafts for python-lxml-4.9.1 ...
> waiting for locks or build slots...
> applying 4 grafts for python-xmlschema-1.2.5 ...
> applying 7 grafts for python-pytest-7.1.3 ...
> applying 11 grafts for python-numpy-1.23.2 ...
> building CA certificate bundle...
> listing Emacs sub-directories...
> building fonts directory...
> building directory of Info manuals...
> building profile with 2 packages...
> --8<---------------cut here---------------end--------------->8---
>
> Note the inconsistency in whether we separate the ellipses from the
> preceding text with a space or not.

Well, to my knowledge, the typographical rule is not clear depending on
some style; without going to USA vs UK vs ….

For consistency, I suggest the rule: ’word...’ and not ’word ...’

Something like the patch attached.
Toggle diff (15 lines)
diff --git a/guix/status.scm b/guix/status.scm
index fd89ba9dd3..0ed6d3318a 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -494,8 +494,8 @@ (define* (print-build-event event old-status status
(let ((count (match (assq-ref properties 'graft)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "applying ~a graft for ~a ..."
- "applying ~a grafts for ~a ..."
+ (format port (info (N_ "applying ~a graft for ~a..."
+ "applying ~a grafts for ~a..."
count))
count
(string-drop-right (store-path-package-name drv)
WDYT?

Cheers,
simon
P
P
pelzflorian (Florian Pelz) wrote on 16 Nov 2023 15:09
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
878r6xhjsv.fsf@pelzflorian.de
Simon Tournier <zimon.toutoune@gmail.com> writes:
Toggle quote (4 lines)
> For consistency, I suggest the rule: ’word...’ and not ’word ...’
>
> Something like the patch attached.

+1

This is more consistent. Looking at the translation files in po/guix,
only guix/status.scm:568 uses the space before ellipsis. The message
"applying ~a graft" does not occur in the manual, so it does not need
changing.

(match event
[…]
(('download-started item uri _ ...)
(when print-urls?
(erase-current-line*)
(format port (info (G_ "downloading from ~a ...")) uri)
(newline port)))

Should we keep this space? Perhaps keep it; it is clearer where the
URI ends.

Regards,
Florian
L
L
Ludovic Courtès wrote on 17 Nov 2023 16:47
(name . pelzflorian (Florian Pelz))(address . pelzflorian@pelzflorian.de)
87fs14nzzt.fsf@gnu.org
Hi,

"pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> skribis:

Toggle quote (7 lines)
> Simon Tournier <zimon.toutoune@gmail.com> writes:
>> For consistency, I suggest the rule: ’word...’ and not ’word ...’
>>
>> Something like the patch attached.
>
> +1

+1!

Toggle quote (11 lines)
> (match event
> […]
> (('download-started item uri _ ...)
> (when print-urls?
> (erase-current-line*)
> (format port (info (G_ "downloading from ~a ...")) uri)
> (newline port)))
>
> Should we keep this space? Perhaps keep it; it is clearer where the
> URI ends.

Yes, we should keep this one: somebody added it on the grounds that it
allowed them to click on URLs in their terminal and get the correct URL,
without the period.

Ludo’.
A
A
Adriel Dumas--Jondeau wrote on 19 Nov 2023 17:55
[PATCH] guix: status: Fix ellipsis inconsistencies.
(address . 67038@debbugs.gnu.org)
44b644651d0cc182b89b8bbb7198f958db7c6666.1700412533.git.leirda@disroot.org
Reported by Ricardo Wurmus.

* guix/status.scm (print-build-event): Fix ellipsis inconsistencies.
---
guix/status.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

We just made this patch after Capitole du Libre at Toulouse as an example for
my first patch \o/

Toggle diff (19 lines)
diff --git a/guix/status.scm b/guix/status.scm
index fd89ba9dd3..0ed6d3318a 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -494,8 +494,8 @@ (define* (print-build-event event old-status status
(let ((count (match (assq-ref properties 'graft)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "applying ~a graft for ~a ..."
- "applying ~a grafts for ~a ..."
+ (format port (info (N_ "applying ~a graft for ~a..."
+ "applying ~a grafts for ~a..."
count))
count
(string-drop-right (store-path-package-name drv)

base-commit: 761810d32a0550912b5bb36a0c9f60141bcb7d20
--
2.41.0
S
S
Simon Tournier wrote on 20 Nov 2023 10:50
control message for bug #67038
(address . control@debbugs.gnu.org)
864jhg3g8u.fsf@gmail.com
tags 67038 + patch
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67038@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67038
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch