Hi,
On Fri, 10 Nov 2023 at 10:12, Ricardo Wurmus <rekado@elephly.net> wrote:
Toggle quote (18 lines)
> --8<---------------cut here---------------start------------->8---
> applying 3 grafts for python-pytest-bootstrap-7.1.3 ...
> applying 9 grafts for libxslt-1.1.37 ...
> applying 6 grafts for python-lxml-4.9.1 ...
> waiting for locks or build slots...
> applying 4 grafts for python-xmlschema-1.2.5 ...
> applying 7 grafts for python-pytest-7.1.3 ...
> applying 11 grafts for python-numpy-1.23.2 ...
> building CA certificate bundle...
> listing Emacs sub-directories...
> building fonts directory...
> building directory of Info manuals...
> building profile with 2 packages...
> --8<---------------cut here---------------end--------------->8---
>
> Note the inconsistency in whether we separate the ellipses from the
> preceding text with a space or not.
Well, to my knowledge, the typographical rule is not clear depending on
some style; without going to USA vs UK vs ….
For consistency, I suggest the rule: ’word...’ and not ’word ...’
Something like the patch attached.
Toggle diff (15 lines)
diff --git a/guix/status.scm b/guix/status.scm
index fd89ba9dd3..0ed6d3318a 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -494,8 +494,8 @@ (define* (print-build-event event old-status status
(let ((count (match (assq-ref properties 'graft)
(#f 0)
(lst (or (assq-ref lst 'count) 0)))))
- (format port (info (N_ "applying ~a graft for ~a ..."
- "applying ~a grafts for ~a ..."
+ (format port (info (N_ "applying ~a graft for ~a..."
+ "applying ~a grafts for ~a..."
count))
count
(string-drop-right (store-path-package-name drv)