[PATCH] gnu: wine-staging: Update to 8.18.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal

Debbugs page

Kaelyn Takata wrote 1 years ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
0c40b27e0ae5c9d46aae0c578485e520d85bcea8.1699128205.git.kaelyn.alexi@protonmail.com
* gnu/packages/wine.scm (wine-staging): Update to 8.18.

Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
---
gnu/packages/wine.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..ca06e264dc 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -304,7 +304,7 @@ (define-public wine64
(define-public wine-staging-patchset-data
(package
(name "wine-staging-patchset-data")
- (version "8.0")
+ (version "8.18")
(source
(origin
(method git-fetch)
@@ -313,7 +313,7 @@ (define-public wine-staging-patchset-data
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
+ (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
(build-system trivial-build-system)
(native-inputs
(list bash coreutils))
@@ -330,10 +330,7 @@ (define-public wine-staging-patchset-data
(wine-staging (string-append out "/share/wine-staging")))
(copy-recursively source build-directory)
(with-directory-excursion build-directory
- (substitute* "patches/patchinstall.sh"
- (("/bin/sh")
- (string-append bash "/bin/sh")))
- (substitute* "patches/gitapply.sh"
+ (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
(("/usr/bin/env")
(string-append coreutils "/bin/env"))))
(copy-recursively build-directory wine-staging)
@@ -363,7 +360,7 @@ (define-public wine-staging
"wine-" wine-version ".tar.xz"))
(file-name (string-append name "-" wine-version ".tar.xz"))
(sha256
- (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
+ (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
(inputs (modify-inputs (package-inputs wine)
(prepend autoconf ; for autoreconf
ffmpeg
@@ -373,6 +370,9 @@ (define-public wine-staging
python
util-linux ; for hexdump
wine-staging-patchset-data)))
+ (native-inputs
+ (modify-inputs (package-native-inputs wine)
+ (prepend python-3)))
(arguments
(substitute-keyword-arguments (package-arguments wine)
((#:phases phases)
@@ -382,7 +382,7 @@ (define-public wine-staging
(lambda* (#:key inputs #:allow-other-keys)
(invoke (search-input-file
inputs
- "/share/wine-staging/patches/patchinstall.sh")
+ "/share/wine-staging/staging/patchinstall.py")
"DESTDIR=."
"--all")))
(add-after 'apply-wine-staging-patches 'patch-SHELL
@@ -417,7 +417,7 @@ (define-public wine64-staging
(lambda* (#:key inputs #:allow-other-keys)
(invoke (search-input-file
inputs
- "/share/wine-staging/patches/patchinstall.sh")
+ "/share/wine-staging/staging/patchinstall.py")
"DESTDIR=."
"--all")))
(add-after 'apply-wine-staging-patches 'patch-SHELL

base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
752670b2c89e20e2044c7182f9f6a8779f40e215.camel@gmail.com
Am Samstag, dem 04.11.2023 um 20:03 +0000 schrieb Kaelyn Takata:
Toggle quote (1 lines)
> * gnu/packages/wine.scm (wine-staging): Update to 8.18.
This ChangeLog falls short of other changes you make, presumably to
keep the package building. In particular:

Toggle quote (40 lines)
> Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> ---
>  gnu/packages/wine.scm | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> index 400f0e7607..ca06e264dc 100644
> --- a/gnu/packages/wine.scm
> +++ b/gnu/packages/wine.scm
> @@ -304,7 +304,7 @@ (define-public wine64
>  (define-public wine-staging-patchset-data
>    (package
>      (name "wine-staging-patchset-data")
> -    (version "8.0")
> +    (version "8.18")
>      (source
>       (origin
>         (method git-fetch)
> @@ -313,7 +313,7 @@ (define-public wine-staging-patchset-data
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32
> "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> +        (base32
> "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
>      (build-system trivial-build-system)
>      (native-inputs
>       (list bash coreutils))
> @@ -330,10 +330,7 @@ (define-public wine-staging-patchset-data
>                  (wine-staging (string-append out "/share/wine-
> staging")))
>             (copy-recursively source build-directory)
>             (with-directory-excursion build-directory
> -             (substitute* "patches/patchinstall.sh"
> -               (("/bin/sh")
> -                (string-append bash "/bin/sh")))
> -             (substitute* "patches/gitapply.sh"
> +             (substitute* '("patches/gitapply.sh"
> "staging/patchinstall.py")
(wine-staging-patchset-data)[#:builder]: Adjust accordingly.

Note, it appears you no longer need bash for this package, so you might
to even more changes.
Toggle quote (21 lines)
>                 (("/usr/bin/env")
>                  (string-append coreutils "/bin/env"))))
>             (copy-recursively build-directory wine-staging)
> @@ -363,7 +360,7 @@ (define-public wine-staging
>                               "wine-" wine-version ".tar.xz"))
>           (file-name (string-append name "-" wine-version ".tar.xz"))
>           (sha256
> -          (base32
> "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> +          (base32
> "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
>      (inputs (modify-inputs (package-inputs wine)
>                (prepend autoconf ; for autoreconf
>                         ffmpeg
> @@ -373,6 +370,9 @@ (define-public wine-staging
>                         python
>                         util-linux ; for hexdump
>                         wine-staging-patchset-data)))
> +    (native-inputs
> +     (modify-inputs (package-native-inputs wine)
> +       (prepend python-3)))
(wine-staging)[native-inputs]: Add python-3.
Toggle quote (11 lines)
>      (arguments
>       (substitute-keyword-arguments (package-arguments wine)
>         ((#:phases phases)
> @@ -382,7 +382,7 @@ (define-public wine-staging
>                (lambda* (#:key inputs #:allow-other-keys)
>                  (invoke (search-input-file
>                           inputs
> -                         "/share/wine-
> staging/patches/patchinstall.sh")
> +                         "/share/wine-
> staging/staging/patchinstall.py")
[#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
Toggle quote (11 lines)
>                          "DESTDIR=."
>                          "--all")))
>              (add-after 'apply-wine-staging-patches 'patch-SHELL
> @@ -417,7 +417,7 @@ (define-public wine64-staging
>                (lambda* (#:key inputs #:allow-other-keys)
>                  (invoke (search-input-file
>                           inputs
> -                         "/share/wine-
> staging/patches/patchinstall.sh")
> +                         "/share/wine-
> staging/staging/patchinstall.py")
(wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
Toggle quote (6 lines)
>                          "DESTDIR=."
>                          "--all")))
>              (add-after 'apply-wine-staging-patches 'patch-SHELL
>
> base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd

Cheers
Kaelyn wrote 1 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 66936@debbugs.gnu.org)
yFeQ6iGuQ2olk09Eg22jxYPGsR7LQcL-hZs5gJY2bKWgv4DDisJc8APr9zuzmNxRAdHkPZYruTjiiKdkE6d-BGm8a6YhwsLQ8-BSTEilVg0=@protonmail.com
On Sunday, November 5th, 2023 at 1:06 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:


Toggle quote (9 lines)
>
>
> Am Samstag, dem 04.11.2023 um 20:03 +0000 schrieb Kaelyn Takata:
>
> > * gnu/packages/wine.scm (wine-staging): Update to 8.18.
>
> This ChangeLog falls short of other changes you make, presumably to
> keep the package building. In particular:

Thank you for the help in filling out the commit message. For this more complicated patch, I wasn't sure how to word it (the format seems to require breaking down a logical change into almost tediously self-explanatory parts and writing a line for each, in a way that gets a bit confusing to gauge for my brain). I'm sending a v2 of the patch rebased against current master, with bash removed from the wine-staging-patchset-data native-inputs and the commit message expanded with your suggestions (plus noting the bash removal).

Thanks,
Kaelyn

Toggle quote (106 lines)
> > Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> > ---
> > gnu/packages/wine.scm | 18 +++++++++---------
> > 1 file changed, 9 insertions(+), 9 deletions(-)
> >
> > diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> > index 400f0e7607..ca06e264dc 100644
> > --- a/gnu/packages/wine.scm
> > +++ b/gnu/packages/wine.scm
> > @@ -304,7 +304,7 @@ (define-public wine64
> > (define-public wine-staging-patchset-data
> > (package
> > (name "wine-staging-patchset-data")
> > - (version "8.0")
> > + (version "8.18")
> > (source
> > (origin
> > (method git-fetch)
> > @@ -313,7 +313,7 @@ (define-public wine-staging-patchset-data
> > (commit (string-append "v" version))))
> > (file-name (git-file-name name version))
> > (sha256
> > - (base32
> > "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> > + (base32
> > "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
> > (build-system trivial-build-system)
> > (native-inputs
> > (list bash coreutils))
> > @@ -330,10 +330,7 @@ (define-public wine-staging-patchset-data
> > (wine-staging (string-append out "/share/wine-
> > staging")))
> > (copy-recursively source build-directory)
> > (with-directory-excursion build-directory
> > - (substitute* "patches/patchinstall.sh"
> > - (("/bin/sh")
> > - (string-append bash "/bin/sh")))
> > - (substitute* "patches/gitapply.sh"
> > + (substitute* '("patches/gitapply.sh"
> > "staging/patchinstall.py")
>
> (wine-staging-patchset-data)[#:builder]: Adjust accordingly.
>
> Note, it appears you no longer need bash for this package, so you might
> to even more changes.
>
> > (("/usr/bin/env")
> > (string-append coreutils "/bin/env"))))
> > (copy-recursively build-directory wine-staging)
> > @@ -363,7 +360,7 @@ (define-public wine-staging
> > "wine-" wine-version ".tar.xz"))
> > (file-name (string-append name "-" wine-version ".tar.xz"))
> > (sha256
> > - (base32
> > "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> > + (base32
> > "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
> > (inputs (modify-inputs (package-inputs wine)
> > (prepend autoconf ; for autoreconf
> > ffmpeg
> > @@ -373,6 +370,9 @@ (define-public wine-staging
> > python
> > util-linux ; for hexdump
> > wine-staging-patchset-data)))
> > + (native-inputs
> > + (modify-inputs (package-native-inputs wine)
> > + (prepend python-3)))
>
> (wine-staging)[native-inputs]: Add python-3.
>
> > (arguments
> > (substitute-keyword-arguments (package-arguments wine)
> > ((#:phases phases)
> > @@ -382,7 +382,7 @@ (define-public wine-staging
> > (lambda* (#:key inputs #:allow-other-keys)
> > (invoke (search-input-file
> > inputs
> > - "/share/wine-
> > staging/patches/patchinstall.sh")
> > + "/share/wine-
> > staging/staging/patchinstall.py")
>
> [#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
>
> > "DESTDIR=."
> > "--all")))
> > (add-after 'apply-wine-staging-patches 'patch-SHELL
> > @@ -417,7 +417,7 @@ (define-public wine64-staging
> > (lambda* (#:key inputs #:allow-other-keys)
> > (invoke (search-input-file
> > inputs
> > - "/share/wine-
> > staging/patches/patchinstall.sh")
> > + "/share/wine-
> > staging/staging/patchinstall.py")
>
> (wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
>
> > "DESTDIR=."
> > "--all")))
> > (add-after 'apply-wine-staging-patches 'patch-SHELL
> >
> > base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd
>
>
> Cheers
Kaelyn Takata wrote 1 years ago
[PATCH v2] gnu: wine-staging: Update to 8.18.
(address . 66936@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
b9c79e013e3dcb3aeca793745a84931257e287c2.1702145463.git.kaelyn.alexi@protonmail.com
* gnu/packages/wine.scm (wine-staging): Update to 8.18.
(wine-staging-patchset-data)[#:builder]: Adjust accordingly.
[native-inputs]: Drop bash.
(wine-staging)[native-inputs]: Add python-3.
[#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
(wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.

Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
---
gnu/packages/wine.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..48f7499ba2 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -304,7 +304,7 @@ (define-public wine64
(define-public wine-staging-patchset-data
(package
(name "wine-staging-patchset-data")
- (version "8.0")
+ (version "8.18")
(source
(origin
(method git-fetch)
@@ -313,10 +313,10 @@ (define-public wine-staging-patchset-data
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
+ (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
(build-system trivial-build-system)
(native-inputs
- (list bash coreutils))
+ (list coreutils))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -324,16 +324,12 @@ (define-public wine-staging-patchset-data
(use-modules (guix build utils))
(let* ((build-directory ,(string-append name "-" version))
(source (assoc-ref %build-inputs "source"))
- (bash (assoc-ref %build-inputs "bash"))
(coreutils (assoc-ref %build-inputs "coreutils"))
(out (assoc-ref %outputs "out"))
(wine-staging (string-append out "/share/wine-staging")))
(copy-recursively source build-directory)
(with-directory-excursion build-directory
- (substitute* "patches/patchinstall.sh"
- (("/bin/sh")
- (string-append bash "/bin/sh")))
- (substitute* "patches/gitapply.sh"
+ (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
(("/usr/bin/env")
(string-append coreutils "/bin/env"))))
(copy-recursively build-directory wine-staging)
@@ -363,7 +359,7 @@ (define-public wine-staging
"wine-" wine-version ".tar.xz"))
(file-name (string-append name "-" wine-version ".tar.xz"))
(sha256
- (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
+ (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
(inputs (modify-inputs (package-inputs wine)
(prepend autoconf ; for autoreconf
ffmpeg
@@ -373,6 +369,9 @@ (define-public wine-staging
python
util-linux ; for hexdump
wine-staging-patchset-data)))
+ (native-inputs
+ (modify-inputs (package-native-inputs wine)
+ (prepend python-3)))
(arguments
(substitute-keyword-arguments (package-arguments wine)
((#:phases phases)
@@ -382,7 +381,7 @@ (define-public wine-staging
(lambda* (#:key inputs #:allow-other-keys)
(invoke (search-input-file
inputs
- "/share/wine-staging/patches/patchinstall.sh")
+ "/share/wine-staging/staging/patchinstall.py")
"DESTDIR=."
"--all")))
(add-after 'apply-wine-staging-patches 'patch-SHELL
@@ -417,7 +416,7 @@ (define-public wine64-staging
(lambda* (#:key inputs #:allow-other-keys)
(invoke (search-input-file
inputs
- "/share/wine-staging/patches/patchinstall.sh")
+ "/share/wine-staging/staging/patchinstall.py")
"DESTDIR=."
"--all")))
(add-after 'apply-wine-staging-patches 'patch-SHELL

base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
--
2.41.0
Kaelyn wrote 1 years ago
skr2s5GnOWEnRZq0MseWHDZxF83OqNfmnBWt52VB9GZKd_t309vwvkZ6HRPI5SiHQ-eDzMqUbBx1sD_U9mQc8GWQ22oTp0u8gTit-wLd5y4=@protonmail.com
Hi guix-devel,

I just sent out https://issues.guix.gnu.org/68005to remove dxvk 1.5.5, which as far as I can tell has been broken for a few years now (IIRC I tested as far back in guix history as wine-staging 5.13 or 5.22 from 2-3 years ago and still encountered the same errors building dxvk). I wanted to bump this 2+ week old update to wine-staging since dxvk is the only dependent on wine-staging and it does not currently build (and the QA status of bug #66936 is still "Pending").

Cheers,
Kaelyn


On Saturday, December 9th, 2023 at 10:11 AM, Kaelyn Takata <kaelyn.alexi@protonmail.com> wrote:

Toggle quote (100 lines)
>
> * gnu/packages/wine.scm (wine-staging): Update to 8.18.
> (wine-staging-patchset-data)[#:builder]: Adjust accordingly.
> [native-inputs]: Drop bash.
> (wine-staging)[native-inputs]: Add python-3.
> [#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
>
> (wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
>
>
> Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> ---
> gnu/packages/wine.scm | 21 ++++++++++-----------
> 1 file changed, 10 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> index 400f0e7607..48f7499ba2 100644
> --- a/gnu/packages/wine.scm
> +++ b/gnu/packages/wine.scm
> @@ -304,7 +304,7 @@ (define-public wine64
> (define-public wine-staging-patchset-data
> (package
> (name "wine-staging-patchset-data")
> - (version "8.0")
> + (version "8.18")
> (source
> (origin
> (method git-fetch)
> @@ -313,10 +313,10 @@ (define-public wine-staging-patchset-data
> (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> + (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
> (build-system trivial-build-system)
> (native-inputs
> - (list bash coreutils))
> + (list coreutils))
> (arguments
> `(#:modules ((guix build utils))
> #:builder
> @@ -324,16 +324,12 @@ (define-public wine-staging-patchset-data
> (use-modules (guix build utils))
> (let* ((build-directory ,(string-append name "-" version))
> (source (assoc-ref %build-inputs "source"))
> - (bash (assoc-ref %build-inputs "bash"))
> (coreutils (assoc-ref %build-inputs "coreutils"))
> (out (assoc-ref %outputs "out"))
> (wine-staging (string-append out "/share/wine-staging")))
> (copy-recursively source build-directory)
> (with-directory-excursion build-directory
> - (substitute* "patches/patchinstall.sh"
> - (("/bin/sh")
> - (string-append bash "/bin/sh")))
> - (substitute* "patches/gitapply.sh"
> + (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
> (("/usr/bin/env")
> (string-append coreutils "/bin/env"))))
> (copy-recursively build-directory wine-staging)
> @@ -363,7 +359,7 @@ (define-public wine-staging
> "wine-" wine-version ".tar.xz"))
> (file-name (string-append name "-" wine-version ".tar.xz"))
> (sha256
> - (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> + (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
> (inputs (modify-inputs (package-inputs wine)
> (prepend autoconf ; for autoreconf
> ffmpeg
> @@ -373,6 +369,9 @@ (define-public wine-staging
> python
> util-linux ; for hexdump
> wine-staging-patchset-data)))
> + (native-inputs
> + (modify-inputs (package-native-inputs wine)
> + (prepend python-3)))
> (arguments
> (substitute-keyword-arguments (package-arguments wine)
> ((#:phases phases)
> @@ -382,7 +381,7 @@ (define-public wine-staging
> (lambda* (#:key inputs #:allow-other-keys)
> (invoke (search-input-file
> inputs
> - "/share/wine-staging/patches/patchinstall.sh")
> + "/share/wine-staging/staging/patchinstall.py")
> "DESTDIR=."
> "--all")))
> (add-after 'apply-wine-staging-patches 'patch-SHELL
> @@ -417,7 +416,7 @@ (define-public wine64-staging
> (lambda* (#:key inputs #:allow-other-keys)
> (invoke (search-input-file
> inputs
> - "/share/wine-staging/patches/patchinstall.sh")
> + "/share/wine-staging/staging/patchinstall.py")
> "DESTDIR=."
> "--all")))
> (add-after 'apply-wine-staging-patches 'patch-SHELL
>
> base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
> --
> 2.41.0
Liliana Marie Prikler wrote 1 years ago
Re: [PATCH] gnu: wine-staging: Update to 8.18.
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
e96d15c19a7163c3b9ede6674bc0750913eac5df.camel@gmail.com
Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
Toggle quote (4 lines)
> I'm sending a v2 of the patch rebased against current master, with
> bash removed from the wine-staging-patchset-data native-inputs and
> the commit message expanded with your suggestions (plus noting the
> bash removal).
I sadly didn't receive the v2, so I'm commenting here instead.

I've pushed both this and the removal of dxvk now.

Thanks
Closed
Kaelyn wrote 1 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
oDKX5EcXzldqxl5p8K4kUVarjl9EmT0PbZjrj_09wDpybDSmsIeB9WnsnOly-9dxVZvU6ndtZQ63YXQKlGcN-n_r03lzDEe6ZPOfiMkZ_48=@protonmail.com
Hi Liliana,

On Sunday, December 31st, 2023 at 3:34 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (12 lines)
>
> Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
>
> > I'm sending a v2 of the patch rebased against current master, with
> > bash removed from the wine-staging-patchset-data native-inputs and
> > the commit message expanded with your suggestions (plus noting the
> > bash removal).
>
> I sadly didn't receive the v2, so I'm commenting here instead.
>
> I've pushed both this and the removal of dxvk now.

Thank you for pushing these changes!

Cheers,
Kaelyn
Toggle quote (1 lines)
> Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66936@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66936
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help