[PATCH] gnu: Remove dxvk.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 24 Dec 2023 16:35
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
1c689ee56afaafdc94806917952535e74b2a2ba8.1703432060.git.kaelyn.alexi@protonmail.com
This package has been broken for some time, and upstream removed support for
building with winelib in version 1.7 released in May 2020.

* gnu/packages/wine.scm (dxvk): Delete variable.

Change-Id: I393853aa6e0c9257907549f346a36a1fe37a61a0
---
gnu/packages/wine.scm | 84 -------------------------------------------
1 file changed, 84 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..5cbed406aa 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -425,87 +425,3 @@ (define-public wine64-staging
(synopsis "Implementation of the Windows API (staging branch, WoW64
version)")
(supported-systems '("x86_64-linux" "aarch64-linux"))))
-
-(define dxvk32
- ;; This package provides 32-bit dxvk libraries on 64-bit systems.
- (package
- (name "dxvk32")
- (version "1.5.5")
- (home-page "https://github.com/doitsujin/dxvk/")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1inl0qswgvbp0fs76md86ilqf9mbshkpjm8ga81khn9zd6v3fvan"))))
- (build-system meson-build-system)
- (arguments
- `(#:system "i686-linux"
- #:configure-flags (list "--cross-file"
- (string-append (assoc-ref %build-inputs "source")
- "/build-wine32.txt"))))
- (native-inputs
- `(("glslang" ,glslang)))
- (inputs
- `(("wine" ,wine-staging)))
- (synopsis "Vulkan-based D3D9, D3D10 and D3D11 implementation for Wine")
- (description "A Vulkan-based translation layer for Direct3D 9/10/11 which
-allows running complex 3D applications with high performance using Wine.
-
-Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
- (supported-systems '("x86_64-linux"))
- (license license:zlib)))
-
-(define-public dxvk
- (package
- (inherit dxvk32)
- (name "dxvk")
- (arguments
- `(#:configure-flags (list "--cross-file"
- (string-append (assoc-ref %build-inputs "source")
- "/build-wine"
- ,(match (%current-system)
- ("x86_64-linux" "64")
- (_ "32"))
- ".txt"))
- #:phases
- (modify-phases %standard-phases
- ,@(if (string=? (%current-system) "x86_64-linux")
- `((add-after 'unpack 'install-32
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dxvk32 (assoc-ref inputs "dxvk32")))
- (mkdir-p (string-append out "/lib32"))
- (copy-recursively (string-append dxvk32 "/lib")
- (string-append out "/lib32"))
- #t))))
- '())
- (add-after 'install 'install-setup
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/setup_dxvk")))
- (mkdir-p (string-append out "/bin"))
- (copy-file "../source/setup_dxvk.sh"
- bin)
- (chmod bin #o755)
- (substitute* bin
- (("wine=\"wine\"")
- (string-append "wine=" (assoc-ref inputs "wine") "/bin/wine"))
- (("x32") ,(match (%current-system)
- ("x86_64-linux" "../lib32")
- (_ "../lib")))
- (("x64") "../lib"))))))))
- (inputs
- `(("wine" ,(match (%current-system)
- ;; ("x86_64-linux" wine64)
- ("x86_64-linux" wine64-staging)
- ;; ("x86_64-linux" mingw-w64-x86_64)
- (_ wine)))
- ,@(match (%current-system)
- ("x86_64-linux"
- `(("dxvk32" ,dxvk32)))
- (_ '()))))
- (supported-systems '("i686-linux" "x86_64-linux"))))

base-commit: 0d13d095420861022e68e87ceebd5e037e12a8b3
--
2.41.0
L
L
Liliana Marie Prikler wrote on 31 Dec 2023 12:34
Re: [PATCH] gnu: wine-staging: Update to 8.18.
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
e96d15c19a7163c3b9ede6674bc0750913eac5df.camel@gmail.com
Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
Toggle quote (4 lines)
> I'm sending a v2 of the patch rebased against current master, with
> bash removed from the wine-staging-patchset-data native-inputs and
> the commit message expanded with your suggestions (plus noting the
> bash removal).
I sadly didn't receive the v2, so I'm commenting here instead.

I've pushed both this and the removal of dxvk now.

Thanks
Closed
K
K
Kaelyn wrote on 31 Dec 2023 17:47
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
oDKX5EcXzldqxl5p8K4kUVarjl9EmT0PbZjrj_09wDpybDSmsIeB9WnsnOly-9dxVZvU6ndtZQ63YXQKlGcN-n_r03lzDEe6ZPOfiMkZ_48=@protonmail.com
Hi Liliana,

On Sunday, December 31st, 2023 at 3:34 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (12 lines)
>
> Am Samstag, dem 09.12.2023 um 18:11 +0000 schrieb Kaelyn:
>
> > I'm sending a v2 of the patch rebased against current master, with
> > bash removed from the wine-staging-patchset-data native-inputs and
> > the commit message expanded with your suggestions (plus noting the
> > bash removal).
>
> I sadly didn't receive the v2, so I'm commenting here instead.
>
> I've pushed both this and the removal of dxvk now.

Thank you for pushing these changes!

Cheers,
Kaelyn
Toggle quote (1 lines)
> Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68005@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68005
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch