[PATCH] add ani-cli package

  • Done
  • quality assurance status badge
Details
3 participants
  • Jaeme Sifat
  • Tobias Geerinckx-Rice
  • Nicolas Débonnaire
Owner
unassigned
Submitted by
Nicolas Débonnaire
Severity
normal
Merged with
N
N
Nicolas Débonnaire wrote on 23 Oct 2023 18:45
(address . guix-patches@gnu.org)
CANOKM3cw24mYPa0JVZWuxByFHYhsrFb=tmv4+trgAOZYi5tcFA@mail.gmail.com
Toggle diff (50 lines)
diff --git a/gnu/packages/ani-cli.scm b/gnu/packages/ani-cli.scm
new file mode 100644
index 0000000000..ceef971267
--- /dev/null
+++ b/gnu/packages/ani-cli.scm
@@ -0,0 +1,43 @@
+(define-module (gnu packages ani-cli)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages terminals)
+ #:use-module (guix build-system copy))
+
+(define-public ani-cli
+ (let ((commit "c7e6838647b57411d791bd250417eb0925d74cca")
+ (revision "0"))
+ (package
+ (name "ani-cli")
+ (version (git-version "4.6" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pystardust/ani-cli")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
"1ni9pzjb5qh87iz7c8252bx79qadr1qx6jnkqvvjcqrchh7q473a"))))
+ (build-system copy-build-system)
+ (propagated-inputs (list yt-dlp
+ curl
+ fzf
+ mpv
+ sed
+ grep))
+ (arguments
+ `(#:install-plan '(("ani-cli" "bin/")
+ ("ani-cli.1" "share/man/man1/"))))
+ (home-page "https://github.com/pystardust/ani-cli")
+ (synopsis "Browse and watch anime from the terminal")
+ (description
+ "ani-cli is a command-line interface (cli) to browse and watch anime
+ (alone AND with friends). It scrapes the site allanime and open videos
+ in mpv audio and video player. There is different features such as
+episode browsing, history tracking,...")
+ (license gpl3))))
Attachment: file
N
T
T
Tobias Geerinckx-Rice wrote on 28 Oct 2023 23:35
(no subject)
(address . control@debbugs.gnu.org)
53f34a671881e12f5e5e4d47502b5469@tobias.gr
merge 66694 66708
J
J
Jaeme Sifat wrote on 28 Nov 2023 15:27
(address . control@debbugs.gnu.org)
8538929f-5400-45c5-a4c7-fd07086fc761@runbox.com
close 66694
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66708@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66708
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch